Bug 1135132 - [RFE] Add OpenStack Cinder storage domains with Ceph backend
Summary: [RFE] Add OpenStack Cinder storage domains with Ceph backend
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Daniel Erez
QA Contact: Ori Gofen
URL:
Whiteboard:
Depends On: 1437392 1160653 1185826 1201211 1252958 1254470 1255221 1258932 1264677 1270725 1270772 1297919 1299513 1570420 1574364
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-28 21:42 UTC by Federico Simoncelli
Modified: 2019-10-10 09:23 UTC (History)
12 users (show)

Fixed In Version: ovirt-engine-3.6.0_alpha3
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1185826 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:37:39 UTC
oVirt Team: Storage
sherold: Triaged+
ylavi: testing_beta_priority+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
Launchpad 1485897 None None None 2016-01-11 12:16:04 UTC

Description Federico Simoncelli 2014-08-28 21:42:26 UTC
Description of problem:
oVirt should be able to manage and consume Ceph volumes through OpenStack Cinder.

Comment 1 Ori Gofen 2015-08-13 10:00:44 UTC
plans to be executed:
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_5_Storage_Live_Merge
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_1_Storage_Live_Snapshot
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_1_Storage_HotPlug_Disk
https//polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_1_Storage_HotPlug_Negative
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_4_Storage_HotPlug
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_4_Storage_Single_Snapshot
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_5_Storage_Allow_Online_Vdisk_Editing
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_5_Storage_Live_Merge
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/2_3_Storage_Cloned_VM_From_Template_Negative
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/2_3_Storage_Templates_General
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_6_Storage_VM_Sanity
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_6_Storage_Sanity%20_without%20SPM%20ans%20master%20domain_
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_6_Storage_Floating_Disk_General
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_6_Storage_Floating_Disk_General
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_6_Storage_Domain_Maintenance_Mode
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_6_Storage_Decommission_Master_Domain_and_SPM
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/workitems/requirement?query=categories.id:storage

Comment 2 Ori Gofen 2015-09-01 15:11:06 UTC
First test run, "3_6_Storage_Ceph_Negative" 

Passed 5
Failed 3
Executed 8

please browse to:
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/testrun?id=3_6_Storage_Ceph_Negative_ogofen&tab=records

Comment 3 Ori Gofen 2015-09-02 13:14:43 UTC
Second test run "3_6_Storage_Templates_On_Ceph" is currently blocked
by bz #1252958 myself and derez have investigated this issue and it is most likely to be a build regression which is already fixed at rhevm3.6-13.noarch

https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/2_3_Storage_Templates_General?query=NOT%20type:heading%20AND%20%28NOT%20TEST_RECORDS:%28%22RHEVM3/2_3_Storage_Templates_General_on_ceph%22,@any%29%29&tree_depth=0&tab=tree

Comment 9 Aharon Canan 2016-01-25 12:52:16 UTC
We tested all the flows and everything was verified except the snapshots part which is known issue from Cinder (https://bugs.launchpad.net/bugs/1485897)

We still have some bugs to verify.
Marking it as verified.

Comment 12 errata-xmlrpc 2016-03-09 20:37:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.