Bug 1139298 - Augeas cannot parse or set 'ssh' in kdump.conf
Summary: Augeas cannot parse or set 'ssh' in kdump.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: augeas
Version: 7.1
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 7.1
Assignee: Dominic Cleal
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1175854 1175856 1180371 1181280
TreeView+ depends on / blocked
 
Reported: 2014-09-08 15:10 UTC by Ryan Barry
Modified: 2015-03-05 09:25 UTC (History)
5 users (show)

Fixed In Version: augeas-1.1.0-14.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1181280 (view as bug list)
Environment:
Last Closed: 2015-03-05 09:25:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0399 normal SHIPPED_LIVE augeas bug fix and enhancement update 2015-03-05 14:17:57 UTC

Description Ryan Barry 2014-09-08 15:10:58 UTC
Description of problem:
Augeas cannot parse or set 'ssh' in kdump.conf

Version-Release number of selected component (if applicable):
augeas-1.1.0-12.el7

How reproducible:
Always

Steps to Reproduce:
1. Try to set "/files/etc/kdump.conf/ssh any_value"
2. Unable to save

Actual results:
print /augeas//error
/augeas/files/etc/kdump.conf/error = "put_failed"
/augeas/files/etc/kdump.conf/error/path = "/files/etc/kdump.conf"
/augeas/files/etc/kdump.conf/error/lens "/usr/share/augeas/lenses/dist/kdump.cug:71.10-.39"
/augeas/files/etc/kdump.conf/error/message = "Malformed child node 'ssh'"

Expected results:
augeas works with 'ssh' parameters to kdump.conf

Additional info:
This is passable with the 'net' options, but 'net' is deprecated. 'nfs' has been replaced in augeas, but 'ssh' does not work.

Comment 2 Dominic Cleal 2014-09-09 10:23:02 UTC
Fixed in 0951590, a8d43f6

Comment 4 Ryan Barry 2014-09-28 16:00:46 UTC
Requesting a backport to 7.0.z

kdumpctl refuses to propagate with "net" in RHEL7. "ssh" must be set.

Comment 6 jiyu 2014-10-13 02:28:40 UTC
Verified with augeas-1.1.0-16.el7.x86_64

Steps to verify:
1. Add line "ssh any_value" to file /etc/kdump.conf

2. #echo 'print /augeas//error'|augtool
<no output>

parse successfully, so bug is fixed

Comment 7 Ryan Barry 2015-01-09 18:12:58 UTC
If possible, a Z-stream clone to 7.0 would be great.

Comment 11 errata-xmlrpc 2015-03-05 09:25:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0399.html


Note You need to log in before you can comment on or make changes to this bug.