Bug 1140865 - can't find Roman font in urw-fonts-1.10-1.fc22
Summary: can't find Roman font in urw-fonts-1.10-1.fc22
Keywords:
Status: CLOSED DUPLICATE of bug 1160132
Alias: None
Product: Fedora
Classification: Fedora
Component: urw-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1142817
TreeView+ depends on / blocked
 
Reported: 2014-09-11 21:28 UTC by Michael Young
Modified: 2014-11-28 14:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-28 14:22:31 UTC


Attachments (Terms of Use)
patched to new font names (11.70 KB, text/plain)
2014-10-24 09:59 UTC, Tom Yan
no flags Details
git diff (2.95 KB, patch)
2014-10-24 10:02 UTC, Tom Yan
no flags Details | Diff

Description Michael Young 2014-09-11 21:28:53 UTC
I am trying to build xen on rawhide, but when it tries to run fig2dev it fails and the build aborts. The relevant lines in the log are

/usr/bin/fig2dev -L png network-bridge.fig >network-bridge.png.tmp
GPL Ghostscript 9.14: Unrecoverable error, exit code 1
Error in ghostcript command
command was: gs -q -dSAFER -sDEVICE=png16m -r80 -g710x553 -sOutputFile=- -

fig2dev defaults to Roman, and the command works with the urw-fonts-2.4-19.fc21 but not with urw-fonts-1.10-1.fc22 and I think it is because it can't find the Roman font.

Comment 1 Michael Young 2014-09-14 15:13:07 UTC
I have investigated this further, and the issue is between ghostscript and urw-fonts. Ghostscript has the file /usr/share/ghostscript/9.14/Resource/Init/Fontmap.GS which translates well known font names (Times-Roman, Helvetica etc.) into the OS font name. Unfortunately urw-fonts has changed the name of many of these fonts so ghostscript translates such fonts into names that no longer exist.

Comment 2 Jerry James 2014-10-21 18:45:41 UTC
Is any fix for this on the horizon?  I'm now hitting this problem when trying to build a new version of the remake package:

Error: /invalidfont in /findfont
Operand stack:
   boxfont   Times-Roman
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval-
-   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   fa
lse   1   %stopped_push   1951   1   3   %oparray_pop   1950   1   3   %oparray_
pop   --nostringval--   1934   1   3   %oparray_pop   1820   1   3   %oparray_po
p   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringv
al--   --nostringval--   2   %stopped_push   --nostringval--   1903   2   3   %o
parray_pop
Dictionary stack:
   --dict:1185/1684(ro)(G)--   --dict:0/20(G)--   --dict:95/200(L)--
Current allocation mode is local
Last OS error: Not a directory
GPL Ghostscript 9.15: Unrecoverable error, exit code 1
epstopdf ($Id: epstopdf.pl 32701 2014-01-17 18:09:54Z karl $) 2.21
!!! Error: Writing to gs failed, error code 1
error: Problems running epstopdf. Check your TeX installation!

Comment 3 Tom Yan 2014-10-22 08:33:21 UTC
(In reply to Michael Young from comment #1)
> I have investigated this further, and the issue is between ghostscript and
> urw-fonts. Ghostscript has the file
> /usr/share/ghostscript/9.14/Resource/Init/Fontmap.GS which translates well
> known font names (Times-Roman, Helvetica etc.) into the OS font name.
> Unfortunately urw-fonts has changed the name of many of these fonts so
> ghostscript translates such fonts into names that no longer exist.

Not sure about your case or how fedora package ghostscript. However ghostscript  comes with a set of equivalent pfb files in Resource/Font with their names changed to the old ones (e.g. Nimbus Roman No9 L).

Btw the maintainer seems to have plan to modify ghostscript to adapt to the new names in the future (For easier management I suppose, and Nimbus Sans Narrow is FINALLY a font family now).

Comment 4 Jerry James 2014-10-23 21:42:29 UTC
Same question as comment 1: what is the ETA for a fix for this?  If help is needed, what can I do to help?

Comment 5 Ngo Than 2014-10-24 08:57:49 UTC
I'm thinking about changing font's name to old name as before. It would fix the issue.

Comment 6 Tom Yan 2014-10-24 09:31:20 UTC
I'll say having this optimization held back until ghostscript adapt to the new font release is a better choice:
http://pkgs.fedoraproject.org/cgit/ghostscript.git/tree/ghostscript.spec#n241

If someone want to help, probably they should talk to upstream to see if what changes need to be made for the adaptation (other than Fontmap.GS, if any)

Comment 7 Tom Yan 2014-10-24 09:59:57 UTC
Created attachment 950298 [details]
patched to new font names

if interested, see if this patch is enough for fixing your problem

Comment 8 Tom Yan 2014-10-24 10:02:03 UTC
Created attachment 950300 [details]
git diff

Comment 9 Jerry James 2014-10-30 17:21:53 UTC
Same question as comment 4: when can we expect a fix for this?  Multiple packages cannot be built in Rawhide due to this bug.  When will they be buildable again?  Today?  In a week?  In a month?  In two months?

Comment 10 Ngo Than 2014-11-28 14:17:03 UTC
I'm working on it

Comment 11 Ngo Than 2014-11-28 14:22:31 UTC

*** This bug has been marked as a duplicate of bug 1160132 ***


Note You need to log in before you can comment on or make changes to this bug.