Bug 1160132 - new release urw-fonts-1.10-1 made lilypond package failed to build
Summary: new release urw-fonts-1.10-1 made lilypond package failed to build
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: urw-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1140865 1147931 (view as bug list)
Depends On:
Blocks: 1142817
TreeView+ depends on / blocked
 
Reported: 2014-11-04 06:07 UTC by Parag Nemade
Modified: 2015-01-21 14:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-21 12:56:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1154589 None None None Never

Internal Links: 1154589

Description Parag Nemade 2014-11-04 06:07:13 UTC
Description of problem:
After some analysis I found that in configure script of lilypond package there is a check which is now evaluated to no

checking for New Century Schoolbook PFB files... no

This rule is executing following command actually which worked with f21 urw-fonts but failed for f22.
On F21 I get
$ fc-list "Century Schoolbook L:foundry=urw:fontformat=Type 1:lang=ru"
/usr/share/fonts/default/Type1/c059016l.pfb: Century Schoolbook L:style=Bold
/usr/share/fonts/default/Type1/c059033l.pfb: Century Schoolbook L:style=Italic
/usr/share/fonts/default/Type1/c059013l.pfb: Century Schoolbook L:style=Roman
/usr/share/fonts/default/Type1/c059036l.pfb: Century Schoolbook L:style=Bold Italic

On F22 I get no output
$ fc-list "Century Schoolbook L:foundry=urw:fontformat=Type 1:lang=ru"

Then I checked new fonts information in fontforge=>Element=> Font Info and found fonts now no longer provide name "Century Schoolbook L" but "Century Schoolbook URW".

Version-Release number of selected component (if applicable):
urw-fonts-1.10-1.fc22

How reproducible:
always failed to (re-)build lilypond in rawhide

Steps to Reproduce:
1.
2.
3.

Actual results:
no font provide name "Century Schoolbook L"

Expected results:
should fonts provide name "Century Schoolbook L"? or new names are okay. If they are then lilypond maintainer need to fix this.



Additional info:

Comment 1 Gwyn Ciesla 2014-11-04 14:49:41 UTC
It looks like the latest rawhide build is radically different version, what took place here?  Did upstream drop support for some components?

Comment 2 Parag Nemade 2014-11-04 15:08:11 UTC
If the new lilypond update still needs "Century Schoolbook L" font then it will fail as in the new urw-fonts update those needed fonts got renamed from "Century Schoolbook L" to "Century Schoolbook URW". There can be fixes at either both sides.
* Ask urw-fonts upstream why those PFB (Type 1) fonts got renamed and can they be changed back?
or
* Check why lilypond needs those fonts and can upstream of lilypond modify configure.ac to change rule for searching fonts with name to "Century Schoolbook URW"?

Comment 3 Paul Flo Williams 2014-11-04 15:36:51 UTC
We could also change modify the Fontconfig snippet to provide "Century Schoolbook L" as an alias for ~URW, possibly indefinitely.

Comment 4 Akira TAGOH 2014-11-06 04:05:19 UTC
Even if providing an alias for old names, it won't work because Cyrillic glyphs has been removed from new urw fonts due to the poor quality. you need to find out an alternative fonts to get it working properly.

Comment 5 Gwyn Ciesla 2014-11-10 16:08:20 UTC
Emailed lilypond bug reporting list.  The dev version still wants ru from URW, so I think they'll need to migrate eventually anyway, so I'm asking for suggestions.

Comment 6 Ngo Than 2014-11-28 13:16:55 UTC
I'm asking the urw fonts upstream why "Century Schoolbook L" is renamed to "Century Schoolbook URW" and Cyrillic glyphs are removed, and waiting for feedback.

But i don't think upstream will revert those changes, so my suggestionn is to migrate lilypond

Comment 7 Ngo Than 2014-11-28 14:19:13 UTC
*** Bug 1147931 has been marked as a duplicate of this bug. ***

Comment 8 Ngo Than 2014-11-28 14:22:31 UTC
*** Bug 1140865 has been marked as a duplicate of this bug. ***

Comment 9 Gwyn Ciesla 2014-12-02 17:45:09 UTC
I agree, though lilypond's upstream has been less than receptive.  It took me nearly a month to get to the right mailing list and get a response, and at this point the best idea they have is to bundle the old font files.  I proposed migration to something else and someone else (who hadn't publicly replied) emailed me privately and said that this was a Fedora problem and not a lilypond problem since it works fine on Debian.  I suggested that Fedora is simply the canary in the coal mine, that other distros will also eventually update urw, and that this is a great opportunity for lilypond to get in front of the problem before it impacts the bulk of it's user base.  Silence.

I've also looked into a way to disable Cyrillic support in lilypond and it's not currently possible.

Comment 10 Ngo Than 2014-12-04 09:31:27 UTC
(In reply to Akira TAGOH from comment #4)
> Even if providing an alias for old names, it won't work because Cyrillic
> glyphs has been removed from new urw fonts due to the poor quality. you need
> to find out an alternative fonts to get it working properly.

the current urw-fonts upstream told me the fonts were renamed by URW and he doesn't know why. Tagoh, will you add providing an alias for old names in fontconfig? It will resolve this issue.

The Cyrillic glyphs were dropped because, frankly, they were of *very* poor quality, the quality was simply not up to the standard required for a printable font. And at least as important, in the majority cases, the Cyrillic did not fit with the typeface style of the rest of the glyphs in the fonts.

Comment 11 Akira TAGOH 2014-12-05 03:48:36 UTC
(In reply to Ngo Than from comment #10)
> the current urw-fonts upstream told me the fonts were renamed by URW and he
> doesn't know why. Tagoh, will you add providing an alias for old names in
> fontconfig? It will resolve this issue.

Better doing that in urw-fonts package. I could attach the proposed file for that if necessary.
That said, as I said earlier, that alias doesn't address this issue because of missing Cyrillic glyphs, which means the language coverage in the fontconfig cache will be also dropped then. so asking for a font with :lang=ru won't matches with URW.

If no alternatives and needing URW with Cyrillic anyway, I'd propose having compat package might be good.

Comment 12 Ngo Than 2015-01-21 12:56:47 UTC
i reverted my change in urw-fonts and built new one in rawhide. i did scratch build lilypond in rawhide whithout any problem

http://koji.fedoraproject.org/koji/taskinfo?taskID=8686786

Comment 13 Gwyn Ciesla 2015-01-21 14:23:33 UTC
Thanks, I'll rebuild lilypond.

Comment 14 Parag Nemade 2015-01-21 14:57:16 UTC
Ngo, Thank you for working on this issue and providing working build now :)


Note You need to log in before you can comment on or make changes to this bug.