Bug 1150377 - [3.5-6.6] Can't install RHEVH successful on physical machine- Error Exception display.
Summary: [3.5-6.6] Can't install RHEVH successful on physical machine- Error Exception...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: 885960 886782 950553 960379 980815 981170 990919 1021437 1022508 1029263 1029724 1046875 1047489 1048079 1050780 1051434 1051514 1051722 1051728 1052021 1052875 1055140 1055383 1056398 1064153 1067863 1078087 1078188 1079695 1085831 1090434 1104600 rhev35betablocker 1150243 1156112 rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-10-08 06:20 UTC by haiyang,dong
Modified: 2016-02-10 20:11 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1156112 (view as bug list)
Environment:
Last Closed: 2015-02-11 21:02:48 UTC
oVirt Team: Node


Attachments (Terms of Use)
attached ovirt-node.log (5.10 KB, text/plain)
2014-10-08 06:20 UTC, haiyang,dong
no flags Details
attached ovirt.log (74.41 KB, text/plain)
2014-10-08 09:15 UTC, haiyang,dong
no flags Details
attached ovirt.log for rhev-hypervisor6-6.6-20141008.0.iso (72.94 KB, text/plain)
2014-10-09 08:10 UTC, haiyang,dong
no flags Details
attached ovirt-node.log for rhev-hypervisor6-6.6-20141008.0.iso (5.10 KB, text/plain)
2014-10-09 08:11 UTC, haiyang,dong
no flags Details
attached ovirt.log from /tmp of rhevh (79.52 KB, text/plain)
2014-10-09 08:57 UTC, haiyang,dong
no flags Details
attached ovirt-node.log (4.96 KB, text/plain)
2014-10-22 03:12 UTC, haiyang,dong
no flags Details
attached logs for rhev-hypervisor6-6.6-20141021.0.el6ev iso (6.05 MB, application/x-xz)
2014-10-22 03:14 UTC, haiyang,dong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 33945 master MERGED install: Use correct arguments for wipefs Never
oVirt gerrit 33948 master MERGED installer: Silence wipefs completely Never
oVirt gerrit 34005 master MERGED install: Partition probing ain't reliable Never
oVirt gerrit 34439 node-3.0 MERGED install: Partition probing ain't reliable Never
oVirt gerrit 34454 None None None Never

Description haiyang,dong 2014-10-08 06:20:58 UTC
Created attachment 944858 [details]
attached ovirt-node.log

Description of problem:
Can't reinstall rhev-hypervisor6-6.6-20141007.0.iso via pxe -  Exception: RuntimError('Failed to set install bootloader',) appears at 57% of installation.

2014-10-08 05:14:27,270      ERROR Installer transaction failed
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ovirt/node/installer/core/progress_page.py", line 126, in __run
  File "/usr/lib/python2.6/site-packages/ovirt/node/plugins.py", line 188, in dry_or
  File "/usr/lib/python2.6/site-packages/ovirt/node/installer/core/progress_page.py", line 120, in do_commit
  File "/usr/lib/python2.6/site-packages/ovirt/node/installer/core/progress_page.py", line 286, in commit
RuntimeError: Failed to set install bootloader

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.6-20141007.0.iso
ovirt-node-3.1.0-0.20.20141006gitc421e04.el6.noarch

How reproducible:
100%

Steps to Reproduce:


Actual results:

Expected results:

Additional info:
Also Provide two test scenarios for this iso.
1. TUI install RHEV-H with USB livecd with/without enforcing=0 --- Failed.(Exception: OSError(30,'Read-only file system') )
2. Auto install via PXE-- Failed.

But no such issue when we using vm to reinstall rhev-hypervisor6-6.6-20141007.0.iso.

Comment 2 haiyang,dong 2014-10-08 09:15:30 UTC
Created attachment 944888 [details]
attached ovirt.log

Comment 3 Fabian Deutsch 2014-10-08 17:59:14 UTC
Snippet from the logs:

2014-10-08 09:11:13,110 - INFO - ovirtfunctions - Removing HostVG
2014-10-08 09:11:13,110 - INFO - ovirtfunctions - Wiping old boot sector
Error: Partition(s) on /dev/mapper/350024e920554256e are being used.
wipefs: invalid option -- 'f'
Usage: wipefs [options] <device>

Options:
 -a, --all           wipe all magic strings (BE CAREFUL!)
 -h, --help          this help
 -n, --no-act        everything to be done except for the write() call
 -o, --offset <num>  offset to erase, in bytes
 -p, --parsable      print out in parsable instead of printable format

For more information see wipefs(8).
2014-10-08 09:11:13,202 - DEBUG - ovirtfunctions - sync
2014-10-08 09:11:13,203 - DEBUG - ovirtfunctions - 
2014-10-08 09:11:13,222 - DEBUG - ovirtfunctions - kpartx -a '/dev/mapper/350024e920554256e'
2014-10-08 09:11:13,222 - DEBUG - ovirtfunctions - 
2014-10-08 09:11:13,473 - DEBUG - ovirtfunctions - partprobe
2014-10-08 09:11:13,473 - DEBUG - ovirtfunctions - 
2014-10-08 09:11:13,499 - DEBUG - ovirtfunctions - service multipathd reload
2014-10-08 09:11:13,499 - DEBUG - ovirtfunctions - Reloading multipathd: [60G[[0;32m  OK  [0;39m]

2014-10-08 09:11:14,259 - DEBUG - ovirtfunctions - multipath -r &>/dev/null
2014-10-08 09:11:14,259 - DEBUG - ovirtfunctions - 
2014-10-08 09:11:14,635 - DEBUG - ovirtfunctions - parted "/dev/mapper/350024e920554256e" -s "mkpart primary ext2 512M 768M"
2014-10-08 09:11:14,635 - DEBUG - ovirtfunctions - Error: You requested a partition from 512MB to 768MB.
The closest location we can manage is 320GB to 320GB.


So it seems that wipefs is taking different options, and thus does not erase remaining labels and fs remainings.
Which further prevents to create the necessary LVs.

Comment 6 haiyang,dong 2014-10-09 08:10:29 UTC
Created attachment 945216 [details]
attached ovirt.log for rhev-hypervisor6-6.6-20141008.0.iso

Comment 7 haiyang,dong 2014-10-09 08:11:02 UTC
Created attachment 945217 [details]
attached ovirt-node.log for rhev-hypervisor6-6.6-20141008.0.iso

Comment 9 haiyang,dong 2014-10-09 08:57:57 UTC
Created attachment 945231 [details]
attached ovirt.log from /tmp of rhevh

Maybe the root cause happen in here from /tmp/ovirt.log:
2014-10-09 07:56:32,976 - DEBUG - install - 
    grub --device-map=/liveos/grub/device.map <<EOF
root (hd0,2)
setup --prefix=/grub (hd0)
EOF

2014-10-09 07:56:32,996 - DEBUG - install - 

    GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename.]
grub> root (hd0,2)
 Filesystem type is ext2fs, partition type 0x83
grub> setup --prefix=/grub (hd0)
 Checking if "/grub/stage1" exists... no

Error 15t: File not found
grub> 
2014-10-09 07:56:32,996 - ERROR - install - GRUB setup failed
2014-10-09 07:56:32,996 - ERROR - install - Grub Installation Failed

Comment 10 Fabian Deutsch 2014-10-09 11:12:37 UTC
Haiyang, it seems as if there are some remaining partitions on the disk which is sued for installation.

Can you please try to clean up the disk manually and then install RHEV-H?

Comment 14 Douglas Schilling Landgraf 2014-10-10 03:20:43 UTC
Hi,

Just for the record, I have reproduced this report.
- No previous partitions in the disk 
- Installation via CDROM

Comment 17 Ying Cui 2014-10-14 07:16:41 UTC
In bug description, there are two additional scenario:
> Additional info:
> Also Provide two test scenarios for this iso.
> 1. TUI install RHEV-H with USB livecd with/without enforcing=0 ---
> Failed.(Exception: OSError(30,'Read-only file system') )
> 2. Auto install via PXE-- Failed.


Hey haiyang, how about these scenario on comment 15 builds?

Comment 18 haiyang,dong 2014-10-14 07:36:40 UTC
(In reply to Ying Cui from comment #17)
> In bug description, there are two additional scenario:
> > Additional info:
> > Also Provide two test scenarios for this iso.
> > 1. TUI install RHEV-H with USB livecd with/without enforcing=0 ---
> > Failed.(Exception: OSError(30,'Read-only file system') )
> > 2. Auto install via PXE-- Failed.
> 
> 
> Hey haiyang, how about these scenario on comment 15 builds?

1. Auto install via pxe--suceess
2. TUI install RHEV-H with USB livecd/cdrom sometimes still failed with Exception: OSError(30,'Read-only file system') 

For scenario 2, I will report a new bug to track OSError exception issue.

Comment 19 haiyang,dong 2014-10-14 09:26:54 UTC
(In reply to haiyang,dong from comment #18)
> 
> 1. Auto install via pxe--suceess
> 2. TUI install RHEV-H with USB livecd/cdrom sometimes still failed with
> Exception: OSError(30,'Read-only file system') 
> 
> For scenario 2, I will report a new bug to track OSError exception issue.

I have reported a new Bug 1152483 to track scenario 2 issue.

Comment 20 haiyang,dong 2014-10-22 03:12:44 UTC
Created attachment 949236 [details]
attached ovirt-node.log

Test version:
rhev-hypervisor6-6.6-20141021.0.el6ev.noarch.rpm
ovirt-node-3.0.1-19.el6.18.noarch

scenario 1: clean disk and install rhev-hypervisor6-6.6-20141021.0.el6ev
 --Install failed and throw execption:
2014-10-22 02:47:15,721      ERROR Installer transaction failed
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ovirt/node/installer/core/progress_page.py", line 126, in __run
  File "/usr/lib/python2.6/site-packages/ovirt/node/plugins.py", line 234, in dry_or
  File "/usr/lib/python2.6/site-packages/ovirt/node/installer/core/progress_page.py", line 120, in do_commit
  File "/usr/lib/python2.6/site-packages/ovirt/node/installer/core/progress_page.py", line 280, in commit
RuntimeError: Failed to set install bootloader

scenario 2:install rhev-hypervisor6-6.6-20141021.0.el6ev on dirty disk-- Hanging on 40% of installation.

Comment 21 haiyang,dong 2014-10-22 03:14:57 UTC
Created attachment 949237 [details]
attached logs for rhev-hypervisor6-6.6-20141021.0.el6ev iso

Comment 22 Ying Cui 2014-10-22 05:07:00 UTC
This bug can reproduce on rhevh 6.6 for 3.4.z build, so block QE testing now.

Comment 24 Fabian Deutsch 2014-10-24 12:20:48 UTC
(In reply to haiyang,dong from comment #21)
> Created attachment 949237 [details]
> attached logs for rhev-hypervisor6-6.6-20141021.0.el6ev iso

I do not know if this was an auto-install or TUI install.
I also do not see if it was for scenario 1 or 2. I can just guess.

Comment 25 haiyang,dong 2014-10-24 13:14:07 UTC
(In reply to Fabian Deutsch from comment #24)
> (In reply to haiyang,dong from comment #21)
> > Created attachment 949237 [details]
> > attached logs for rhev-hypervisor6-6.6-20141021.0.el6ev iso
> 
> I do not know if this was an auto-install or TUI install.
> I also do not see if it was for scenario 1 or 2. I can just guess.

It's TUI install of scenario 1. Due to Hanging on 40% of installation for scenario 2, so i couldn't get any logs for scenario 2.

Comment 26 Fabian Deutsch 2014-10-24 14:52:22 UTC
Steps to reproduce the issue in a VM:

1. _Install_ RHEV-H with:
qemu-img create -f qcow2 "hd1.qcow2" 30G
qemu-kvm \
  -serial stdio -m 2048 -boot d \
  -drive file=hd1.qcow2,media=disk,index=1,if=scsi,cache=none,serial=35000cca35fdc2dfc1 \
  -drive file=hd1.qcow2,media=disk,index=3,if=scsi,cache=none,serial=35000cca35fdc2dfc1 \
  -cdrom rhev-hypervisor6-6.6-20141024.0.iso

2. Reboot right after installation
3. Choose _Reinstall_ and do the TUI renistall
4. The installation hangs at 40%

Comment 32 haiyang,dong 2014-11-24 08:13:28 UTC
Test version:
rhevh-6.6-20141119.0.el6ev.iso
ovirt-node-3.1.0-0.27.20141119git24e087e.el6.noarch

Didn't meet it in my physical machine, so this bug has been fixed in in rhevh 6.6 for RHEV 3.5 bulid version, change the status into "VERIFIED"

Comment 35 errata-xmlrpc 2015-02-11 21:02:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.