Bug 1150967 - imrelp does not support options for keepalive
Summary: imrelp does not support options for keepalive
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rsyslog
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Radovan Sroka
QA Contact: Stefan Dordevic
URL:
Whiteboard:
Depends On: 1211056 1420716
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-09 10:25 UTC by Dalibor Pospíšil
Modified: 2017-08-01 09:53 UTC (History)
4 users (show)

Fixed In Version: rsyslog-8.24.0-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:53:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2306 0 normal SHIPPED_LIVE rsyslog bug fix and enhancement update 2017-08-01 12:41:59 UTC

Description Dalibor Pospíšil 2014-10-09 10:25:40 UTC
Description of problem:
if following config is used the rsyslog complains about unknown options keepalive.time, keepalive.interval, keepalive.probes, keepalive

module(load="imrelp")
input(type="imrelp" port="514" keepalive="on" keepalive.probes="2" keepalive.interval="2" keepalive.time="5")

Version-Release number of selected component (if applicable):
rsyslog-relp-7.4.7-7.el7_0

How reproducible:
always

Additional info:
this does work on RHEL6 rsyslog7-7.4.10-2.el6

Comment 1 Tomas Heinrich 2015-04-12 14:54:18 UTC
Unless librelp is rebased in el7.2, this can't be solved on rsyslog's side.

Comment 9 errata-xmlrpc 2017-08-01 09:53:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2306


Note You need to log in before you can comment on or make changes to this bug.