Bug 1154419 - NetKVM fails HCK test for 2008R2, single CPU
Summary: NetKVM fails HCK test for 2008R2, single CPU
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard: Fixed_Not_Ship
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-19 14:44 UTC by Yossi Hindin
Modified: 2015-11-24 08:44 UTC (History)
8 users (show)

Fixed In Version: virtio-win-prewhql-0.1-99
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:44:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Yossi Hindin 2014-10-19 14:44:39 UTC
With 2008R2 and single CPU, the following HCK tests fail:

DF - Fuzz Query and Set File Information Test
DF - Fuzz Query and Set Securty Test

NDISTest 6.5 - [2 Machines] - MPE_Ethernet.xml

Multiple process group device test
DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification)

Comment 2 Mike Cao 2014-10-20 02:15:08 UTC
mdeng ,pls try to reproduce it w/ single vcpu and vcpu=4

Comment 3 Min Deng 2014-10-22 06:05:16 UTC
QE reproduced the bug on the following builds
kernel-3.10.0-186.el7.x86-64
qemu-kvm-rhev-2.1.2-1.el7.x86_64
virtio-win-prewhql-0.1-93
All passed jobs with single cpu and vcpu=4
DF - Fuzz Query and Set File Information Test
DF - Fuzz Query and Set Securty Test
DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification)
All failed jobs 
NDISTest 6.5 - [2 Machines] - MPE_Ethernet.xml (Got BSOD)
Partly passed jobs
Multiple process group device test -failed with single vcpu (The job won't run at all)
Multiple process group device test -passed with vcpu=4
QE will report bugs for failed jobs later if there wasn't exited bugs.

Comment 4 Min Deng 2014-10-23 07:36:18 UTC
(In reply to dengmin from comment #3)
> QE reproduced the bug on the following builds
> kernel-3.10.0-186.el7.x86-64
> qemu-kvm-rhev-2.1.2-1.el7.x86_64
> virtio-win-prewhql-0.1-93
> All passed jobs with single cpu and vcpu=4
> DF - Fuzz Query and Set File Information Test
> DF - Fuzz Query and Set Securty Test
> DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification)
> All failed jobs 
> NDISTest 6.5 - [2 Machines] - MPE_Ethernet.xml (Got BSOD)
> Partly passed jobs
> Multiple process group device test -failed with single vcpu (The job won't
> run at all)
> Multiple process group device test -passed with vcpu=4
> QE will report bugs for failed jobs later if there wasn't exited bugs.

 QE want to clarify some details
 
 For Job named NDISTest 6.5 - [2 Machines] - MPE_Ethernet.xml (Got BSOD)
 Already reported two bugs for these issues
 Bug 1155891 and bug 1155910

Comment 5 Min Deng 2014-10-23 08:27:13 UTC
(In reply to dengmin from comment #3)
> QE reproduced the bug on the following builds
> kernel-3.10.0-186.el7.x86-64
> qemu-kvm-rhev-2.1.2-1.el7.x86_64
> virtio-win-prewhql-0.1-93
> All passed jobs with single cpu and vcpu=4
> DF - Fuzz Query and Set File Information Test
> DF - Fuzz Query and Set Securty Test
> DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification)
> All failed jobs 
> NDISTest 6.5 - [2 Machines] - MPE_Ethernet.xml (Got BSOD)
> Partly passed jobs
> Multiple process group device test -failed with single vcpu (The job won't
> run at all)
> Multiple process group device test -passed with vcpu=4
> QE will report bugs for failed jobs later if there wasn't exited bugs.

  For job named by multiple process group device test so we should run this job with multiple vcpus but not single one.Please refer to the following message from MS' hck log
-------------------------------------------------------------------------------
Report Details 
Test Cases 
Title Result 
 Failed 
 Start Test 10/23/2014 1:30:58.921 PM Running groupsize.exe 
End Test 10/23/2014 1:30:58.921 PM Running groupsize.exe 
Result:   Fail 
Repro:   groupsize.exe -ValidateMultipleGroupsExist 
 
 Failed 
 Start Test 10/23/2014 1:30:58.921 PM Verify the system is configured into multiple active processor groups 
Error 10/23/2014 1:30:58.921 PM ValidateMultipleGroupsExist - *Failure: Expected more than one active processor group, but found only one*. 
File:   testsrc\basetest\topology\groupsize\groupsize.cpp Line: 102 
Error Type:   HRESULT 
Error Code:   0x0 
Error Text:   The operation completed successfully. 
End Test 10/23/2014 1:30:58.921 PM Verify the system is configured into multiple active processor groups 
Result:   Fail 
Repro:   groupsize.exe -ValidateMultipleGroupsExist 
-----------------------------------------------------------------------

Comment 7 lijin 2015-04-02 02:28:45 UTC
test with build 102 and "-smp 1",following jobs can pass smoothly on win2k8R2 guest:
DF - Fuzz Query and Set File Information Test
DF - Fuzz Query and Set Securty Test
NDISTest 6.5 - [2 Machines] - MPE_Ethernet.xml
DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification)

So this issue has been fixed already.

package info:
kernel-3.10.0-223.el7.x86_64
qemu-kvm-rhev-2.1.2-20.el7.x86_64
seabios-1.7.5-4.el7.x86_64
virtio-win-prewhql-102

qemu cli:
NIC1:
/usr/libexec/qemu-kvm -name 102NIC2008R2CIN -enable-kvm -m 2G -smp 1 -uuid 4692745a-bc90-40c3-ba30-c658c3121d2d -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/102NIC2008R2CIN,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=102NIC2008R2CIN,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=102NIC2008R2CIN.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:39:3c:cd:92,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:7b:68:81:78,bus=pci.0,mq=on,vectors=10

NIC2:
/usr/libexec/qemu-kvm -name 102NIC2008R2SIN -enable-kvm -m 2G -smp 1 -uuid d644e192-c109-4878-bdea-8b66a3e0486c -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/102NIC2008R2SIN,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=102NIC2008R2SIN,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=102NIC2008R2SIN.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:68:62:0b:a2,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:3e:28:c3:90,bus=pci.0,mq=on,vectors=10

Comment 11 lijin 2015-07-17 07:15:52 UTC
change status to verified according to comment#7

Comment 13 errata-xmlrpc 2015-11-24 08:44:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.