Bug 1157193 - Predictable Network Interface Names cannot fit
Summary: Predictable Network Interface Names cannot fit
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-netload-plugin
Version: rawhide
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-26 01:03 UTC by poma
Modified: 2014-11-24 22:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-24 22:14:45 UTC
Type: Bug


Attachments (Terms of Use)
Handle predictable interface names length (5.59 KB, patch)
2014-11-09 18:27 UTC, poma
no flags Details | Diff

Description poma 2014-10-26 01:03:50 UTC
"Netload-plugin cannot handle predictable interface names."
https://bugzilla.xfce.org/show_bug.cgi?id=9807
e.g.
systemd-udevd: renamed network interface wlan0 to wlp0s4f1u3

This accompanied patch works reliably, long since.
"Workaround for extending the maximum interface name size (+10 chars)"
http://bug-attachment.xfce.org/attachment.cgi?id=4881


Also, 
"Length limit of interface names precludes use of valid interfaces"
https://bugzilla.xfce.org/show_bug.cgi?id=9869

Comment 1 poma 2014-10-26 01:10:27 UTC
"Network Monitor applet doesn't accept more than 7 characters in interface name"
https://bugzilla.redhat.com/show_bug.cgi?id=1002329

Comment 2 Kevin Fenzi 2014-10-28 13:24:32 UTC

*** This bug has been marked as a duplicate of bug 1002329 ***

Comment 3 poma 2014-11-09 16:20:06 UTC
The show never stops. :)

xfce4-netload-plugin-1.2.2:

... wlp0s4f1u3: renamed from wlan0  BROKEN
... wlan567890: renamed from wlan0  BROKEN
... wlan56789: renamed from wlan0   OK

Only net.ifname.lenght <= 9

Comment 4 poma 2014-11-09 16:23:05 UTC
Information for build xfce4-netload-plugin-1.2.2-1.fc22
http://koji.fedoraproject.org/koji/buildinfo?buildID=590130

Comment 5 poma 2014-11-09 18:27:07 UTC
Created attachment 955530 [details]
Handle predictable interface names length

Comment 6 Kevin Fenzi 2014-11-09 21:23:44 UTC
Upstream fixed this in a different way. They removed the limit on it entirely... 

Can you please comment on upstream bug: 
https://bugzilla.xfce.org/show_bug.cgi?id=9869

and see what might be going on with their fix?

Comment 7 poma 2014-11-21 12:28:38 UTC
1.2.3 broke it even more, in addition - incomplete units display.

The way it works OK:
# https://bugzilla.xfce.org/show_bug.cgi?id=9807
# https://bugzilla.xfce.org/show_bug.cgi?id=9869
# https://bugzilla.redhat.com/show_bug.cgi?id=1157193
# https://bugzilla.redhat.com/show_bug.cgi?id=1002329
# This commit didn't solve ifnames lenght problem at all:
# Do not enforce max length for text/device entries (bug #9869)
# http://git.xfce.org/panel-plugins/xfce4-netload-plugin/commit/?id=215438c
# So here we go again
# Handle predictable interface names length
Patch10:        handle-predictable-interface-names-length.patch
# Add argument as_bits to format_byte_humanreadable function
# http://git.xfce.org/panel-plugins/xfce4-netload-plugin/commit/?id=2e2d905
Patch11:        Add-argument-as_bits-to-format_byte_humanreadable-function.patch
# Add bufBS value in commandline test program
# http://git.xfce.org/panel-plugins/xfce4-netload-plugin/commit/?id=8fb438c
Patch12:        Add-bufBS-value-in-commandline-test-program.patch
# Add option Show values as bits (bug #9932)
# http://git.xfce.org/panel-plugins/xfce4-netload-plugin/commit/?id=4be032a
Patch14:        Add-option-Show-values-as-bits.patch

Comment 8 Kevin Fenzi 2014-11-21 20:02:02 UTC
Can you expand on "in addition - incomplete units display" ? 

Note that this breakage is why I haven't pushed this to any stable releases.

Comment 9 Kevin Fenzi 2014-11-22 22:07:16 UTC
Please test 1.2.4. Just built in rawhide. 

https://koji.fedoraproject.org/koji/taskinfo?taskID=8211934

Comment 10 poma 2014-11-24 18:53:31 UTC
Actually labels were reduced only to "B", but this has now all been resolved, with the addition of "b".
Super duper.

Tested with:
$ rpm -q xfce4-netload-plugin
xfce4-netload-plugin-1.2.4-1.fc20.x86_64
PASSED.


Note You need to log in before you can comment on or make changes to this bug.