Bug 1157849 - [RFE] Use AJAX for the component list when editing and searching bugs
[RFE] Use AJAX for the component list when editing and searching bugs
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
All Linux
high Severity high (vote)
: ---
: ---
Assigned To: Jeff Fearn
Rony Gong
: Reopened, TestCaseProvided
: 1165747 1254423 (view as bug list)
Depends On:
Blocks: 1136693 1181004 1221871 1221927
  Show dependency treegraph
 
Reported: 2014-10-27 17:02 EDT by Kevin Kofler
Modified: 2015-09-21 02:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.4.9039
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-20 19:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2014-10-27 17:02:19 EDT
Description of problem:
When I want to reassign a Fedora bug, clicking on "Edit" for "Component" fails to give me the complete list of components because they are too many for a combobox:
* In QtWebKit (Konqueror+KWebKitPart, Rekonq), it only offers the first 9999 components (up to openstack-ceilometer in the alphabet) and the last one (zzuf), anything inbetween (e.g. xorg-x11-* packages) is not shown.
* KHTML (Konqueror+KHTML) fails to load the component list entirely, the combobox shows only the bug's current component, as if I had never clicked on "Edit".

Version-Release number of selected component (if applicable):
4.4.6026

How reproducible:
Always

Steps to Reproduce:
1. Open a Fedora bug in Konqueror or Rekonq (or any other QtWebKit browser, I suppose).
2. Click "Edit" on "Component".
3. Try to select another component from the combobox.

Actual results:
Not all components are shown.

Expected results:
A solution to edit the component that does not rely on a combobox with more than 10000 entries.

Additional info:
Reportedly, Firefox does not have that limitation, but several browsers do.
Comment 1 Jason McDonald 2014-10-27 17:59:34 EDT
This is a known problem that has been reported many times over the years and results from Fedora's insanely long component list, which is now > 17,000 components.  The lengthy component list also causes performance problems and some users see timeouts when attempting to load some Bugzilla pages.

Most web browsers limit listboxes to 10,000 items to prevent malicious pages from causing the browser to run out of memory.  This is not something that the Bugzilla maintainers can change -- we've already tried, and failed to convince the Chrome folks to increase the limit.

In 2013, we implemented a workaround under bug 950315, where the user can type the component name into an auto-completed field.  This requires the browser to have javascript enabled (which will also be mandatory for Bugzilla 5.0 when we upgrade to it).

*** This bug has been marked as a duplicate of bug 787206 ***
Comment 2 Kevin Kofler 2014-10-27 18:05:58 EDT
My point is that the auto-completed field is NOT available for reassigning bugs (the Component field of show_bug.cgi). I do not get such a text field, and yes, I have JavaScript enabled.
Comment 3 Jason McDonald 2014-11-03 01:55:07 EST
Apologies, I was looking at enter_bug.cgi instead of show_bug.cgi.  A similar solution to the one in enter_bug.cgi should be implemented in show_bug.cgi, and ideally for query.cgi (Advanced Search) as well.
Comment 5 Jason McDonald 2014-11-19 22:34:22 EST
*** Bug 1165747 has been marked as a duplicate of this bug. ***
Comment 7 Matt Tyson 2015-04-20 01:40:04 EDT
Jeff has had some ideas on how to make the drop down box easier to use than what we currently have in enter_bug.cgi.
Comment 9 Jason McDonald 2015-04-23 01:49:11 EDT
The fix for this bug may also fix one or more of the following bugs:

* Bug 1132442
* Bug 1136681
* Bug 1136687
* Bug 1136693
* Bug 1151025
* Bug 1153422
* Bug 1180018
* Bug 1181004 (probably onlt partially)
Comment 10 Rony Gong 2015-05-11 22:55:48 EDT
Tested on 
QA environment(bzweb01-qe) with version(4.4.9033-1, DB: mysql)
QA environment(bzperfweb01.app.qa) with version(4.4.9033-1, DB: psql )
Result: Failed, the assingee, qa_contact, cc, docs_contact doesn't changed when component changed.
Steps:
1.create a bug of RHEL7, select 'aic94xx-firmware' as component
2.Then update above bug's component to '389-ds-base',save
3. Check the assingee, qa_contact, cc, docs_contact, no change. 
The default assingee, qa_contact, cc, docs_contact of 'aic94xx-firmware' and '389-ds-base' are not same.
Comment 11 Rony Gong 2015-05-11 23:01:08 EDT
Another error happened in advanced search:
1.Go to advanced page,
2.Select 2 products by press the "Ctrl" button
Then page pop up dialog contains below message:
Error: Bad product id: v90_product,v97_product at /loader/0x7f199b1ce098/Bugzilla/Extension/ChosenAjax/WebService/Search.pm line 108
Comment 12 Jason McDonald 2015-05-14 00:18:19 EDT
I found a regression on the Advanced Search page when not logged in.  If you attempt to select a product, Bugzilla pops up an error dialog with the message "Error: You must log in before using this part of Red Hat Bugzilla."

Suggest extending the QE test cases to include using the search fuinctionality while not logged in.  Of course, this should only show public bugs and fields, similar to seatching as a logged in user who has no groups.
Comment 13 Rony Gong 2015-05-14 00:26:51 EDT
Thanks, QE will add this case. Also test the search by a user who has no groups, it works fine.
Comment 14 Rony Gong 2015-05-14 22:14:45 EDT
Why add an abandoned commit 48177, please confirm it.
Comment 15 Rony Gong 2015-05-15 02:14:55 EDT
Tested on 
QA environment(bzweb01-qe) with version(4.4.9033-5, DB: mysql)
QA environment(bzperfweb01.app.qa) with version(4.4.9033-5, DB: psql )
Result: Pass
Comment 16 Matt Tyson 2015-05-26 23:53:13 EDT
This is now on our testing site at https://partner-bugzilla.redhat.com/

Please test it out and provide feedback.
Comment 17 Jason McDonald 2015-08-18 02:07:35 EDT
*** Bug 1254423 has been marked as a duplicate of this bug. ***
Comment 18 leigh scott 2015-08-18 02:25:37 EDT
(In reply to Matt Tyson from comment #16)
> This is now on our testing site at https://partner-bugzilla.redhat.com/
> 
> Please test it out and provide feedback.

+1 for the new interface
Comment 19 Matt Tyson 2015-09-20 19:28:57 EDT
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.