Bug 115843 - tda1004x module is missing
tda1004x module is missing
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 12:05 EST by Bernd Bartmann
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 15:59:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2004-02-16 12:05:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The module tda1004x (DVB-T demodulator chip) is missing from the FC2
Test 1 kernel. This module is required to get DVB-T running with the
Hauppauge WinTV Nova-T card.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. search for tda1004x kernel module
2.
3.
    

Additional info:
Comment 1 Bernd Bartmann 2004-02-16 12:31:43 EST
The module does not appear in "make menuconfig" when using the FC2
Test1 supplied .config file due to "CONFIG_STANDALONE=y"
Comment 2 Arjan van de Ven 2004-02-16 12:34:12 EST
"CONFIG_STANDALONE=y" means we don't want build-time firmware.
Which is correct, we can't generally download all firmware for some
driver and just distribute it; quite often that's not even allowed.
Comment 3 Bernd Bartmann 2004-02-16 12:40:27 EST
Arjan, the existense of the firmware file is not a build time
requirement. In fact you can also supply a different firmware filename
at module load time.
Comment 4 Arjan van de Ven 2004-02-16 12:42:51 EST
then the Kconfig for the file is borken.....
Comment 5 Bernd Bartmann 2004-02-16 12:55:30 EST
Just sent a mail to the DVB mailing list about this problem.
Comment 6 Bernd Bartmann 2004-02-16 15:38:20 EST
The DVD guys seem to have fixed this in their CVS after my problem
report, but now I have another problem. In the meantime I rebuild the
FC2 Test1 kernel to include the tda1004x module (using the supplied
.config). While trying to load the tda1004x module I'm getting this
error message:
                                                                     
                            
FATAL: Error inserting tda1004x
(/lib/modules/2.6.1-1.65bb/kernel/drivers/media/dvb/frontends/tda1004x.ko):
Unknown symbol in module, or unknown parameter (see dmesg)
                                                                     
                            
In /var/log/messages I get:
tda1004x: Unknown symbol sys_close

Any ideas how to fix this one?
Comment 7 Arjan van de Ven 2004-02-16 15:45:08 EST
they have very evil code there; it's not allowed to read files from
kernel space like that, they should use request_firmware interface
Comment 8 Bernd Bartmann 2004-02-17 18:07:26 EST
Now it finally works for me. Watching DVB-T television the whole
evening :-)

All I had to do was to re-add EXPORT_SYMBOL(sys_close) to fs/open.c
which was removed by your linux-2.6.0-compile.patch.
Comment 9 Neil Aspinall 2004-02-20 04:35:50 EST
I also got this working by changing all calls to sys_close() into
calls to close() in drivers/media/dvb/frontends/tda1004x.c.

Is there a reason for Fedora not exporting sys_close() from fs/open.c?
Comment 10 Arjan van de Ven 2004-02-20 04:38:32 EST
any user of it is broken. It cannot be used correctly.
tda1004x.c is rather broken. Really.
Even when not using request_firmware() and co, opening a file needs to
be done differently.
Comment 11 Alan Cox 2004-05-03 15:59:13 EDT
Being resolved upstream, will be picked up over time once firmware
handling is in the base kernel [and possibly when someone reminds us
to turn it on 8)]. 

Comment 12 Thomas Vander Stichele 2004-08-25 10:56:50 EDT
Is there much value of deprecating/removing stuff from the FC kernel
that's not (yet) done upstream ? I thought the new point of FC kernels
was to stick as close to upstream as possible ?
Comment 13 Phil Anderson 2005-01-04 07:38:37 EST
# ChangeSet
#   2004/12/13 08:34:11-08:00 hunold@linuxtv.org 
#   [PATCH] dvb: frontend update
#   
#   - tda1004x: fixed firmware upload problems
<snip>
#   Signed-off-by: Michael Hunold <hunold@linuxtv.org>
#   Signed-off-by: Andrew Morton <akpm@osdl.org>
#   Signed-off-by: Linus Torvalds <torvalds@osdl.org>

Looks like a fix for this is finally on the way.....
Comment 14 Phil Anderson 2005-03-19 08:22:05 EST
Also see bug 151555

Note You need to log in before you can comment on or make changes to this bug.