Bug 1158654 - [FEAT] Journal Based Replication (JBR - formerly NSR)
Summary: [FEAT] Journal Based Replication (JBR - formerly NSR)
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Jeff Darcy
QA Contact:
URL:
Whiteboard:
Depends On: 1327225 1327227 1328043 1333370 1336328 1349385 1408680 1408773 1408776
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-29 19:31 UTC by Jeff Darcy
Modified: 2018-11-20 04:25 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-20 04:25:49 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Jeff Darcy 2014-10-29 19:31:16 UTC
Leader/journal based synchronous and quasi-synchronous replication, as described in http://review.gluster.org/#/c/8915/ and elsewhere.

Comment 1 Vijay Bellur 2016-02-04 03:14:28 UTC
REVIEW: http://review.gluster.org/12943 (NSR: Volgen Support) posted (#13) for review on master by Jeff Darcy (jdarcy@redhat.com)

Comment 2 Vijay Bellur 2016-02-05 12:44:22 UTC
REVIEW: http://review.gluster.org/12943 (NSR: Volgen Support) posted (#14) for review on master by Jeff Darcy (jdarcy@redhat.com)

Comment 3 Vijay Bellur 2016-02-08 19:40:57 UTC
COMMIT: http://review.gluster.org/12943 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit fac8038a9fa80e16b557d91b9e2fec271cfda5fa
Author: Jeff Darcy <jdarcy@redhat.com>
Date:   Mon Dec 14 16:25:22 2015 -0500

    NSR: Volgen Support
    
    Allows the user to convert an afr-volume to a nsr-volume
    by using cluster.nsr option in the volume set command
    
    gluster volume set <volname> cluster.nsr <on/off>
    
    Change-Id: Ia1c5aa89d27535f7275d474cf312dc5efb8e222f
    BUG: 1158654
    Signed-off-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-on: http://review.gluster.org/12943
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Jeff Darcy 2016-04-14 14:01:33 UTC
Renaming from NSR to JBR.  Also, this is now going to be used as a tracker bug, with subsidiary bugs associated with it for the individual pieces.

Comment 5 Niels de Vos 2016-06-16 12:39:37 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 jack.wong 2016-09-21 20:27:04 UTC
(In reply to Niels de Vos from comment #5)
> This bug is getting closed because a release has been made available that
> should address the reported issue. In case the problem is still not fixed
> with glusterfs-3.8.0, please open a new bug report.
> 
> glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages
> for several distributions should become available in the near future. Keep
> an eye on the Gluster Users mailinglist [2] and the update infrastructure
> for your distribution.
> 
> [1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
> [2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Are you sure that this feature is implemented in GlusterFS 3.8? How do I enable Journal-Based Replication in that release?

Comment 7 Atin Mukherjee 2016-09-22 03:47:32 UTC
(In reply to jack.wong from comment #6)
> (In reply to Niels de Vos from comment #5)
> > This bug is getting closed because a release has been made available that
> > should address the reported issue. In case the problem is still not fixed
> > with glusterfs-3.8.0, please open a new bug report.
> > 
> > glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages
> > for several distributions should become available in the near future. Keep
> > an eye on the Gluster Users mailinglist [2] and the update infrastructure
> > for your distribution.
> > 
> > [1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
> > [2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
> 
> Are you sure that this feature is implemented in GlusterFS 3.8? How do I
> enable Journal-Based Replication in that release?

It's certainly not. This was done by mistake.

Comment 8 Karthik U S 2018-11-20 04:25:49 UTC
As we do not have any plan to work on any of the SSR/JBR related bugs in the near future, we are closing this bug. In the future if there is a ask and we have enough resources we will reopen and work on this.


Note You need to log in before you can comment on or make changes to this bug.