Bug 1159842 - wrong encoding of Russian man pages
Summary: wrong encoding of Russian man pages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Chaloupka
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Depends On:
Blocks: 1189029
TreeView+ depends on / blocked
 
Reported: 2014-11-03 13:39 UTC by Martin Frodl
Modified: 2015-07-22 06:20 UTC (History)
4 users (show)

Fixed In Version: man-pages-overrides-6.7.0-1.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, certain manual pages in Russian language were incorrectly encoded. As a consequence, users were unable to read such man pages. This bug has been fixed, and man pages are displayed in the correct encoding.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:20:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1295 normal SHIPPED_LIVE man-pages-overrides bug fix update 2015-07-20 17:54:02 UTC

Description Martin Frodl 2014-11-03 13:39:47 UTC
Description of problem:

Man pages owned by coreutils are displayed incorrectly when the ru_RU.utf8 locale is being used. Instead of displaying Cyrillic characters as expected, the man page is full of weird accented Latin letters, obviously resulting from an incorrect encoding.

To verify this, try any of the following commands:

$ LANG=ru_RU.utf8 man ls
$ LANG=ru_RU.utf8 man rm
$ LANG=ru_RU.utf8 man mkdir

Additional info:
This issue has not been observed on RHEL 5 or 7.

Comment 1 Ondrej Vasik 2014-11-03 13:48:54 UTC
I don't think coreutils package provides localized man pages. I assume this is caused by man-pages-ru package.

Comment 3 Martin Frodl 2014-11-03 14:00:36 UTC
It seems man-pages-overrides is to blame:

$ LANG=ru_RU.utf8 man -w ls
/usr/share/man/overrides/ru/man1/ls.1.gz
$ rpm -qf /usr/share/man/overrides/ru/man1/ls.1.gz
man-pages-overrides-6.6.3-2.el6.noarch

Comment 4 Jan Chaloupka 2014-11-04 11:06:31 UTC
Some russian man-pages were covered in bz816252. Looks like some man-pages have different encoding then others.

Comment 5 Jan Chaloupka 2014-11-04 11:14:24 UTC
There are two tarballs:
1) manpages-ru-0.97.rh.tar.bz2
2) man-pages-ru_3.24-2059-1223-20100508.tar.bz2

the first one is not UTF-8, the second-one is. Removing man-pages belonging to 1) will solve this issue.

Comment 13 errata-xmlrpc 2015-07-22 06:20:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1295.html


Note You need to log in before you can comment on or make changes to this bug.