Bug 1164576 - iSCSi connections are doubled upon detach-attach
Summary: iSCSi connections are doubled upon detach-attach
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Ala Hino
QA Contact: Aharon Canan
URL:
Whiteboard:
Depends On:
Blocks: 1258428
TreeView+ depends on / blocked
 
Reported: 2014-11-16 16:48 UTC by Ori Gofen
Modified: 2016-03-09 19:27 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1258428 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:27:15 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
logs (693.03 KB, application/x-gzip)
2014-11-16 16:48 UTC, Ori Gofen
no flags Details
logs (1.26 MB, application/x-gzip)
2015-06-07 15:28 UTC, Ori Gofen
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC

Description Ori Gofen 2014-11-16 16:48:22 UTC
Created attachment 958022 [details]
logs

Description of problem:

see bz #1159637 

The operation of detach-attach an iSCSi storage domain does not login to iSCSi sessions as it should (on my hosts 4 iqn's are configured)
Upon attach the receiving host is logged to 3 session out of 4 iqn's ,furthermore, it is somehow logged in to each session twice(one nic only):

[root@dhcp-2-51 ~]# lspci | grep Ether
00:19.0 Ethernet controller: Intel Corporation 82567LM-3 Gigabit Network Connection (rev 02)

[root@dhcp-2-51 ~]# iscsiadm -m session
tcp: [17] 10.35.160.105:3260,2 iqn.1992-04.com.emc:cx.ckm00121000438.a7
tcp: [18] 10.35.160.105:3260,2 iqn.1992-04.com.emc:cx.ckm00121000438.a7
tcp: [19] 10.35.160.106:3260,3 iqn.1992-04.com.emc:cx.ckm00121000438.b6
tcp: [20] 10.35.160.106:3260,3 iqn.1992-04.com.emc:cx.ckm00121000438.b6
tcp: [21] 10.35.160.107:3260,4 iqn.1992-04.com.emc:cx.ckm00121000438.b7
tcp: [22] 10.35.160.107:3260,4 iqn.1992-04.com.emc:cx.ckm00121000438.b7
tcp: [23] 10.35.160.104:3260,1 iqn.1992-04.com.emc:cx.ckm00121000438.a6

see also sessions.log file(it is the output of getDeviceList)
Version-Release number of selected component (if applicable):
vt10

How reproducible:
100%

Steps to Reproduce:
* Have a storage group with 4 iqn's
1.(on first dc) Create iSCSi domain
2.(on first dc) Create NFS Domain
3.(on second dc) Craete NFS domain
4. detach iSCSi domain and attach it to second dc

Actual results:
Host receiving the domain has connections duplicity

Expected results:
no duplicity, the host is logged in to all sessions needed to see the iSCSi domain

Additional info:

Comment 1 Allon Mureinik 2014-12-22 11:16:31 UTC
Liron/Greg, is this related to bug 1176402?

Comment 2 Greg Padgett 2014-12-22 11:23:52 UTC
(In reply to Allon Mureinik from comment #1)
> Liron/Greg, is this related to bug 1176402?

Unsure.  I'm figuring out (with Ori) if/how I can reproduce the issue and won't know more until then.

Comment 3 Yaniv Lavi 2015-01-15 09:47:21 UTC
(In reply to Greg Padgett from comment #2)
> (In reply to Allon Mureinik from comment #1)
> > Liron/Greg, is this related to bug 1176402?
> 
> Unsure.  I'm figuring out (with Ori) if/how I can reproduce the issue and
> won't know more until then.

Can you please update of the status of this issue?

Comment 4 Greg Padgett 2015-01-15 22:26:03 UTC
(In reply to Yaniv Dary from comment #3)
> (In reply to Greg Padgett from comment #2)
> > (In reply to Allon Mureinik from comment #1)
> > > Liron/Greg, is this related to bug 1176402?
> > 
> > Unsure.  I'm figuring out (with Ori) if/how I can reproduce the issue and
> > won't know more until then.
> 
> Can you please update of the status of this issue?

Hi Yaniv, I can't reproduce it in my dev environment, so I'm getting a virt host that can connect to the tested storage and will debug/fix it from there.  (Same applies for bug 1164578 as well)

Comment 5 Eyal Edri 2015-02-25 08:42:16 UTC
3.5.1 is already full with bugs (over 80), and since none of these bugs were added as urgent for 3.5.1 release in the tracker bug, moving to 3.5.2

Comment 6 Ori Gofen 2015-06-07 15:28:01 UTC
Created attachment 1035950 [details]
logs

reproduced on rhevm 3.5 vt15.4.


[root@fury66 ~]# iscsiadm -m session
tcp: [1] 10.35.160.107:3260,4 iqn.1992-04.com.emc:cx.ckm00121000438.b7 (non-flash)
tcp: [2] 10.35.160.107:3260,4 iqn.1992-04.com.emc:cx.ckm00121000438.b7 (non-flash)
tcp: [3] 10.35.160.105:3260,2 iqn.1992-04.com.emc:cx.ckm00121000438.a7 (non-flash)
tcp: [4] 10.35.160.106:3260,3 iqn.1992-04.com.emc:cx.ckm00121000438.b6 (non-flash)
tcp: [4] 10.35.160.106:3260,3 iqn.1992-04.com.emc:cx.ckm00121000438.b6 (non-flash)
tcp: [5] 10.35.160.104:3260,1 iqn.1992-04.com.emc:cx.ckm00121000438.a6 (non-flash)

please be aware-> two of the hosts have one Ethernet controller each, this does not reproduce on machines with two nics or more

Comment 7 Ori Gofen 2015-08-25 12:30:55 UTC
This bug is Verfied on latest 3.6 rhevm build (12)

Comment 8 Ori Gofen 2015-08-31 08:57:34 UTC
Verified on latest oVirt 3.5 and latest Rhevm 3.6.
note: iscsi connection are not doubled any more but the final result of this flow differs from 3.5 to 3.6.
while in 3.6 'hypervisor A' which is detaching iscsi domain and "left" with only file storage has no iscsi connection upon detach.
in 3.5 'hypervisor A' left with redundant connections upon detach:

root@el71-host01 ~ $ iscsiadm -m session
tcp: [11] 10.35.160.106:3260,3 iqn.1992-04.com.emc:cx.ckm00121000438.b6 (non-flash)
tcp: [6] 10.35.160.107:3260,4 iqn.1992-04.com.emc:cx.ckm00121000438.b7 (non-flash)
tcp: [8] 10.35.160.105:3260,2 iqn.1992-04.com.emc:cx.ckm00121000438.a7 (non-flash)

Comment 9 Aharon Canan 2015-08-31 09:03:36 UTC
We didn't get 3.5.5 rhevm build yet - therefore it wasn't verified on the relevant build. 

Back to on_qa to verify once we will have 3.5.5 downstream build.

Comment 11 Aharon Canan 2015-08-31 11:14:50 UTC
Verified on 3.6 based on comment #8

Comment 14 errata-xmlrpc 2016-03-09 19:27:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.