Bug 1165208 - clicking on external providers in tree view doesn't update main-tab content properly
Summary: clicking on external providers in tree view doesn't update main-tab content p...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Alexander Wels
QA Contact: Michael Burman
URL:
Whiteboard: ux
: 1165124 (view as bug list)
Depends On:
Blocks: 1083998 1113000 1113003 rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-18 14:59 UTC by movciari
Modified: 2015-02-16 13:35 UTC (History)
14 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 13:35:59 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
screenshot (57.10 KB, image/png)
2014-11-18 14:59 UTC, movciari
no flags Details
screen-cast: selecting 'External Providers' in left-pane tree (1.14 MB, application/ogg)
2014-11-19 16:51 UTC, Einav Cohen
no flags Details
master not working (2.73 MB, application/ogg)
2014-11-24 14:05 UTC, Alexander Wels
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 35492 master MERGED webadmin: Selecting provider does not update content Never
oVirt gerrit 35569 ovirt-engine-3.5 MERGED webadmin: Selecting provider does not update content Never

Description movciari 2014-11-18 14:59:29 UTC
Description of problem:
on clean setup of vt10, clicking on "External Providers" in tree view keeps previous tab open instead of opening external providers tab

Version-Release number of selected component (if applicable):
vt10

How reproducible:
always

Steps to Reproduce:
1. go to "Virtual Machines" main tab
2. click "External Providers" in tree view

Actual results:
still shows virtual machines tab

Expected results:
should show external providers tab

Additional info:
works on my old vt9 setup, so it can be either a regression in vt10 or an issue that shows only on a new setup with no VMs, hosts or anything

Comment 1 movciari 2014-11-18 14:59:57 UTC
Created attachment 958617 [details]
screenshot

Comment 3 Einav Cohen 2014-11-19 16:51:00 UTC
Created attachment 959072 [details]
screen-cast: selecting 'External Providers' in left-pane tree

Comment 4 Einav Cohen 2014-11-19 16:58:43 UTC
see attachment 959072 [details] from ~latest master: 

right after logging into the system: once selecting the 'External Provider' node on the left-pane System tree, the 'Provider' main-tab appears, however the main-tab *content* indeed remains the previous content (i.e. the VM's main-tab content), but only for ~2 seconds or so. After that - the content updates to be the correct 'Providers' content. 

After that: Switching back and forth between the VMs main-tab and the Providers main tab (e.g. by clicking alternately on the 'System' tree-node and on the 'External Provider tree-node) the behavior is OK. 

@Michal - are you experiencing a similar behavior in vt10 (maybe in your case it is more than 2 seconds due to slower client / slower client-server connection)?

@Alexander - anything that we can do about this issue (e.g. once switching tabs - hide the main-tab content completely and display only progress-animation until content is ready or something similar)?

Comment 5 Einav Cohen 2014-11-19 17:42:22 UTC
*** Bug 1165124 has been marked as a duplicate of this bug. ***

Comment 6 Einav Cohen 2014-11-19 17:44:18 UTC
@Michael (reporter of duplicate bug 1165124) - same question as the one I asked Michal in Comment #4. thanks.

Comment 8 Michael Burman 2014-11-23 07:49:19 UTC
Hi Einav,

In my case and as i reported in bug 1165124, in vt10 the content doesn't refreshing at all. And it's not only the 'external provider' tab, this behavior is for all tabs and sub tabs in left tree.

Comment 9 Einav Cohen 2014-11-24 13:17:25 UTC
(In reply to Michael Burman from comment #8)
> Hi Einav,
> 
> In my case and as i reported in bug 1165124, in vt10 the content doesn't
> refreshing at all. And it's not only the 'external provider' tab, this
> behavior is for all tabs and sub tabs in left tree.

Thanks, Michael. 

@Alexander - in case you cannot reproduce this yourself (I couldn't on 'master', but maybe reproducible on 'ovirt-engine-3.5'/downstream), please contact Michael and/or Michal in order to see this behavior on their environment. thanks.

Comment 10 Alexander Wels 2014-11-24 14:05:12 UTC
Created attachment 960803 [details]
master not working

Yes I can reproduce no problem, working on figuring out the problem.

Comment 11 sefi litmanovich 2014-12-08 08:55:23 UTC
Hi, saw this bz and wanted to share my experience with this.
I got the same behaviour as in description on vt12.
It does seem to work when you choose external_providers on the left tree and then click on the providers tab again.

Comment 12 Michael Burman 2014-12-08 09:08:37 UTC
works on vt13.1

Comment 13 Einav Cohen 2014-12-10 15:39:36 UTC
not sure why this didn't move to ON_QA automatically -> moving manually. 

@Michael - thanks for testing. move to VERIFIED?

Comment 14 Michael Burman 2014-12-10 15:48:42 UTC
Hi Einav, yes sure.

Verified on - 3.5.0-0.23.beta.el6ev


Note You need to log in before you can comment on or make changes to this bug.