Bug 116724 (shmat) - X segfaults with kernel-2.6.3-1.100 with SHM_IPC errors
Summary: X segfaults with kernel-2.6.3-1.100 with SHM_IPC errors
Status: CLOSED RAWHIDE
Alias: shmat
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
: 116725 116756 (view as bug list)
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-24 18:43 UTC by Kaj J. Niemi
Modified: 2015-01-04 22:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-25 14:48:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.0.log, doesn't seem to much interesting related to the segfaults (26.04 KB, text/plain)
2004-02-24 18:44 UTC, Kaj J. Niemi
no flags Details

Description Kaj J. Niemi 2004-02-24 18:43:09 UTC
Description of problem:
After rebooting with kernel-2.6.3-1.100 both rhgb started and run
level 5 X servers segfault. Everything works fine with kernel-2.6.3-1.97.

I'll attach XFree86.0.log, below is the output from messages:

Feb 24 20:30:35 d100 gdm[2268]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Feb 24 20:30:37 d100 gdm[2272]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Feb 24 20:30:43 d100 gdm[2276]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Feb 24 20:30:48 d100 gdm[2280]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Feb 24 20:30:48 d100 gdm[2213]: deal_with_x_crashes: Running the
XKeepsCrashing script


Version-Release number of selected component (if applicable):
XFree86-4.3.0-59
kernel-2.6.3-1.100

How reproducible:
Always.

Steps to Reproduce:
1. reboot with 2.6.3-1.100
2. wait for rhgb or run level 5 X to start
3.

Comment 1 Kaj J. Niemi 2004-02-24 18:44:59 UTC
Created attachment 98003 [details]
XFree86.0.log, doesn't seem to much interesting related to the segfaults

Comment 2 Mike A. Harris 2004-02-24 20:05:15 UTC
This seems rather significant to me actually:

(EE) RADEON(0): shmat() call retruned errno 1013

So does:

(WW) RADEON(0): Video BIOS not detected in PCI space!
(WW) RADEON(0): Attempting to read Video BIOS from legacy ISA space!

Comment 3 Kaj J. Niemi 2004-02-24 20:15:24 UTC
Whoops, I skimmed it for The Big Error.. that EE was so suddle ;-) My bad.

Related, Warren Togami reported the same with 2.6.3-1.99 in his blog.

Maybe related, 2.6.3-1.100 lost the USB controllers as well. I noticed
it when kudzu asked if I really wanted to remove them.

Comment 4 Gene Czarcinski 2004-02-24 21:25:18 UTC
Confirm ... have the same problem on Radeon 9200 (R200) with pciid
1106:3059

Comment 5 John Ellson 2004-02-24 21:33:49 UTC
(I realize that the NVIDEA drivers taint the kernel, but this might be
related.)

The NVIDIA-Linux-x86-1.0-5336-pkg1 drivers compiled OK with 1.97,
but fail to compile with 1.100.   The error message was:
"Shared memory test failed (Invalid argument): please check that your
kernel has CONFIG_SYSVIPC enabled."
   

Comment 6 Steve Bergman 2004-02-25 00:15:17 UTC
I have a problem that looks to be related.

mplayer dies with the error:

X11 error: BadAccess (attempt to access private resource denied) 

From an strace:
2578  shmget(IPC_PRIVATE, 230400, IPC_CREAT|0777) = 1081356
2578  shmat(1081356, 0, 0)              = -1 EINVAL (Invalid argument)

My rawhide is coompletely up to date, except for openssl-devel which
has a dependency issue.

Comment 7 Sammy 2004-02-25 01:51:21 UTC
I am using XFree86 -59 with 2.6.3 arjanv kernel (compiled myself) 
with no problems (Radeon 7200). There were some new radeonfb upgrades on top 
of 2.6.3. I would think that this is more of a kernel problem. 

Comment 8 Bill Nottingham 2004-02-25 04:32:07 UTC
*** Bug 116756 has been marked as a duplicate of this bug. ***

Comment 9 Matthew Eastman 2004-02-25 07:06:21 UTC
I have the exact problem since I've upgraded kernels and I have a
Radeon M7-C; perhaps there is some kind of conflict between this
particular kernel and the Radeon drivers.

Comment 10 Warren Togami 2004-02-25 09:17:46 UTC
This seems to be fixed for me on 2.6.3-1.106.  Try it for yourself
when it hits rawhide.

Comment 11 Mike A. Harris 2004-02-25 11:05:28 UTC
*** Bug 116725 has been marked as a duplicate of this bug. ***

Comment 12 Mike A. Harris 2004-02-25 11:12:10 UTC
*** Bug 116756 has been marked as a duplicate of this bug. ***

Comment 13 Kaj J. Niemi 2004-02-25 12:47:23 UTC
Works with 2.6.3-1.106.

Comment 14 John Ellson 2004-02-25 14:41:57 UTC
NVIDIA 5336 drivers on 1.106 seem OK.

Comment 15 Dave Jones 2004-02-25 14:48:45 UTC
should be fixed now.


Comment 16 Don Hardaway 2004-02-25 15:37:43 UTC
How about drivers for the netgear WG511 wireless card that uses prism
duette or gt chip set.  What is it's status since I can only get my
old 802.11 card to work with core 2

Comment 17 Mike A. Harris 2004-02-27 07:42:15 UTC
Dave) Yep, I've gotten numerous confirmations that the new kernel
fixes the shmat bug.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.