Bug 1168398 - Update Mail to Email in User Settings
Summary: Update Mail to Email in User Settings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Shimon Shtein
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks: 1130651 1188301
TreeView+ depends on / blocked
 
Reported: 2014-11-26 19:40 UTC by sthirugn@redhat.com
Modified: 2019-09-25 20:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:43:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
NeedInfo Screenshot (154.93 KB, image/png)
2015-09-07 10:00 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 8525 None None None 2016-04-22 16:50:38 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description sthirugn@redhat.com 2014-11-26 19:40:29 UTC
Description of problem:
Update Mail to Email in User Settings

Version-Release number of selected component (if applicable):
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.34-1.el6.noarch
* candlepin-common-1.0.14-1.el6.noarch
* candlepin-selinux-0.9.34-1.el6.noarch
* candlepin-tomcat6-0.9.34-1.el6.noarch
* elasticsearch-0.90.10-7.el6.noarch
* foreman-1.8.0-0.develop.201411171200git7c3c059.el6.noarch
* foreman-compute-1.8.0-0.develop.201411171200git7c3c059.el6.noarch
* foreman-gce-1.8.0-0.develop.201411171200git7c3c059.el6.noarch
* foreman-libvirt-1.8.0-0.develop.201411171200git7c3c059.el6.noarch
* foreman-ovirt-1.8.0-0.develop.201411171200git7c3c059.el6.noarch
* foreman-postgresql-1.8.0-0.develop.201411171200git7c3c059.el6.noarch
* foreman-proxy-1.8.0-0.develop.201411121327gitab6edc2.el6.noarch
* foreman-release-1.8.0-0.develop.201411171200git7c3c059.el6.noarch
* foreman-selinux-1.8.0-0.develop.201410280941git10de1c5.el6.noarch
* foreman-vmware-1.8.0-0.develop.201411171200git7c3c059.el6.noarch
* katello-2.1.0-1.201411061509gitb0b8f43.el6.noarch
* katello-certs-tools-2.0.1-1.el6.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-2.1.0-1.201411170016gitcc577bc.el6.noarch
* katello-repos-2.1.1-1.el6.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-docker-plugins-0.2.1-0.2.beta.el6.noarch
* pulp-katello-0.3-3.el6.noarch
* pulp-nodes-common-2.5.0-0.7.beta.el6.noarch
* pulp-nodes-parent-2.5.0-0.7.beta.el6.noarch
* pulp-puppet-plugins-2.5.0-0.7.beta.el6.noarch
* pulp-puppet-tools-2.5.0-0.7.beta.el6.noarch
* pulp-rpm-plugins-2.5.0-0.7.beta.el6.noarch
* pulp-selinux-2.5.0-0.7.beta.el6.noarch
* pulp-server-2.5.0-0.7.beta.el6.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.3.3-1.el6.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6.noarch
* ruby193-rubygem-runcible-1.3.0-1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Web UI -> My Account 


Actual results:
Tab -> 'Mail Preferences'
General -> 'Mail enabled'


Expected results:
Tab -> 'Email Preferences'
General -> 'Email enabled'

Additional info:

Comment 1 RHEL Program Management 2014-11-26 19:53:49 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-11-27 09:56:31 UTC
Created redmine issue http://projects.theforeman.org/issues/8525 from this bug

Comment 4 Bryan Kearney 2015-02-18 23:06:03 UTC
Upstream bug assigned to sshtein@redhat.com

Comment 9 Bryan Kearney 2015-05-11 20:04:23 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/8525 has been closed
-------------
Shimon Shtein
Applied in changeset commit:1a282cbac427815a5844445271e038c7bfc90f23.

Comment 10 Jitendra Yejare 2015-09-07 10:00:23 UTC
Created attachment 1070919 [details]
NeedInfo Screenshot

Comment 11 Jitendra Yejare 2015-09-07 10:01:58 UTC
Though in all other areas been converted to 'email', The conversion has not been made under Web UI -> my account -> General -> 'mail enabled'. Is it expected ? If yes, I will make it Verified else FailedQA.

See screenshot of doubt.

Comment 14 Jitendra Yejare 2015-09-07 13:11:41 UTC
The observations described in Comment 11 are observed in Upstream only. Screenshot for same is attached already.

Comment 17 Tazim Kolhar 2015-11-04 11:40:27 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***
Version Tested:
# rpm -qa | grep foreman
foreman-proxy-1.11.0-0.develop.201510201341git00875b3.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-debug-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-compute-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-gce-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-vmware-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-ovirt-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-release-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-libvirt-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-postgresql-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201510201150gitab068d9.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch

steps:

1. Navigate to Web UI -> My Account 


Tab -> 'Email Preferences'
General -> 'Email enabled'

Comment 21 errata-xmlrpc 2016-07-27 08:43:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.