Bug 1168486 - Don't ask user to run shell command
Summary: Don't ask user to run shell command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Fabian Deutsch
QA Contact: wanghui
URL:
Whiteboard:
Depends On:
Blocks: 1059435 1198657 1250199
TreeView+ depends on / blocked
 
Reported: 2014-11-27 06:06 UTC by Fabian Deutsch
Modified: 2016-07-04 00:41 UTC (History)
7 users (show)

Fixed In Version: ovirt-node-plugin-hosted-engine-0.3.0-1.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1198657 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:22:58 UTC
oVirt Team: Node
Target Upstream Version:
ylavi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 35633 None None None Never

Description Fabian Deutsch 2014-11-27 06:06:36 UTC
Description of problem:
We currently ask the user to drop to shell and run host-deploy --vm-status.
But dropping to shell is unsupported, so we must not ask to do so.

Version-Release number of selected component (if applicable):
vt12

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 wanghui 2015-11-27 10:38:28 UTC
Test version:
rhev-hypervisor7-7.2-20151112.1.el7ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-3.el7ev.noarch

Test steps:
1. Setup Hosted engine succeed.
2. Shutdown vm.
3. Due to there is bug#1280185, need to logout rhevh then login to check the status.
4. Check the Hosted Engine page.

Test result:
1. After step4, it shows as follows.

Engine Status: Engine is down or not deployed.

No more infos to let user run shell command now. So this issue is fixed in ovirt-node-plugin-hosted-engine-0.3.0-3.el7ev.noarch. Change the status to verified.

Comment 6 errata-xmlrpc 2016-03-09 14:22:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.