Bug 1169349 - vmstat disk device field is not long enough
Summary: vmstat disk device field is not long enough
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: procps-ng   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Jan Rybar
QA Contact: Jan Houska
Lenka Špačková
URL:
Whiteboard:
Keywords: Patch, Regression, Upstream
Depends On: 586078
Blocks: 590060 1203710 1313485 596948 1295829
TreeView+ depends on / blocked
 
Reported: 2014-12-01 12:07 UTC by Martin Frodl
Modified: 2018-11-14 19:40 UTC (History)
11 users (show)

Fixed In Version: procps-ng-3.3.10-10.el7
Doc Type: Release Note
Doc Text:
"vmstat -d" is now able to display devices with longer names When a disk statistics report is required, only the first 15 characters of the device name were previously read from the `/proc/diskstats` file. Consequently, devices with names longer than 15 characters were not shown in the output of the "vmstat -d" command. With this update, the formatting string has been changed to read up to 31 characters, and devices with longer names are now correctly displayed by "vmstat -d".
Story Points: ---
Clone Of: 586078
Environment:
Last Closed: 2016-11-04 06:35:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
procps-ng-3.3.10-vmstat-devlen.patch (2.29 KB, patch)
2016-01-14 15:53 UTC, Jaromír Cápík
no flags Details | Diff
Patch putting previous patch to effect (417 bytes, patch)
2016-07-26 13:34 UTC, Jan Rybar
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2447 normal SHIPPED_LIVE procps-ng bug fix update 2016-11-03 14:03:27 UTC

Comment 2 Jaromír Cápík 2016-01-14 15:53 UTC
Created attachment 1114874 [details]
procps-ng-3.3.10-vmstat-devlen.patch

This is a blind forward-port of the procps-3.2.8-vmstat-devlen.patch from RHEL6. There's a small risk of breaking customer apps linked against the libprocps library, if they use disk_stat and partition_stat structures.

Comment 9 Jan Rybar 2016-07-26 13:34 UTC
Created attachment 1184275 [details]
Patch putting previous patch to effect

Additional fix to the previous patch (required).

Comment 14 errata-xmlrpc 2016-11-04 06:35:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2447.html


Note You need to log in before you can comment on or make changes to this bug.