Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 586078 - vmstat disk device field is not long enough
vmstat disk device field is not long enough
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: procps (Show other bugs)
5.4
All Linux
high Severity medium
: rc
: ---
Assigned To: Jan Görig
BaseOS QE - Apps
:
Depends On:
Blocks: 590060 596948 1169349
  Show dependency treegraph
 
Reported: 2010-04-26 14:49 EDT by Casey Dahlin
Modified: 2014-12-01 07:07 EST (History)
7 users (show)

See Also:
Fixed In Version: procps-3.2.7-17.el5
Doc Type: Bug Fix
Doc Text:
Cause vmstat doesn't read whole device name if it is too long Consequence Devices with long name weren't showed by vmstat -d command Fix Increased number of maximum characters for device name Result Devices with long name are shown
Story Points: ---
Clone Of:
: 596948 1169349 (view as bug list)
Environment:
Last Closed: 2011-04-20 09:25:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image with vmstat disalignment in rh el 5.x anc correct in F13 (37.79 KB, image/png)
2010-07-15 09:07 EDT, Gianluca Cecchi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0459 normal SHIPPED_LIVE procps bug fix update 2011-04-20 09:25:35 EDT

  None (edit)
Description Casey Dahlin 2010-04-26 14:49:49 EDT
Description of problem:
vmstat needlessly restricts device names in output to 15 characters. The maximum in the kernel is 32.

Version-Release number of selected component (if applicable):
procps-3.2.7-16.el5

Additional info:
procps-3.2.7-vmstat-partstats.patch introduced this. The fix is to change %15s to %32s in the format strings introduced there.
Comment 1 Daniel Novotny 2010-04-27 05:18:08 EDT
OK, can change this, thanks for the bug report
Comment 3 Gianluca Cecchi 2010-07-15 09:06:24 EDT
Can I also add request to fix layout so that the command

vmstat 3

returns correct headers alignment with data?

As an example I'm going to attach an image where I have:
- default gnome terminal window in F13 without customizations (so 80x24)
(but the output result is similar running a terminal session from putty on windows or from secure shell client for windows by http://www.ssh.com)
- vmstat 3 2 on F13 ---> headers are correctly aligned
- ssh to localhost vmstat 3 2 ---> headers are correctly aligned
- ssh to a rh el 5.5 host vmstat 3 2 ---> headers are not correctly aligned 
So that you have to resize your terminal....

I presume in F13 a fix was inserted. Any chance to have it in rhg el 5.5 too?
And possibly in rh el 6 .... (not tried yet beta1 or beta2)

Thanks for reading,

Gianluca
Comment 4 Gianluca Cecchi 2010-07-15 09:07:22 EDT
Created attachment 432079 [details]
image with vmstat disalignment in rh el 5.x anc correct in F13
Comment 5 Gianluca Cecchi 2010-07-15 09:14:33 EDT
I don't know if the problem arises only in big-memory configurations where you can have generally big number for "free", "cache" columns...
It would be good to have a sort of auto alignment:

For example if I use -S M switch I can get something like this
[root@orasvi2 ~]# vmstat -S M 3 2 
procs -----------memory---------- ---swap-- -----io---- --system-- -----cpu------
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 1 46      0  24123    798   8134    0    0  7676  1730    5    4 13  4 41 41  0
 0 46      0  24123    798   8134    0    0 87457 12092 12325 34963 18  6 10 66  0

where the second line has the final "0" character one line below, because "bi" column is 87457 vs 7676 of the first line.....
Or perhaps it would be good to add a switch to not show some fields (for example si and so if you are not interested in them when doing a particular proactive monitoring...

Gianluca
Comment 7 RHEL Product and Program Management 2010-08-09 14:46:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 Jan Görig 2011-03-17 06:22:30 EDT
Fixed in procps-3.2.7-17.el5.
Comment 14 Jan Görig 2011-03-17 08:25:28 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
 vmstat doesn't read whole device name if it is too long
Consequence
 Devices with long name weren't showed by vmstat -d command
Fix
 Increased number of maximum characters for device name
Result
 Devices with long name are shown
Comment 19 errata-xmlrpc 2011-04-20 09:25:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0459.html

Note You need to log in before you can comment on or make changes to this bug.