Bug 1173437 - [RFE] changes needed in snapshot info command's xml output.
Summary: [RFE] changes needed in snapshot info command's xml output.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1245084 1250387 1250388
TreeView+ depends on / blocked
 
Reported: 2014-12-12 07:24 UTC by Darshan
Modified: 2015-09-30 12:15 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.6.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1245084 1250387 1250388 (view as bug list)
Environment:
Last Closed: 2015-09-30 12:15:13 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Darshan 2014-12-12 07:24:03 UTC
Description of problem:
1. If description for a snapshot is not available then the description tag is missing in the xml output of snapshot info command. Its better to have the description tag always and if description is not available then "NA" can be given there. By this the xml output will be more consistent.

2. Its better to give the snapshot creation time as the Epoch time, so that it can be suitably converted to the time zone of the user when showing it in the console.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-08-14 08:54:14 UTC
REVIEW: http://review.gluster.org/11919 (snapshot: Fix snapshot info's xml output) posted (#1) for review on release-3.6 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-08-14 12:37:08 UTC
REVIEW: http://review.gluster.org/11919 (snapshot: Fix snapshot info's xml output) posted (#2) for review on release-3.6 by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2015-08-17 03:31:18 UTC
REVIEW: http://review.gluster.org/11919 (snapshot: Fix snapshot info's xml output) posted (#3) for review on release-3.6 by Avra Sengupta (asengupt@redhat.com)

Comment 4 Anand Avati 2015-08-20 06:49:54 UTC
REVIEW: http://review.gluster.org/11919 (snapshot: Fix snapshot info's xml output) posted (#4) for review on release-3.6 by Avra Sengupta (asengupt@redhat.com)

Comment 5 Anand Avati 2015-08-26 06:41:04 UTC
COMMIT: http://review.gluster.org/11919 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit b8118289a928c72cf5a2298419c188fb87426c2f
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Aug 5 15:56:53 2015 +0530

    snapshot: Fix snapshot info's xml output
    
        Backport of http://review.gluster.org/#/c/11834/
    
    Display description field with (null) if
    no description is present for the snapshot, instead
    of removing the field altogether
    
    Change-Id: I965b08cd6e54eea56c32e2712fab7daa8a663f11
    BUG: 1173437
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/11919
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 6 Avra Sengupta 2015-08-27 07:03:55 UTC
Currently we provide the create time stamp in xml in the server's timezone instead of epoch time. We would like to stick to the same, because of the following reasons.

1. It is more readable, and makes more sense to the user, when we display the current time format in CLI, rather than the epoch time. And we don't want to display a different output in CLI, and another one in xml.

2. Even given the epoch time, you would need to process it to get it in the suitable, time zone that you need. The same can be done in the current format.

3. With giving just the epoch time, we lose the serer's timezone info. And we don't feel it's necessary to show, both the current format, and the epoch time.

Given the above reasons, I propose, we limit the scope of this bug, to description issue only. Could you comment on the same.

Comment 7 Darshan 2015-08-27 07:18:25 UTC
(In reply to Avra Sengupta from comment #6)
> Currently we provide the create time stamp in xml in the server's timezone
> instead of epoch time. We would like to stick to the same, because of the
> following reasons.
> 
> 1. It is more readable, and makes more sense to the user, when we display
> the current time format in CLI, rather than the epoch time. And we don't
> want to display a different output in CLI, and another one in xml.
> 
> 2. Even given the epoch time, you would need to process it to get it in the
> suitable, time zone that you need. The same can be done in the current
> format.
> 
> 3. With giving just the epoch time, we lose the serer's timezone info. And
> we don't feel it's necessary to show, both the current format, and the epoch
> time.
> 
> Given the above reasons, I propose, we limit the scope of this bug, to
> description issue only. Could you comment on the same.

Makes sense. You can retain the time format of creation-time as it is.

Comment 8 Avra Sengupta 2015-08-27 08:02:37 UTC
Based on the above comment moving it to MODIFIED

Comment 9 Raghavendra Bhat 2015-09-30 12:15:13 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.6, please open a new bug report.

glusterfs-3.6.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-devel/2015-September/046821.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.