Bug 1250388 - [RFE] changes needed in snapshot info command's xml output.
[RFE] changes needed in snapshot info command's xml output.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Avra Sengupta
: Triaged
Depends On: 1173437
Blocks: 1245084 1250387
  Show dependency treegraph
 
Reported: 2015-08-05 05:42 EDT by Avra Sengupta
Modified: 2015-10-14 06:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1173437
Environment:
Last Closed: 2015-10-14 06:30:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avra Sengupta 2015-08-05 05:42:30 EDT
+++ This bug was initially created as a clone of Bug #1173437 +++

Description of problem:
1. If description for a snapshot is not available then the description tag is missing in the xml output of snapshot info command. Its better to have the description tag always and if description is not available then "NA" can be given there. By this the xml output will be more consistent.

2. Its better to give the snapshot creation time as the Epoch time, so that it can be suitably converted to the time zone of the user when showing it in the console.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2015-08-14 04:37:39 EDT
REVIEW: http://review.gluster.org/11918 (snapshot: Fix snapshot info's xml output) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 2 Anand Avati 2015-08-14 08:29:18 EDT
REVIEW: http://review.gluster.org/11918 (snapshot: Fix snapshot info's xml output) posted (#2) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 3 Anand Avati 2015-08-24 03:15:38 EDT
REVIEW: http://review.gluster.org/11918 (snapshot: Fix snapshot info's xml output) posted (#3) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 4 Anand Avati 2015-08-27 02:57:38 EDT
REVIEW: http://review.gluster.org/11918 (snapshot: Fix snapshot info's xml output) posted (#4) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 5 Avra Sengupta 2015-08-27 04:04:22 EDT
Based on comment 6 and 7 on https://bugzilla.redhat.com/show_bug.cgi?id=1173437, limiting the scope of the bug to only the description fix.
Comment 6 Anand Avati 2015-08-29 06:05:45 EDT
REVIEW: http://review.gluster.org/11918 (snapshot: Fix snapshot info's xml output) posted (#5) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 7 Pranith Kumar K 2015-10-14 06:30:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 8 Pranith Kumar K 2015-10-14 06:38:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.