Bug 1250387 - [RFE] changes needed in snapshot info command's xml output.
[RFE] changes needed in snapshot info command's xml output.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: bugs@gluster.org
: Triaged
Depends On: 1173437 1250388
Blocks: 1245084
  Show dependency treegraph
 
Reported: 2015-08-05 05:41 EDT by Avra Sengupta
Modified: 2016-06-16 09:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1173437
Environment:
Last Closed: 2016-06-16 09:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avra Sengupta 2015-08-05 05:41:48 EDT
+++ This bug was initially created as a clone of Bug #1173437 +++

Description of problem:
1. If description for a snapshot is not available then the description tag is missing in the xml output of snapshot info command. Its better to have the description tag always and if description is not available then "NA" can be given there. By this the xml output will be more consistent.

2. Its better to give the snapshot creation time as the Epoch time, so that it can be suitably converted to the time zone of the user when showing it in the console.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2015-08-05 06:46:13 EDT
REVIEW: http://review.gluster.org/11834 (snapshot: Fix snapshot info's xml output) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Anand Avati 2015-08-05 06:56:20 EDT
REVIEW: http://review.gluster.org/11834 (snapshot: Fix snapshot info's xml output) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 3 Anand Avati 2015-08-12 04:26:14 EDT
REVIEW: http://review.gluster.org/11834 (snapshot: Fix snapshot info's xml output) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 4 Anand Avati 2015-08-14 08:22:05 EDT
REVIEW: http://review.gluster.org/11834 (snapshot: Fix snapshot info's xml output) posted (#5) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 5 Anand Avati 2015-08-20 02:18:57 EDT
REVIEW: http://review.gluster.org/11834 (snapshot: Fix snapshot info's xml output) posted (#7) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 6 Avra Sengupta 2015-08-27 04:04:13 EDT
Based on comment 6 and 7 on https://bugzilla.redhat.com/show_bug.cgi?id=1173437, limiting the scope of the bug to only the description fix. Moving it to MODIFIED
Comment 7 Niels de Vos 2016-06-16 09:28:57 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.