Bug 1206098 - AttributeError: 'NoneType' object has no attribute 'path'
Summary: AttributeError: 'NoneType' object has no attribute 'path'
Keywords:
Status: CLOSED DUPLICATE of bug 1177273
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1221774
TreeView+ depends on / blocked
 
Reported: 2015-03-26 10:14 UTC by Michal Formanek
Modified: 2015-06-17 21:42 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-17 21:42:50 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (503.85 KB, text/plain)
2015-03-26 10:14 UTC, Michal Formanek
no flags Details
File: anaconda.log (11.66 KB, text/plain)
2015-03-26 10:14 UTC, Michal Formanek
no flags Details
File: environ (590 bytes, text/plain)
2015-03-26 10:14 UTC, Michal Formanek
no flags Details
File: journalctl (329.78 KB, text/plain)
2015-03-26 10:14 UTC, Michal Formanek
no flags Details
File: lsblk_output (2.82 KB, text/plain)
2015-03-26 10:14 UTC, Michal Formanek
no flags Details
File: nmcli_dev_list (2.30 KB, text/plain)
2015-03-26 10:14 UTC, Michal Formanek
no flags Details
File: os_info (443 bytes, text/plain)
2015-03-26 10:14 UTC, Michal Formanek
no flags Details
File: program.log (30.62 KB, text/plain)
2015-03-26 10:14 UTC, Michal Formanek
no flags Details
File: storage.log (128.62 KB, text/plain)
2015-03-26 10:14 UTC, Michal Formanek
no flags Details
File: ifcfg.log (3.86 KB, text/plain)
2015-03-26 10:14 UTC, Michal Formanek
no flags Details

Description Michal Formanek 2015-03-26 10:14:11 UTC
Description of problem:
Click to "Install to Hard Drive" on LiveCD

Version-Release number of selected component:
anaconda-core-22.20.2-1.fc22.x86_64

The following was filed automatically by anaconda:
anaconda 22.20.2-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/livepayload.py", line 76, in setup
    if not stat.S_ISBLK(os.stat(osimg.path)[stat.ST_MODE]):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 1219, in _runThread
    payload.setup(storage, instClass)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 238, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'NoneType' object has no attribute 'path'

Additional info:
cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz0 root=live:LABEL=LIVE ro rd.live.image quiet rhgb
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
other involved packages: python-libs-2.7.9-5.fc22.x86_64
product:        Fedora"
release:        Fedora release 22 (Twenty Two)
type:           anaconda
version:        Fedora

Potential duplicate: bug 1177273

Comment 1 Michal Formanek 2015-03-26 10:14:15 UTC
Created attachment 1006739 [details]
File: anaconda-tb

Comment 2 Michal Formanek 2015-03-26 10:14:17 UTC
Created attachment 1006740 [details]
File: anaconda.log

Comment 3 Michal Formanek 2015-03-26 10:14:18 UTC
Created attachment 1006741 [details]
File: environ

Comment 4 Michal Formanek 2015-03-26 10:14:22 UTC
Created attachment 1006742 [details]
File: journalctl

Comment 5 Michal Formanek 2015-03-26 10:14:23 UTC
Created attachment 1006743 [details]
File: lsblk_output

Comment 6 Michal Formanek 2015-03-26 10:14:25 UTC
Created attachment 1006744 [details]
File: nmcli_dev_list

Comment 7 Michal Formanek 2015-03-26 10:14:26 UTC
Created attachment 1006745 [details]
File: os_info

Comment 8 Michal Formanek 2015-03-26 10:14:28 UTC
Created attachment 1006746 [details]
File: program.log

Comment 9 Michal Formanek 2015-03-26 10:14:30 UTC
Created attachment 1006747 [details]
File: storage.log

Comment 10 Michal Formanek 2015-03-26 10:14:31 UTC
Created attachment 1006748 [details]
File: ifcfg.log

Comment 11 Eli Boaz 2015-05-03 00:56:50 UTC
Another user experienced a similar problem:

  	Installing f22 beta to surface pro and taping on the screen to bring up the onscreen keyboard

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22_B-3 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.0.0-0.rc5.git4.1.fc22.x86_64
other involved packages: python-libs-2.7.9-5.fc22.x86_64
package:        anaconda-core-22.20.9-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 12 Stephen Gallagher 2015-05-14 19:35:01 UTC
Another user experienced a similar problem:

I just started up liveinst with an existing Windows 7 installation on the machine

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-T3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.1-300.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.12-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 13 Stephen Gallagher 2015-05-14 19:37:09 UTC
Another user experienced a similar problem:

Crashed right after starting liveinst on a Dell XPS 15 with a pre-existing Windows 7 installation

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-T3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.1-300.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.12-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 14 Petr Schindler 2015-05-21 11:26:47 UTC
Another user experienced a similar problem:

Anaconda crashes right after I start it (on workstation livecd RC2).

Before I run livecd I deleted raid partition in bios (firmware raid).

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-2 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.0.2-300.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 15 kurtmc 2015-05-27 17:49:45 UTC
Another user experienced a similar problem:

Running "Install to Hard Drive" after booting to Fedora 22 x86 Live on USB

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat ro rd.live.image quiet rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.i686
other involved packages: python-libs-2.7.9-6.fc22.i686
package:        anaconda-core-22.20.13-1.fc22.i686
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 16 John Williams 2015-05-30 16:55:59 UTC
Another user experienced a similar problem:

When presented with the option of running live OS or installing to hard disk, I chose installing to hard disk.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 17 jzg.dev 2015-06-04 04:57:05 UTC
Another user experienced a similar problem:

Put Fedora-Live-Workstation-x86_64-22-3.iso (changed to .raw) onto a USB drive using SUSE Image Writer. 
Booted up into Fedora 22 Live.
Select "Install to Hard Drive".
I see the language selection window pop up briefly and then a popup stating "An unknown error has occured"

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 18 John Williams 2015-06-06 20:48:31 UTC
Another user experienced a similar problem:

On the first page of install with the option to select language the error message popped up before clicking anything.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 19 Stuart D Gathman 2015-06-12 01:29:07 UTC
Another user experienced a similar problem:

Booted MATE Live USB, selected Install to Hard Disk from desktop.  Language selection appears, then app crashes.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat rw rd.live.image rd.live.overlay=LABEL=LIVE quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.i686
other involved packages: python-libs-2.7.9-6.fc22.i686
package:        anaconda-core-22.20.13-1.fc22.i686
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 20 Galen A. 2015-06-15 00:12:19 UTC
Another user experienced a similar problem:

1. Used liveusb-creator with Fedora KDE 22 x64 image
2. Booted USB in UEFI mode
3. Ran Installer from KDE menu
4. Immediate crash

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz0 root=live:LABEL=LIVE rw rd.live.image rd.live.overlay=LABEL=LIVE quiet rhgb
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 21 Galen A. 2015-06-15 00:52:55 UTC
Okay, Mine seems to be caused by my OCZ Revodrive - parted says:

Error: Can't have a partition outside the disk!
Ignore/Cancel? I                                                          
Model: ATA OCZ-REVODRIVE3 (scsi)
Disk /dev/sde: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  240GB  240GB  primary

It is 240GB large, but it seems to be reporting that it is 120GB (I think I know why, it is two 120GB disks configured like RAID0, from the factory).

Any way to bypass/disable drive detection?

Trying netinstall gives error: DeviceTreeErrror: Failed to scan disk sde

Comment 22 Galen A. 2015-06-15 00:53:48 UTC
Okay, Mine seems to be caused by my OCZ Revodrive - parted says:

Error: Can't have a partition outside the disk!
Ignore/Cancel? I                                                          
Model: ATA OCZ-REVODRIVE3 (scsi)
Disk /dev/sde: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  240GB  240GB  primary

It is 240GB large, but it seems to be reporting that it is 120GB (I think I know why, it is two 120GB disks configured like RAID0, from the factory).

Any way to bypass/disable drive detection?

Trying netinstall gives error: DeviceTreeErrror: Failed to scan disk sde

Comment 23 Galen A. 2015-06-15 18:57:19 UTC
Solved my problem (OCZ RevoDrive reporting partition too large for disk, due to software raid) by finding ata device id in dmesg and adding boot option libata.force=8.00:disable,9.00:disable - turning off detection of the RevoDrive.  

Installation now works for me.

Comment 24 David Shea 2015-06-17 21:42:50 UTC
There's a lot of noise in here from a python unicode vs. str bug that has since been resolved. I'm going to close this bug and clear the abrt hash. If anyone still experiences this problem, please submit a new bug and hopefully it will upload new logs.

*** This bug has been marked as a duplicate of bug 1177273 ***


Note You need to log in before you can comment on or make changes to this bug.