Bug 1221774 - Anaconda crashes with multiple errors on Dell XPS 15
Summary: Anaconda crashes with multiple errors on Dell XPS 15
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 22
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1177273 1206098
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-14 19:27 UTC by Stephen Gallagher
Modified: 2015-06-17 21:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 20:28:14 UTC
Type: Bug


Attachments (Terms of Use)
FIrst of three simultaneous error dialogs (554.22 KB, text/plain)
2015-05-14 19:27 UTC, Stephen Gallagher
no flags Details
Second of three simultaneous error dialogs (555.25 KB, text/plain)
2015-05-14 19:30 UTC, Stephen Gallagher
no flags Details
Third of three simultaneous error dialogs (554.42 KB, text/plain)
2015-05-14 19:32 UTC, Stephen Gallagher
no flags Details
System hardware information (11.69 KB, text/plain)
2015-05-14 19:33 UTC, Stephen Gallagher
no flags Details

Description Stephen Gallagher 2015-05-14 19:27:55 UTC
Created attachment 1025570 [details]
FIrst of three simultaneous error dialogs

Description of problem:
When starting liveinst on a Fedora 22 Workstation Final TC3 Live image, anaconda crashes with three simultaneous blivet errors (see attachments). This is on a Dell XPS 15 system with a pre-existing drive containing a Windows 7 installation.

Version-Release number of selected component (if applicable):
python-blivet-1.0.9-1.fc22.noarch
anaconda-22.20.12-1.fc22.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. Boot the live image
2. Start liveinst

Actual results:
Within a few seconds of starting, anaconda crashes with three crash dialogs.


Expected results:
Anaconda should proceed as normal and install the system. Patches with more detail incoming.


Additional info:

Comment 1 Stephen Gallagher 2015-05-14 19:30:37 UTC
Created attachment 1025571 [details]
Second of three simultaneous error dialogs

Comment 2 Stephen Gallagher 2015-05-14 19:32:14 UTC
Created attachment 1025572 [details]
Third of three simultaneous error dialogs

Comment 3 Stephen Gallagher 2015-05-14 19:33:41 UTC
Created attachment 1025574 [details]
System hardware information

Comment 4 Stephen Gallagher 2015-05-14 19:38:04 UTC
One of the three errors I hit appears to be BZ #1206098

Comment 5 Fedora Blocker Bugs Application 2015-05-14 19:41:12 UTC
Proposed as a Blocker for 22-final by Fedora user sgallagh using the blocker tracking app because:

 "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces."
and
"The user must be able to select which of the disks connected to the system will be affected by the installation process."
seem to be the most relevant, but this is also borderline "The installer must run when launched normally from the release-blocking images."

Comment 6 Stephen Gallagher 2015-05-14 20:15:30 UTC
Removing blocker request. This is likely a hardware failure, rather than a general issue.

Comment 7 Stephen Gallagher 2015-05-14 20:28:14 UTC
Yup, switching out the drive made things work. Sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.