Bug 1178119 - Package is outdated, please update to the latest version
Summary: Package is outdated, please update to the latest version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: poedit
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mario Blättermann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1029927 1076883 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-02 12:35 UTC by Mario Blättermann
Modified: 2015-01-27 03:06 UTC (History)
6 users (show)

Fixed In Version: poedit-1.7.3-4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-27 03:06:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Mario Blättermann 2015-01-02 12:35:10 UTC
Our current Poedit package in both F21 and Rawhide is more than two years old, that version has been released on October 7, 2012. A few newer releases happened since then, the latest version is 1.7.1. This has a reworked GUI, is based on the latest GTK3 and comes with a undo/redo feature what I'm awaiting for years.

I've updated the package, the source rpm is available from [1]. For testing purposes, I've created a temporary copr repo [2].

[1] https://mariobl.fedorapeople.org/Packages/SRPMS/poedit-1.7.1-1.fc21.src.rpm
[2] https://copr.fedoraproject.org/coprs/mariobl/poedit-latest/

Some notes about rpmlint:

I get an error message that the source tarball is not available:

poedit.spec: I: checking-url https://github.com/vslavik/poedit/releases/download/v1.7.1-oss/poedit-1.7.1.tar.gz (timeout 10 seconds)
poedit.spec: W: invalid-url Source0: https://github.com/vslavik/poedit/releases/download/v1.7.1-oss/poedit-1.7.1.tar.gz HTTP Error 403: Forbidden
The value should be a valid, public HTTP, HTTPS, or FTP URL.

But I'm able to download the tarball properly using wget:

$ wget https://github.com/vslavik/poedit/releases/download/v1.7.1-oss/poedit-1.7.1.tar.gz
--2015-01-02 13:19:33--  https://github.com/vslavik/poedit/releases/download/v1.7.1-oss/poedit-1.7.1.tar.gz
Auflösen des Hostnamen »github.com (github.com)«... 192.30.252.131
Verbindungsaufbau zu github.com (github.com)|192.30.252.131|:443... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 302 Found
Platz: https://s3.amazonaws.com/github-cloud/releases/477156/bf2445a4-7cac-11e4-8b1f-debbeff4fe1a.gz?response-content-disposition=attachment%3B%20filename%3Dpoedit-1.7.1.tar.gz&response-content-type=application/octet-stream&AWSAccessKeyId=AKIAISTNZFOVBIJMK3TQ&Expires=1420201233&Signature=TWI0qUSU9VNMRf0VDJzoL5NRlxU%3D[folge]
--2015-01-02 13:19:33--  https://s3.amazonaws.com/github-cloud/releases/477156/bf2445a4-7cac-11e4-8b1f-debbeff4fe1a.gz?response-content-disposition=attachment%3B%20filename%3Dpoedit-1.7.1.tar.gz&response-content-type=application/octet-stream&AWSAccessKeyId=AKIAISTNZFOVBIJMK3TQ&Expires=1420201233&Signature=TWI0qUSU9VNMRf0VDJzoL5NRlxU%3D
Auflösen des Hostnamen »s3.amazonaws.com (s3.amazonaws.com)«... 54.231.34.104
Verbindungsaufbau zu s3.amazonaws.com (s3.amazonaws.com)|54.231.34.104|:443... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 1938119 (1,8M) [application/octet-stream]
In »»poedit-1.7.1.tar.gz«« speichern.

poedit-1.7.1.tar.gz 100%[====================>]   1,85M   596KB/s   in 3,2s   

2015-01-02 13:19:38 (596 KB/s) - »»poedit-1.7.1.tar.gz«« gespeichert [1938119/1938119]

So I assume it is OK to use the GitHub location. Downloads from SourceForge are no longer available.


Due to the long time nobody has updated the package, I assume some help with maintaining the package would be useful. Would you accept me as a co-maintainer of the poedit package? I'm using it every day, already for almost ten years.

Comment 1 Mario Blättermann 2015-01-02 13:36:01 UTC
"BuildRequires: zip" is superfluous, it is required by bzip2-libs. That one is part of the minimum build environment [1], bz2-libs is pulled in by bzip2. I've tested it on Koji [2].

[1] http://fedoraproject.org/wiki/Packaging:Guidelines#Exceptions_2
[2] http://koji.fedoraproject.org/koji/taskinfo?taskID=8512849

Comment 2 c72578 2015-01-03 10:29:40 UTC
Hello Mario,
thank you very much for caring about an updated Poedit package version for Fedora, which I really appreciate.
The package is working fine for me so far. Also a German man file has been included in this package.

One warning has already been reported upstream to the author, so that the semicolon gets added there:

"poedit.desktop: warning: key "MimeType" is a list and does not have a semicolon as trailing character, fixing"

Regards,
Wolfgang

Comment 3 Mario Blättermann 2015-01-03 11:48:52 UTC
(In reply to c72578 from comment #2)
> "poedit.desktop: warning: key "MimeType" is a list and does not have a
> semicolon as trailing character, fixing"
> 
That's the purpose of running "desktop-file-install" while building the package. This fixes such things.

Hopefully some maintainer (or even provenpackager) responses soon... As I already wrote, I'm willing to co-maintain this package.

Comment 4 Haïkel Guémar 2015-01-07 16:11:52 UTC
@Mario: if you want to help, please start packaging the missing dependencies required by latest poedit releases. Co-maintainers are always welcome.

Comment 5 Mario Blättermann 2015-01-07 20:27:56 UTC
(In reply to Haïkel Guémar from comment #4)
> @Mario: if you want to help, please start packaging the missing dependencies
> required by latest poedit releases. Co-maintainers are always welcome.

We don't need to package any new dependencies. Well, Poedit switched from GTK2 to GTK3 recently, but even wxGTK3 and lucene++ are already available in sufficient versions in F21. Have a look at my Copr repo:
https://copr.fedoraproject.org/coprs/mariobl/poedit-latest/builds/

I've requested commit access to the Git repo.

Comment 6 hguemar 2015-01-08 16:29:33 UTC
@Mario: great, lucene++ wasn't packaged few months ago.
ACLs approved, I also reassign this ticket to you. Thanks !

Comment 7 Fedora Update System 2015-01-08 22:38:02 UTC
poedit-1.7.1-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/poedit-1.7.1-3.fc21

Comment 8 Fedora Update System 2015-01-09 11:54:46 UTC
Package poedit-1.7.1-3.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing poedit-1.7.1-3.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0465/poedit-1.7.1-3.fc21
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-01-11 21:00:01 UTC
poedit-1.7.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/poedit-1.7.3-1.fc21

Comment 10 Fedora Update System 2015-01-14 20:01:34 UTC
poedit-1.7.3-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/poedit-1.7.3-3.fc21

Comment 11 Mario Blättermann 2015-01-14 20:04:14 UTC
(In reply to Fedora Update System from comment #10)
> poedit-1.7.3-3.fc21 has been submitted as an update for Fedora 21.
> https://admin.fedoraproject.org/updates/poedit-1.7.3-3.fc21

This package contains some backports from upstream's Git, which disable the undo/redo chain and make the copy/cut/paste menu entries working. Besides that, an appdata file has been added to let it appear in appropriate software applications.

Comment 12 Fedora Update System 2015-01-15 19:42:48 UTC
poedit-1.7.3-4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/poedit-1.7.3-4.fc21

Comment 13 Mario Blättermann 2015-01-15 20:00:16 UTC
*** Bug 1029927 has been marked as a duplicate of this bug. ***

Comment 14 Mario Blättermann 2015-01-15 20:03:43 UTC
*** Bug 1076883 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2015-01-27 03:06:14 UTC
poedit-1.7.3-4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.