Bug 117927 - cmi_8330 audio not detected
Summary: cmi_8330 audio not detected
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
: 117926 119960 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2004-03-10 05:54 UTC by G.Wolfe Woodbury
Modified: 2014-03-17 02:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-08 15:51:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
kudzu -p -b isapnp for FC3T1 (612 bytes, text/plain)
2004-07-15 04:15 UTC, G.Wolfe Woodbury
no flags Details

Description G.Wolfe Woodbury 2004-03-10 05:54:36 UTC
Description of problem:

Kudzu fails to detect/configure CMI_8330 sound system

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install development tree
2. reboot with CMI_8330 enabled
Actual results:
nothing is detected/configured

Expected results:
Kudzu should detect/configure using snd_cmi8330 module

Additional info:
Asus P5A-B motherboard sound system, AMD K6-2 CPU @ 333MHz

Comment 1 Bill Nottingham 2004-03-10 05:57:04 UTC
The kernel is no longer exporting ISAPnP maps.

Comment 2 Bill Nottingham 2004-03-10 16:37:58 UTC
*** Bug 117926 has been marked as a duplicate of this bug. ***

Comment 3 G.Wolfe Woodbury 2004-04-04 06:50:08 UTC
install from "development" 4/3/04 still has problems with CMI 8330.
Kernel detects card and "fixes" DMA and interrupts, but kudzu doesn't
find the card to configure it.  (I did cheat during the install and
force a modprobe for the 3Com 509 Etherlink III card, and anaconda
configured it then. [117926])

Will file bug against kudzu now.

Comment 4 Bill Nottingham 2004-04-05 19:15:37 UTC
*** Bug 119960 has been marked as a duplicate of this bug. ***

Comment 5 G.Wolfe Woodbury 2004-04-19 06:10:33 UTC
As of rawhide 4/17/04 this bug is still occurring.
Kernel doesn't see the card, kudzu doesn't see the card, and soundcard
detection doesn't see the card.

I modprobed the snd-cmi8330.ko and then ran soundcard detection and it
still doesn't see the card properly.

Comment 6 G.Wolfe Woodbury 2004-04-29 08:42:07 UTC
FC2test3 still cannot find/configure the CMI-8330 controller.

Comment 7 G.Wolfe Woodbury 2004-05-10 04:34:59 UTC
Fresh install from development(rawhide) of 2004.05.09 still cannot
detect or setup snd-cmi8330 ISA based soundcard.

Comment 8 Alex Kanavin 2004-05-20 20:58:40 UTC
Have the same problem with Sound Blaster Vibra16X PnP on FC2. 
Bill, what does "The kernel is no longer exporting ISAPnP maps" mean? 

As far as I see, the kernel detects and configures the card just fine
(dmesg output), but kudzu does not see it. So I had to add

alias sound-slot-0 snd-sb16

to /etc/modproble.conf by hand. Could it be that module name change
broke something? 

Comment 9 Bill Nottingham 2004-05-21 17:13:40 UTC
Do you have a /proc/isapnp? ISTR that that moved in 2.6. (Sorry, my
isapnp test box isn't available ATM.)

Comment 10 Alex Kanavin 2004-05-21 17:28:53 UTC
No /proc/isapnp here, but I have a /proc/bus/isapnp/ directory. I'm
not sure if that's the same thing.

Comment 11 G.Wolfe Woodbury 2004-05-30 17:54:58 UTC
bug still present in kernel 2.6.6-1.397 and current kudzu and
system-config-soundcard.  Device is not detected and configured.

Comment 12 G.Wolfe Woodbury 2004-07-14 16:57:10 UTC
As of FC3t1 the system still doesn't properly detect and configure
this ISA device.  Does anyone really care about this?

Comment 13 Bill Nottingham 2004-07-14 18:58:56 UTC
What does kudzu -p -b isapnp say?

Comment 14 Alex Kanavin 2004-07-14 19:05:12 UTC
On my FC2 it says exactly nothing.

Comment 15 Bill Nottingham 2004-07-14 19:10:03 UTC
On FC2 it won't; I was curious about the results on FC3t1.

Comment 16 Bill Nottingham 2004-07-14 19:10:46 UTC
Actually, more specifically, the results with kudzu-1.1.71-1.

Comment 17 Alex Kanavin 2004-07-14 19:40:01 UTC
Updated to kudzu-1.1.72-1

class: UNSPEC
detached: 0
driver: ns558
desc: "CTL00f0 - CTL7005"
deviceId: CTL7005
pdeviceId: CTL00f0
compat: PNPb02f
class: AUDIO
detached: 0
driver: snd-sb16
desc: "CTL00f0 - CTL0043"
deviceId: CTL0043
pdeviceId: CTL00f0

Also, if I remove /etc/modprobe.conf and /etc/sysconfig/hwdata the
card is detected and installed fine now, except for the
non-descriptive description (above). Oh, and I get the following

Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 412, in ?
NameError: name 'hardware_state' is not defined

Comment 18 Bill Nottingham 2004-07-14 19:42:56 UTC
Hm, that bug is a system-config-display bug, should be unrelated.

The non-descriptive description is because the ISAPnP stuff the kernel
exports via sysfs has basically *no* user-useful strings attached to
it, and we don't have a built up table of what everything is.

Comment 19 Alex Kanavin 2004-07-14 20:02:30 UTC
But there is something user-useful!

[root@cs181035096 /]# cat /sys/devices/pnp0/00:01/name
Creative ViBRA16X PnP

Comment 20 G.Wolfe Woodbury 2004-07-15 04:14:28 UTC
I'm attaching the output of kudzu -p -b isapnp in the next comment. 
There are several possible recognizable patterns, and kudzu does tag
the audio driver right, but there is no proper setup of the device.

Comment 21 G.Wolfe Woodbury 2004-07-15 04:15:44 UTC
Created attachment 101930 [details]
kudzu -p -b isapnp for FC3T1

Comment 22 Bill Nottingham 2004-07-20 16:27:05 UTC
Is that entry already in /etc/sysconfig/hwconf?

If so, does it configure it if you remove it?

Comment 23 G.Wolfe Woodbury 2004-07-21 20:58:38 UTC
Will test, however, the 3c509 still isn't detected as an network card
during installation or firstboot.

Comment 24 Bill Nottingham 2004-07-21 21:19:36 UTC
ISAPnP network cards have never been supported for install, AFAIK.

Comment 25 G.Wolfe Woodbury 2004-07-21 21:24:12 UTC
Kudzu detects and re-configs the cmi8330 on re-boot.

re: the 3c509, install used to detect the card and list it during the
network setup (FC1 still does).  Now it sees it only if I modprobe the
driver before the network screen comes up.  This should be a separate
bug, no?

Comment 26 Bill Nottingham 2004-07-21 21:26:20 UTC

Comment 27 G.Wolfe Woodbury 2004-09-28 15:38:27 UTC
Rawhide of 2004-09-27 properly handles the CMI-8330 card.

Comment 28 Bill Nottingham 2004-09-28 16:27:04 UTC
Leaving open, I'd like to get the naming cleaned up as stated earlier
in the bug.

Comment 29 Bill Nottingham 2004-12-08 15:51:25 UTC
The naming for ISAPnP should be better in FC3.

Note You need to log in before you can comment on or make changes to this bug.