Bug 1182363 - [RFE][HC] - when creating a glusterfs volume unsupported volume types should be hidden in the downstream product
Summary: [RFE][HC] - when creating a glusterfs volume unsupported volume types should ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.5.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.0.0-rc3
: 4.0.0
Assignee: Sahina Bose
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: RHEV_HyperConverged_SLA 1177769 Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2015-01-14 23:22 UTC by Paul Cuzner
Modified: 2016-08-23 20:22 UTC (History)
16 users (show)

Fixed In Version: ovirt-4.0.0-5
Doc Type: Enhancement
Doc Text:
This update ensures that only supported volume types are displayed when managing volumes in the Manager.
Clone Of:
Environment:
Last Closed: 2016-08-23 20:22:22 UTC
oVirt Team: Gluster
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1743 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0 GA Enhancement (ovirt-engine) 2016-09-02 21:54:01 UTC
oVirt gerrit 57136 master NEW webadmin: gluster vol defaults in case of HC cluster 2016-05-06 13:11:07 UTC

Description Paul Cuzner 2015-01-14 23:22:33 UTC
Description of problem:
upstream glusterfs provides striped, erasure coding etc - but these volume types are not supported downstream. Creating a volume with RHEVM (or RHSC) shows these unsupported volume types which may lead to user error/confusion/support calls.

Version-Release number of selected component (if applicable):
3.5

How reproducible:


Steps to Reproduce:
1. Follow the steps to create a glusterfs volume
2. observe the pull down list includes striped volume variants
3.

Actual results:
Use could created unsupported volumes

Expected results:
User should only be able to create volumes with the downstream product that are supported by Red Hat

Additional info:

Comment 1 Sahina Bose 2015-01-16 14:19:42 UTC
Kanagaraj, don't we have a tech preview warning with these types?

Comment 2 Kanagaraj 2015-01-19 04:11:24 UTC
I think its only in RHSC downstream but not in RHEVM

Comment 3 Yaniv Lavi 2016-05-09 11:06:01 UTC
oVirt 4.0 Alpha has been released, moving to oVirt 4.0 Beta target.

Comment 8 Sahina Bose 2016-06-16 13:30:24 UTC
Patch is merged in the 4.0 branch, moving this to ON_QA

Comment 9 Yaniv Lavi 2016-06-19 14:11:47 UTC
Can you attach the patch to the bug?

Comment 10 Eyal Edri 2016-06-19 15:54:52 UTC
This bug is missing the require_doc_text flag.
Can you please update doc_text and the flag please?

Comment 11 Sahina Bose 2016-06-20 04:39:39 UTC
(In reply to Yaniv Dary from comment #9)
> Can you attach the patch to the bug?

http://gerrit.ovirt.org/57136 - is present in the 4.0 branch. The branch was created after this patch was merged.

Comment 12 RamaKasturi 2016-08-10 12:15:18 UTC
Verified with  Red Hat Virtualization Manager Version: 4.0.1.1-0.1.el7ev

Only volume types Distribute, Replicate and Distributed-replicate are displayed while creating a new volume.

Comment 14 errata-xmlrpc 2016-08-23 20:22:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html


Note You need to log in before you can comment on or make changes to this bug.