Bug 118400 - gpdf is unable to show documents.
Summary: gpdf is unable to show documents.
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gpdf   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
: 128354 (view as bug list)
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2004-03-16 12:49 UTC by Leonid Kanter
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 15:50:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leonid Kanter 2004-03-16 12:49:36 UTC
Description of problem:

Looks like current gpdf is completely broken. It's unable to show any
document correctly. In some documents it show underline characters in
place of regular text, with other documents it's simply falling down. 

Version-Release number of selected component (if applicable):

gpdf-0.124-1

How reproducible:

always

Steps to Reproduce:
1. gpdf /usr/share/doc/pam-0.77/pdf/pam.pdf

  
Actual results:

You'll see white page with some horisontal lines on it.

Expected results:

display must be the same like in xpdf or ggv applications.

gpdf is currently the default pdf viewer application, so this behavior
is a showstopper. If it cannot be fixed, maybe ggv can be configured
as the default pdf viewer - it works perfectly.

Comment 1 Alexander Larsson 2004-03-16 13:40:21 UTC
It works fine for other documents, such as
/usr/share/doc/cups-1.1.20/translation.pdf.


Comment 2 Alexander Larsson 2004-03-16 13:52:04 UTC
Filed upstream as http://bugzilla.gnome.org/show_bug.cgi?id=137365

Comment 3 Warren Togami 2004-04-18 13:57:07 UTC
/usr/share/doc/pam-0.77/pdf/pam.pdf seems unchanged by the
http://people.redhat.com/wtogami/temp/ eexec freetype patch.  This
confirms this is a separate gpdf issue from Bug #117743.

Comment 4 Colin Charles 2004-05-07 12:51:40 UTC
Still occurs in gpdf-0.131-2, from fedora development latest. Upstream
bug hasn't changed status either.

Comment 5 Chris Thomas 2004-05-16 00:23:44 UTC
Confirmed: I have gpdf-0.131-2 and documents that dont display
corectly, display perfectly with ggv.

Comment 6 Bryan W Clark 2004-08-26 04:41:31 UTC
Just to check point, gpdf-2.7.90-2 still has this same issue and the
upstream bug is still open.  I'll try to ping Martin sometime soon
when I get the chance to chat with him.

Comment 7 Bryan W Clark 2004-08-26 05:17:57 UTC
*** Bug 128354 has been marked as a duplicate of this bug. ***

Comment 8 Matthias Clasen 2004-10-15 20:28:31 UTC
gpdf 2.8.0 in test3 is still unable to display 
/usr/share/doc/pam-0.77/pdf/pam.pdf

Comment 9 Marco Pesenti Gritti 2004-11-06 13:47:51 UTC
The upstream bug has been marked as a dup of:

http://bugzilla.gnome.org/show_bug.cgi?id=112506

Apparently not easy to solve :/

Comment 10 Dan Williams 2004-11-17 18:24:47 UTC
Mass reassign to Marco.

Comment 11 Ray Strode [halfline] 2005-03-24 15:50:33 UTC
Hi Leonid,

In FC4, we will be shipping Evince in place of gpdf.  It offers nicer rendering,
page thumbnails, and a very nice search interface.  

If you have any issues with Evince please file bugs under the evince component.
 Thanks.


Note You need to log in before you can comment on or make changes to this bug.