Bug 117743 - [PATCH] freetype eexec bug causes gpdf hangs on PDF from oowriter
[PATCH] freetype eexec bug causes gpdf hangs on PDF from oowriter
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Brock Organ
:
: 115689 120215 120233 120516 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-07 21:01 EST by William Hooper
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 14:43:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample PDF file (113.37 KB, application/pdf)
2004-03-07 21:02 EST, William Hooper
no flags Details

  None (edit)
Description William Hooper 2004-03-07 21:01:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040211 Firefox/0.8

Description of problem:
I created a simple test PDF from oowriter (openoffice.org-1.1.0-29)
with just the sentance "This is a test".  It displays fine in xpdf and
in the FC1 version of gpdf.  See attached PDF.  The best I can tell
this isn't the Type 3 font issue of bug 109786.  It doesn't seem to
matter if I use the toolbar button or File -> Export as PDF.

Version-Release number of selected component (if applicable):
gpdf-0.123-2
Comment 1 William Hooper 2004-03-07 21:02:20 EST
Created attachment 98364 [details]
Sample PDF file
Comment 2 Alexander Larsson 2004-03-15 11:40:58 EST
I filed this upstream so that the maintainer can look at it:

http://bugzilla.gnome.org/show_bug.cgi?id=137263
Comment 3 Alexander Larsson 2004-03-16 03:22:41 EST
It turns out this was a bug in freetype.
See:

http://bugzilla.gnome.org/show_bug.cgi?id=129400
Comment 4 Alexander Larsson 2004-03-16 03:26:43 EST
*** Bug 115689 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Larsson 2004-04-13 10:59:33 EDT
*** Bug 120516 has been marked as a duplicate of this bug. ***
Comment 6 Warren Togami 2004-04-18 09:53:44 EDT
http://people.redhat.com/wtogami/temp/
I copied test patch i386 RPMS and SRPM here for others to easily test
and confirm.  I have confirmed that it works on my i386, and dwmw said
it works on his FC2 ppc.
Comment 7 Warren Togami 2004-04-18 13:01:24 EDT
*** Bug 120215 has been marked as a duplicate of this bug. ***
Comment 8 Scott Sloan 2004-04-18 14:32:54 EDT
*** Bug 120233 has been marked as a duplicate of this bug. ***
Comment 9 William Hooper 2004-04-18 17:40:11 EDT
The RPMs from Comment #6 fix it for me on i386 also.
Comment 10 Warren Togami 2004-04-19 14:43:46 EDT
rawhide tomorrow
copying to fedora.us RPMS.updates now

Note You need to log in before you can comment on or make changes to this bug.