Bug 118507 - Missing perl module Logwatch.pm in daily status mail causes error
Missing perl module Logwatch.pm in daily status mail causes error
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: logwatch (Show other bugs)
1.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
: 118565 118736 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-17 02:15 EST by Robert Scheck
Modified: 2007-03-27 00:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 09:53:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-03-17 02:15:21 EST
Description of problem:
The following is copied from my daily status mail generated by 
logwatch:

--- snipp ---
Can't locate Logwatch.pm in @INC (@INC contains: /etc/log.d//lib /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
+/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
+/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl
+/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 .) at /etc/log.d/scripts/services/kernel line 24.
BEGIN failed--compilation aborted at /etc/log.d/scripts/services/kernel line 24.

 ---------------------- Kernel End -------------------------
--- snapp --

Only errors in that mail :-(

Version-Release number of selected component (if applicable):
logwatch-5.1-2

How reproducible & Steps to Reproduce:
1. Get logwatch-5.1-2 from Rawhide
2. Rebuild it
3. Test it
  
Actual results:
The perl Module "Logwatch.pm" isn't installed (forgotten?).

Expected results:
--- logwatch.spec       2004-03-17 08:08:20.000000000 +0100
+++ logwatch.spec.rsc   2004-03-17 08:13:00.000000000 +0100
@@ -30,6 +30,7 @@

 %install
 rm -rf %{buildroot}
+install -m 0755 -d %{buildroot}%{_sysconfdir}/log.d/lib
 install -m 0755 -d %{buildroot}%{_sysconfdir}/log.d/conf/logfiles
 install -m 0755 -d %{buildroot}%{_sysconfdir}/log.d/conf/services
 install -m 0755 -d %{buildroot}%{_sysconfdir}/log.d/scripts/services
@@ -49,6 +50,8 @@
 install -m 0644 conf/logfiles/* %{buildroot}%{_sysconfdir}/log.d/conf/logfiles
 install -m 0644 conf/services/* %{buildroot}%{_sysconfdir}/log.d/conf/services

+install -m 0644 lib/Logwatch.pm %{buildroot}%{_sysconfdir}/log.d/lib/Logwatch.pm
+
 install -m 0755 -d %{buildroot}%{_mandir}/man8
 install -m 0644 logwatch.8 %{buildroot}%{_mandir}/man8

@@ -100,12 +103,16 @@
 %{_sysconfdir}/log.d/scripts/logfiles/xferlog/*
 %{_sysconfdir}/log.d/logwatch
 %{_sysconfdir}/log.d/logwatch.conf
+%{_sysconfdir}/log.d/lib/Logwatch.pm
 %{_sysconfdir}/cron.daily/00-logwatch
 %{_mandir}/man8/logwatch.8*

Additional info:
After changing my spec file to that written above, all works fine, 
so please solve that problem. Thank you :)
Comment 1 Elliot Lee 2004-03-17 09:53:25 EST
Thanks for coming up with the correct fix to this problem :)
Comment 2 Bill Nottingham 2004-03-18 00:56:53 EST
*** Bug 118565 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2004-03-19 16:11:42 EST
*** Bug 118736 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.