Bug 119975 - LVM2 is not setup after installation
Summary: LVM2 is not setup after installation
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 118787 (view as bug list)
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-04-04 13:30 UTC by Ronny Buchmann
Modified: 2014-03-17 02:43 UTC (History)
2 users (show)

Fixed In Version: 7.50-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-16 07:28:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for rc.sysinit (873 bytes, patch)
2004-04-04 13:34 UTC, Ronny Buchmann
no flags Details | Diff

Description Ronny Buchmann 2004-04-04 13:30:09 UTC
Description of problem:
- anaconda doens't create /etc/lvm (which is OK, I think)
- rc.sysinit doesn't setup LVM2 if /etc/lvm not present (IMO not OK)
- lvm vgscan --mknodes exits with code 5

Detailed error messages are in bug 118787 and bug 119964.

Version-Release number of selected component (if applicable):
initscripts-7.49-1
lvm2-2.00.08-5

How reproducible:
always after fresh-install and no manual intervention

Steps to Reproduce:
1. do a fresh install using LVM
2. start system
  
Actual results:
errors fully posted in bug 118787 and bug 119964


Expected results:
startup without errors

Solution:
vgmknodes should be called after vgchange -a y, not together with vgscan.
/etc/lvm shouldn't be a prerequisite (if we have lvm2 installed, why
shouldn't we try to run it?)

Comment 1 Ronny Buchmann 2004-04-04 13:34:11 UTC
Created attachment 99096 [details]
fix for rc.sysinit

Comment 2 Bill Nottingham 2004-04-16 07:28:59 UTC
lvm2 actually contains /etc/lvm these days.

added in 7.50-1 , thanks!

Comment 3 Jeremy Katz 2004-05-06 21:43:35 UTC
*** Bug 118787 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.