Bug 1188346 - [RFE] Add email configuration settings to katello-installer
Summary: [RFE] Add email configuration settings to katello-installer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1080617 (view as bug list)
Depends On:
Blocks: 1130651 1188301
TreeView+ depends on / blocked
 
Reported: 2015-02-02 16:30 UTC by sthirugn@redhat.com
Modified: 2019-09-26 18:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:47:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 5824 Normal Resolved Configure Rails email settings 2020-04-08 14:04:02 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Internal Links: 1264038

Description sthirugn@redhat.com 2015-02-02 16:30:50 UTC
Description of problem:
Satellite 6.1 is introducing email notifications.  Basic email configuration settings should be configurable in the katello-installer - Ref: http://www.theforeman.org/manuals/1.7/index.html

Version-Release number of selected component (if applicable):
N/A

How reproducible:
N/A

Steps to Reproduce:
N/A

Actual results:
N/A

Expected results:
N/A

Additional info:

Comment 2 Bryan Kearney 2015-04-17 18:13:26 UTC
Created redmine issue http://projects.theforeman.org/issues/10179 from this bug

Comment 3 Bryan Kearney 2015-04-20 11:57:59 UTC
*** Bug 1080617 has been marked as a duplicate of this bug. ***

Comment 4 Bryan Kearney 2015-04-20 11:58:08 UTC
Connecting redmine issue http://projects.theforeman.org/issues/5824 from this bug

Comment 5 Bryan Kearney 2015-08-25 18:33:16 UTC
Upstream bug component is Installer

Comment 6 Bryan Kearney 2015-12-01 15:05:45 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/5824 has been closed
-------------
Stephen Benjamin
User contributed some documentation related to email.yml which is really useful:
  https://github.com/theforeman/theforeman.org/pull/280/files

Is documentation sufficient for this issue or do we want to add some options to the installer to configure email.yml?

Comment 11 sthirugn@redhat.com 2016-04-07 15:30:54 UTC
Verified in satellite-6.2.0-6.2.beta.el7sat.noarch.  I passed in the following parameters and they are set properly in satellite.

foreman-installer --scenario katello --foreman-admin-email='***' \
 --foreman-email-delivery-method='smtp' \
 --foreman-email-smtp-address='smtp.*****' \
 --foreman-email-smtp-authentication='none' \
 --foreman-email-smtp-domain=*** \
 --foreman-email-smtp-port=25 \

Comment 13 errata-xmlrpc 2016-07-27 08:47:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.