Bug 118941 - Anaconda does not find IDE hard drives *or network*, kernel does.
Anaconda does not find IDE hard drives *or network*, kernel does.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
: 119550 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-22 18:32 EST by Chris Kloiber
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 13:39:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error message on ALT-F1 (333.95 KB, image/jpeg)
2004-03-22 18:42 EST, Chris Kloiber
no flags Details
Kernel finds drive if you 'mknod /dev/hda' (ALT-F2) (402.26 KB, image/jpeg)
2004-03-22 18:43 EST, Chris Kloiber
no flags Details
Where are we in the install when this happens? (ALT-F3) (394.57 KB, image/jpeg)
2004-03-22 18:43 EST, Chris Kloiber
no flags Details
Random stuff from ALT-F4 (383.98 KB, image/jpeg)
2004-03-22 18:44 EST, Chris Kloiber
no flags Details
/mnt/syslog (49.86 KB, text/plain)
2004-03-22 21:30 EST, Chris Kloiber
no flags Details
/tmp/anaconda.log (5.73 KB, text/plain)
2004-03-22 21:30 EST, Chris Kloiber
no flags Details
anaconda log from HP zv5000z AMD64 nForce3 notebook (6.38 KB, text/plain)
2004-03-29 21:45 EST, Brian Stretch
no flags Details
syslog from HP zv5000z AMD64 nForce3 notebook (20.64 KB, text/plain)
2004-03-29 21:46 EST, Brian Stretch
no flags Details
FC2 T2 Installing successfully after using blank (no partitions) drive (350.33 KB, image/jpeg)
2004-04-01 03:24 EST, Mike Larkin
no flags Details

  None (edit)
Description Chris Kloiber 2004-03-22 18:32:21 EST
Description of problem:

Attempting to install any recent FC2-test2_x86_64 tree, (and
incidentally the RHEL4-alpha1) to my eMachines M6807 AMD64 laptop,
Anaconda claims there are no hard drives found to install to. However
if you drop into <ALT><F2> and 'mknod /dev/hda ; fdisk /dev/hda' you
will see the hard drive just fine.

Some digital pictures will be attached for your viewing pleasure.

Also, Anaconda completely misses probing the video and mouse, although
once I showhorned all the rpms onto the machine the new xorg-x11 does
indeed support this video adapter. (This could be due to missing pci
id's in /usr/share/hwdata/pcitable that are listed in
/usr/share/hwdata/pci.ids. In this case missing: 1002 4e50 "RV350
[Mobility Radeon 9600 M10]", but there are many others.) The mouse is
a synaptics touchpad (works like a 3 button wheel mouse).
Comment 1 Chris Kloiber 2004-03-22 18:42:03 EST
Created attachment 98763 [details]
Error message on ALT-F1
Comment 2 Chris Kloiber 2004-03-22 18:43:08 EST
Created attachment 98764 [details]
Kernel finds drive if you 'mknod /dev/hda' (ALT-F2)
Comment 3 Chris Kloiber 2004-03-22 18:43:59 EST
Created attachment 98765 [details]
Where are we in the install when this happens? (ALT-F3)
Comment 4 Chris Kloiber 2004-03-22 18:44:54 EST
Created attachment 98766 [details]
Random stuff from ALT-F4
Comment 5 Jeremy Katz 2004-03-22 19:04:56 EST
Attaching /tmp/syslog and /tmp/anaconda.log will be far more helpful :)
Comment 6 Chris Kloiber 2004-03-22 19:09:55 EST
Undoubtedly, but how? I'm in the middle of a failed install, with no
floppy drive or serial ports. Would a USB pen work at that point? Or
can I perhaps trick the network into coming up and using ssh?
Comment 7 Chris Kloiber 2004-03-22 21:30:13 EST
Created attachment 98769 [details]
/mnt/syslog

USB pendrive didn't work, but I got the network to cooperate...
Comment 8 Chris Kloiber 2004-03-22 21:30:42 EST
Created attachment 98770 [details]
/tmp/anaconda.log
Comment 9 Brian Stretch 2004-03-29 21:45:43 EST
Created attachment 98951 [details]
anaconda log from HP zv5000z AMD64 nForce3 notebook
Comment 10 Brian Stretch 2004-03-29 21:46:30 EST
Created attachment 98952 [details]
syslog from HP zv5000z AMD64 nForce3 notebook
Comment 11 Brian Stretch 2004-03-29 21:50:27 EST
That looks like the same problem I'm having with my HP zv5000z Athlon
64 notebook (nForce3 chipset, not the VIA chipset the eMachines
notebook uses).  I've attached my anaconda.log and syslog.  I used scp
to copy the files to my Linux server.  Nice to have that available.  I
was trying to install from a boot CD and the four FC2 test2 .iso's on
my server via NFS.  linux idle=poll selinux=0 text (idle=poll works
around the unpatched K8 Errata #93 bug in my HP's BIOS). 
Comment 12 graham voysey 2004-03-30 17:23:34 EST
this seems similar to <a
href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118881
">Bug 118881</a>.
Comment 13 Pau Aliagas 2004-03-31 03:02:51 EST
I've tried several ways to overcome the "no IDE drives found" problem
to no success:

1. boot the fedora x86_64 DVD
2. mknod /dev/hda
3. boot with FC1 DVD and change to FC2T2
4. boot with vmlinuz + initrd from the FC2T2 DVD copied into /boot as
   explained in:
   www.redhat.com/archives/fedora-test-list/2004-February/msg00445.html

The previous four methods have already been discussed but didn't work
for me.

4. boot with boot-iso from devel
5. boot with vmlinuz + initrd from the devel tree (same trick than before)

In both cases the hard disk and the cdrom are detected by the kernel,
but anaconda asks for a driver or driver disk.

If I choose Hard Disk, in vt3 it says:
devices[0] is TOSHIBA MK60221GAS - hda using ignore (not loaded)

If I choose Local CDROM, in vt3 it says:
devices[0] is PIONEER DVD-RW-DVR-K12RA - hdc using ignore (not loaded)
Comment 14 Marty Shannon 2004-03-31 21:09:25 EST
*** Bug 119550 has been marked as a duplicate of this bug. ***
Comment 15 Jared Smith 2004-03-31 21:50:37 EST
I'm seing the same problem on an HP d220 desktop machine.  (This is a
Pentium 4 machine, so I guess the problem isn't limited to Athlon64
machines.)  I'd be more than happy to do more testing and be a guinea
pig if you'd like me to.

(For what it's worth, this is one of those machines that CD1 wouldn't
boot in, even though I verified the md5sum before burning, and
verified the disk after burning through the anaconda-runtime iso
checking mechanism.  Booting from a burned boot.iso worked great,
until it couldn't see any IDE CD-ROMs to install from.)
Comment 16 Mike Larkin 2004-04-01 03:24:02 EST
Created attachment 99029 [details]
FC2 T2 Installing successfully after using blank (no partitions) drive
Comment 17 Mike Larkin 2004-04-01 03:25:03 EST
I had the same problem with my M6805 eMachines notebook and was able
to get things working by installing on a completely clean drive with
no partitions.

Now, this is not the best solution for most people, but if you don't
mind wiping things out, it might work. 

This probably points to something wrong in the way
kudzu/partedUtils/isys reads the partition table. If anyone is
interested in the partition table of the drive that _doesn't_ work,
let me know.

PS - I completely replaced the drive with an old 20gb unit I had
laying around, so the smaller capacity may have had something to do
with it working as well (the original unit was 60gb), but I doubt that
it played a part.

PPS - I did not use any kernel cmdline options. 
Comment 18 Chris Kloiber 2004-04-01 04:52:38 EST
I just created a DVD from the rawhide-20040331 tree including the
newer anaconda... No change for me, anaconda still could not find
/dev/hda.

After dd-ing /dev/zero to /dev/hda it did reinitialize the drive and
install, but as mentioned that is sub-optimal... Thanks for the
headsup though, at least I can start using it.
Comment 19 Gene Czarcinski 2004-04-01 06:06:05 EST
This problem you had/have with partition tables and parted may be
related to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=113201

I have a system with two identical Maxtor 60GB drives on hda and hdb.
 The hda drive's partition table was initially done by Win2k when it
was installed.  Further partitioning of the disk was done by fdisk on
FC1.  The hdb drive was partitioned by fdisk on FC1.

FC2, the 2.6 kernel and parted do not like the hda partitioning and
complain.  I have to use the kernel boot hda=c,h,s parameter to get
things done right.  There is no complaint about hdb.
Comment 20 alan santos 2004-04-01 14:34:39 EST
Trying the hda=c,h,s doesn't make any difference for me with an
emachines m6805.
Comment 21 alan santos 2004-04-02 13:58:58 EST
Removing all partitions from HD and then installing worked for me as
well. 
Comment 22 Vincent 2004-04-04 03:15:20 EDT
I'm on a duel boot machine /dev/hda is WindowsXP /dev/hdb is FC2-t2
Whiping out /dev/hda is not an option I have several gigs of data on
it. This machine had FC1 working with the exact same configuration so
when I tried installing again I was greeted with these errors:
                                                                     
                                                       
Unable to align partition properly. This probably means that another
partition tool generated an incorrect partition table, because it
did'nt have the correct BIOS geometry, It is safe to ignore, but
ignoring may cause (fixable) problems with some boot loaders.
                                                                     
                                                       
(I saw this the first time also but assumed (fixable) was nothing to
worry about and clicked okay. The second time around installing I
clicked cancel and came across a new warning):
                                                                     
                                                       
The partition table on device hda was unreadable to create new
partitions it must be initilized, causing the loss of ALL DATA on this
drive.
This operation will overide any previous installation choices about
which drives to ignore.
would you like to initilize this drive, erasing ALL DATA?
                                                                     
                                                       
#fdisk -l
Disk /dev/hda: 122.9 GB, 122942324736 bytes
16 heads, 63 sectors/track, 238216 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes
                                                                     
                                                       
Disk /dev/hdb: 20.4 GB, 20490559488 bytes
255 heads, 63 sectors/track, 2491 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
                                                                     
                                                       
If any other info is needed e-mail me i'll be up all night burning data.
Comment 23 Miguel A Paraz 2004-04-04 04:48:56 EDT
It isn't limited to /dev/hdN devices. I tried installing from a USB
hard disk. Upon choosing the USB Mass Storage option for drivers, I get:

devices[1] is Tekram TR-621 2.5 - sda using ignore (not loaded)

Even while the dmesg screen showed that it was able to open the
partition table. It's a 20 GB disk with a single 16 GB partition.
Comment 24 tszanto 2004-04-07 07:17:13 EDT
I ran into the same problem using a Gigabyte GA-K8VT800 motherboard. 
Everything worked fine in AMD64 Core 1. However, it's interesting 
that the kernel could start without the "idle=poll" parameter, 
apparently Core 1 can only start with idle=poll even with the latest 
(F6) BIOS installed.
    
Comment 25 Chris Kloiber 2004-04-09 22:37:43 EDT
Just tried installing from a tree using
anaconda-9.92-0.20040407220217, but the situation has not improved.
Also I noticed that if I boot the boot.iso and attempt a network
install, the via-rhine driver is loaded, but anaconda claims there is
no network device to install with and presents a list of drivers to
try. via-rhine is not in the list because the module is already
loaded... Is this a udev problem, it's acting like anaconda just has
no /dev entries?
Comment 26 Mikko Kortelainen 2004-04-10 07:00:33 EDT
About that via-rhine missing:

In stage 2 it is detected, and can be configured in the interface
configuration just as usual.
Comment 27 andrej 2004-04-11 06:24:45 EDT
1.)AS TO #22 FROM VINCENT:
2.)AS TO #13 FROM PAU:

1.) AS TO #22 FROM VINCENT: while installing FC2-t1 in order to have a
dual boot system (with WinXPpro) I had similar problems like the ones
you described - after using parted in fact I've gone through the whole
installation - and winXP won't boot any more. 
- checking the disk with Partition Magic on another machine I got a
message, that the geometry specified is incorrect - the disk was de
facto unusable. 
I've been given a hint to use the recovery utilities from WinXPpro
setup disk (image for 6xfddisk, can be found on microsoft's site). It
helped - winXP booted again. 

2.) AS TO #13 FROM PAU: I'm experiencing the same problem 
I've got :
mainboard: Epox 4beav
IDE hdd: 80GB Seagate st380021a
several partitions (primary and extended)- done with some MS tool (I
can't remember if msdos fdisk or some other).

I've currently got a dual boot (FC2-t1 + winxpPro); tried to upgrade
to dual boot with FC2-t2+WINXP; 

I get stuck with the same kind of error message Pau does:

devices[0] is SEAGATE ((drive type)) - hda using ignore (not loaded)
Comment 28 Chris Kloiber 2004-04-14 13:31:26 EDT
Jeremy,

Today's rawhide (20040414) is a *VAST* improvement, Thanks!

The hard drives are detected, as is the video and mouse. (anthough
VESA was used rather than ATI, and the display is not probed.)
Keyboard is an issue, but that's a kernel problem for me, and plugging
in a usb keyboard works for the install. I am backing up my customized
kernel that works with the keyboard and PCMCIA, then I will burn a DVD
and re-install.

Existing installs on the hard drive are detected.

Network installs are still not working, driver is loaded, but anaconda
is not seeing it still. 
Comment 29 Chris Kloiber 2004-04-14 14:46:17 EDT
Next iteration of this problem.

Burned DVD and began resintall, things worked wonderfully up until it
began to install packages. On the first package I received an error
suggesting it could not unmount the CD, and would I make sure I'm not
cd'd into /mnt/source on VT2. (I was not) VT3 shows:

* Unable to copy comps package
* moving (1) to step installpackages
* switching from iso [1,2,3,4] to [] for fedora-logos-1.1.23-1.noarch
* isys.py:mount()- going to mount /tmp/hdc on /mnt/source
* exception was int argument required for fedora-logos-1.1.23-1
* exception in umountCD: isys.umount() can only unmount by mount point

It might help to mention that /mnt/source does not exist anymore.
Comment 30 Jeremy Katz 2004-04-15 13:39:48 EDT
Okay, the DVD handling should be fixed.  I got bitten by an API change
in rpm-python (again).  Network installs is a dupe of 120360.  The
original thing here about the hard drive not being detected being
fixed, I'm going to close this as rawhide.

Note You need to log in before you can comment on or make changes to this bug.