Bug 1189473 - [RFE] While creating a snapshot the timestamp has to be appended to the snapshot name.
Summary: [RFE] While creating a snapshot the timestamp has to be appended to the snaps...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On: 1181108
Blocks: 1311043
TreeView+ depends on / blocked
 
Reported: 2015-02-05 12:40 UTC by Mohammed Rafi KC
Modified: 2016-06-16 12:41 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Enhancement
Doc Text:
Clone Of: 1181108
: 1311043 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:41:05 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-02-05 12:41:10 UTC
REVIEW: http://review.gluster.org/9597 (snapshot:append timestamp with snapname) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-02-06 05:57:01 UTC
REVIEW: http://review.gluster.org/9597 (snapshot:append timestamp with snapname) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Anand Avati 2015-02-17 13:26:51 UTC
REVIEW: http://review.gluster.org/9597 (snapshot:append timestamp with snapname) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 4 Anand Avati 2015-02-20 05:18:07 UTC
REVIEW: http://review.gluster.org/9597 (snapshot:append timestamp with snapname) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 5 Anand Avati 2015-03-06 09:21:16 UTC
REVIEW: http://review.gluster.org/9597 (snapshot:append timestamp with snapname) posted (#5) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 6 Anand Avati 2015-03-06 10:14:35 UTC
REVIEW: http://review.gluster.org/9597 (snapshot:append timestamp with snapname) posted (#6) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 7 Anand Avati 2015-03-09 10:25:21 UTC
REVIEW: http://review.gluster.org/9597 (snapshot:append timestamp with snapname) posted (#7) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 8 Anand Avati 2015-03-09 10:26:46 UTC
REVIEW: http://review.gluster.org/9597 (snapshot:append timestamp with snapname) posted (#8) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 9 Anand Avati 2015-03-09 11:15:57 UTC
REVIEW: http://review.gluster.org/9597 (snapshot: append timestamp with snapname) posted (#9) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 10 Mohammed Rafi KC 2015-03-10 11:23:39 UTC
Initial consumer of this feature is Samba's Shadow Copy
feature. This feature allows Windows user to get previous 
revisions of a file. For this feature to work snapshot 
names under .snaps folder (USS) should have timestamp in 
following format appended:
@GMT-YYYY.MM.DD-hh.mm.ss
PS: https://www.samba.org/samba/docs/man/manpages/vfs_shadow_copy2.8.html
This format is configurable by Samba conf file. Due to a 
limitation in Windows directory access the exact format 
cannot be used by USS. Therefore we have modified the file 
format to:
_GMT-YYYY.MM.DD-hh.mm.ss
Snapshot scheduling feature also required to append timestamp 
to the snapshot name therefore timestamp is appended in 
snapshot creation itself instead of doing the changes in 
snapview server.
More info:
https://www.mail-archive.com/gluster-users@gluster.org/msg18895.html

Comment 11 Anand Avati 2015-03-10 11:42:04 UTC
COMMIT: http://review.gluster.org/9597 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 1ae8b4c33af175545d6afe99aeb7a21896960a35
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Feb 5 16:12:53 2015 +0530

    snapshot: append timestamp with snapname
    
    Appending GMT time stamp with snapname by default.
    If no-timestamp flag is given during snapshot creation,
    then time stamp will not append with snapname;
    
    Initial consumer of this feature is Samba's Shadow Copy
    feature. This feature allows Windows user to get previous
    revisions of a file. For this feature to work snapshot
    names under .snaps folder (USS) should have timestamp in
    following format appended:
    @GMT-YYYY.MM.DD-hh.mm.ss
    
    PS: https://www.samba.org/samba/docs/man/manpages/vfs_shadow_copy2.8.html
    
    This format is configurable by Samba conf file. Due to a
    limitation in Windows directory access the exact format
    cannot be used by USS. Therefore we have modified the file
    format to:
    _GMT-YYYY.MM.DD-hh.mm.ss
    
    Snapshot scheduling feature also required to append timestamp
    to the snapshot name therefore timestamp is appended in
    snapshot creation itself instead of doing the changes in
    snapview server.
    
    More info:
    https://www.mail-archive.com/gluster-users@gluster.org/msg18895.html
    
    Change-Id: Idac24670948cf4c0fbe916ea6690e49cbc832d07
    BUG: 1189473
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/9597
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 12 Anand Avati 2015-03-12 06:40:52 UTC
REVIEW: http://review.gluster.org/9861 (Snapshot:wrong logging is used) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 13 Anand Avati 2015-03-12 08:41:00 UTC
REVIEW: http://review.gluster.org/9861 (Snapshot:wrong logging is used) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 14 Anand Avati 2015-03-12 10:53:03 UTC
REVIEW: http://review.gluster.org/9861 (Snapshot: wrong logging is used) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 15 Anand Avati 2015-03-13 10:30:09 UTC
REVIEW: http://review.gluster.org/9861 (Snapshot:wrong logging is used) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 16 Anand Avati 2015-04-01 09:21:27 UTC
REVIEW: http://review.gluster.org/9861 (Snapshot:wrong logging is used) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 17 Vijay Bellur 2016-02-15 08:53:00 UTC
REVIEW: http://review.gluster.org/9861 (Snapshot:wrong logging is used) posted (#6) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 18 Vijay Bellur 2016-02-23 05:36:05 UTC
COMMIT: http://review.gluster.org/9861 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 1fd7655ab0795e5aa96cdbfb8c522b222734f4f2
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Mar 12 12:09:06 2015 +0530

    Snapshot:wrong logging is used
    
    Change-Id: I56e5f5696fbbb4290f95adb9b68f9e43ed037ed3
    BUG: 1189473
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/9861
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 19 Niels de Vos 2016-06-16 12:41:05 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.