Bug 1194311 - Unexpected warning output installing Satellite 6.1 on RHEL 6.6 when running yum install katello
Summary: Unexpected warning output installing Satellite 6.1 on RHEL 6.6 when running y...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.1.0
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-19 14:36 UTC by Alex Krzos
Modified: 2019-11-14 06:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:48:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
complete yum install katello output (547.41 KB, text/plain)
2015-02-19 14:36 UTC, Alex Krzos
no flags Details
For `yum install katello` on RHEL 7.1 (613.46 KB, text/plain)
2015-07-23 17:02 UTC, DipenDevra
no flags Details
Satellite 6.2 Beta Snap 8.1 - yum install log (550.25 KB, text/plain)
2016-04-15 14:35 UTC, Brad Buckingham
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Alex Krzos 2015-02-19 14:36:25 UTC
Created attachment 993641 [details]
complete yum install katello output

Description of problem:
There are several warning when installing the Satellite 6 Installer on RHEL 6.6:


  Installing : candlepin-selinux-0.9.41-1.el6.noarch                                                                                                                                                                   248/460
  Installing : gutterball-1.0.10-1.el6.noarch                                                                                                                                                                          249/460
warning: user tomcat does not exist - using root
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
....
warning: group tomcat does not exist - using root
warning: user tomcat does not exist - using root
  Installing : python-itsdangerous-0.23-1.el6_6sat.noarch                                                                                                                                                              250/460
  Installing : 1:python-flask-0.10.1-4.el6_6sat.noarch                                                                                                                                                                 251/460


  Installing : python-crane-0.2.2-1.el6_6sat.noarch                                                                                                                                                                    258/460
SELinux:  Could not downgrade policy file /etc/selinux/targeted/policy/policy.24, searching for an older version.
SELinux:  Could not open policy file <= /etc/selinux/targeted/policy/policy.24:  No such file or directory
libsemanage.semanage_reload_policy: load_policy returned error code 2.
SELinux:  Could not downgrade policy file /etc/selinux/targeted/policy/policy.24, searching for an older version.
SELinux:  Could not open policy file <= /etc/selinux/targeted/policy/policy.24:  No such file or directory
libsemanage.semanage_reload_policy: load_policy returned error code 2.
/usr/sbin/semanage: Could not commit semanage transaction
  Installing : pulp-selinux-2.6.0-0.7.beta.el6_6sat.noarch                                                                                                                                                             259/460


  Installing : katello-2.2.0.4-1.el6_6sat.noarch                                                                                                                                                                       460/460
Non-fatal POSTTRANS scriptlet failure in rpm package ruby193-rubygem-foreman-redhat_access-0.0.7-2.el6_6sat.noarch
warning: %posttrans(ruby193-rubygem-foreman-redhat_access-0.0.7-2.el6_6sat.noarch) scriptlet failed, exit status 1
  Verifying  : ruby193-rubygem-hike-1.2.1-3.el6.noarch                                                                                                                                                                   1/460

Version-Release number of selected component (if applicable):
Satellite 6.1 Beta Snap 3 on RHEL 6.6

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:


selinux was disabled before the install

Comment 1 Alex Krzos 2015-02-19 14:45:10 UTC
The portion on gutterball install has already been addressed with:

https://bugzilla.redhat.com/show_bug.cgi?id=1190040

Comment 2 RHEL Program Management 2015-02-20 00:59:59 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Sachin Ghai 2015-02-20 10:04:57 UTC
The other scriptlet issue is addressed here:
https://bugzilla.redhat.com/show_bug.cgi?id=1191406

Comment 5 Brad Buckingham 2015-02-20 16:16:26 UTC
From the comments, it looks like the SELinux warnings will still need to be addrressed.

Comment 7 DipenDevra 2015-07-23 17:02:41 UTC
Created attachment 1055460 [details]
For `yum install katello` on RHEL 7.1

Comment 9 Brad Buckingham 2016-04-15 14:35:48 UTC
Created attachment 1147680 [details]
Satellite 6.2 Beta Snap 8.1 - yum install log

Comment 11 Lukas Pramuk 2016-06-28 16:45:28 UTC
VERIFIED.

# yum install -y satellite

================================================================================
 Package                     Arch   Version            Repository          Size
================================================================================
Installing:
 satellite                   noarch 6.2.0-17.0.el7sat  satellite          5.4 k
Installing for dependencies:
...
restorecon reset /var/lib/crane context system_u:object_r:var_lib_t:s0->system_u:object_r:httpd_sys_content_t:s0
restorecon reset /var/lib/crane/metadata context system_u:object_r:var_lib_t:s0->system_u:object_r:httpd_sys_content_t:s0

Installed:
  satellite.noarch 0:6.2.0-17.0.el7sat                                          

Dependency Installed:
...

>>> the only extra output was 2 restorecons, no warnings, no errors

Comment 12 Lukas Pramuk 2016-06-28 16:49:58 UTC
VERIFIED on rhel6.

# yum install -y satellite

================================================================================
 Package                     Arch   Version            Repository          Size
================================================================================
Installing:
 satellite                   noarch 6.2.0-10.0.el6sat  satellite          4.3 k
Installing for dependencies:
...
restorecon reset /var/lib/crane context system_u:object_r:var_lib_t:s0->system_u:object_r:httpd_sys_content_t:s0
restorecon reset /var/lib/crane/metadata context system_u:object_r:var_lib_t:s0->system_u:object_r:httpd_sys_content_t:s0

Installed:
  satellite.noarch 0:6.2.0-10.0.el6sat                                          

Dependency Installed:
...

Comment 14 errata-xmlrpc 2016-07-27 08:48:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.