Bug 119769 - cannot run as user
cannot run as user
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
: 119602 119858 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 20:27 EST by Scott Sloan
Modified: 2013-07-02 18:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 14:11:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (349.64 KB, text/plain)
2004-04-02 03:55 EST, Scott Sloan
no flags Details

  None (edit)
Description Scott Sloan 2004-04-01 20:27:11 EST
Description of problem:

[scott@localhost scott]$ system-logviewer
Could not set exec context to user_u:sysadm_r:sysadm_t.
[scott@localhost scott]$ su
Password:
[root@localhost scott]# sysetm-logviewer
bash: sysetm-logviewer: command not found
[root@localhost scott]# system-logviewer
/usr/share/system-logviewer/LogFileFrame.py:121: DeprecationWarning:
but we use it for a constructor for convenience
  self.searchEntry = gtk.Entry()
[root@localhost scott]#

This happens with all system-*

How reproducible:

every time

Steps to Reproduce:
1. from user, try and launch and of the system- programs
2. type in root password
3. they die
  
Actual results:

program is killed

Expected results:

program should launch

Additional info:

if this is not a bug then all system programs should be removed from
the user menu. what is the point of the user seeing them if they can't
not run them even if they know the root password
Comment 1 Scott Sloan 2004-04-02 03:55:08 EST
Created attachment 99071 [details]
strace output
Comment 2 Tammy Fox 2004-04-02 11:03:05 EST
This looks like it might be a symptom of SELinux. Please disable
SELinux with the setenforce 0 command as described at
http://people.redhat.com/kwade/fedora-docs/selinux-faq-en/, try to run
system-logviewer as a user again, and let me know what happens.
Comment 3 Scott Sloan 2004-04-02 11:35:18 EST
With Setting: 

/etc/sysconfig/selinux

selinux=disabled

I can start system-* succssfully, so you're right Tammy in that this
is a direct symptom of selinux. 
Comment 4 Tammy Fox 2004-04-02 11:51:49 EST
After further investigation, it looks like userhelper is dumping out
the  Could not set exec context to user_u:sysadm_r:sysadm_t error message.

I am changing the component to usermode.
Comment 5 Tim Waugh 2004-04-04 10:19:07 EDT
FWIW, this works for users created with 'useradd' (i.e. with
sysadm_r), but not with seuser add -R user_r (i.e. with user_r).

[tim@tornado tim]$ id -Z
tim:user_r:user_t
[tim@tornado tim]$ gdmsetup
Could not set exec context to tim:sysadm_r:sysadm_t.

[foo@tornado foo]$ id -Z
user_u:sysadm_r:sysadm_t
[foo@tornado foo]$ gdmsetup
[asks for password, then works]
Comment 6 Bill Nottingham 2004-04-05 17:42:39 EDT
*** Bug 119602 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2004-04-05 17:42:46 EDT
*** Bug 119858 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Walsh 2004-11-30 14:11:33 EST
Current policy fixes this problem

Note You need to log in before you can comment on or make changes to this bug.