Bug 1199667 - Puppet modules list for a content view needs pagination to avoid serious usability issue
Summary: Puppet modules list for a content view needs pagination to avoid serious usab...
Keywords:
Status: CLOSED DUPLICATE of bug 1231579
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Katello QA List
David O'Brien
URL:
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-03-06 22:51 UTC by Og Maciel
Modified: 2016-03-07 16:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-07 16:16:59 UTC


Attachments (Terms of Use)

Description Og Maciel 2015-03-06 22:51:34 UTC
Description of problem:

I have a custom product/repo pointing at https://forge.puppetlabs.com and fully synchronized with 3200+ modules. Whenever I attempt to add a puppet module to a content view, from the moment I click the Puppet Module tab (of my selected content view) to the moment I can actually use the web UI to select a puppet module or even click anywhere else) it takes a few minutes on my Firefox web browser. The API call to grab all puppet module names takes less than 3 seconds, but rendering the results back into the web page brings the browser to its knees.

Version-Release number of selected component (if applicable):

* Satellite-6.1.0-RHEL-6-20150303.0

How reproducible:


Steps to Reproduce:
1. Create a custom product and repo pointing to https://forge.puppetlabs.com
2. Sync the repo
3. Create a content view and try to add a random puppet module from the web ui

Actual results:

The web browser gets pegged for a couple of minutes and you cannot click on anything


Expected results:


Additional info:

Comment 2 David O'Brien 2015-08-20 02:13:54 UTC
Is there any sort of workaround for this atm or should I just add "wait for the browser to reload" or something similar to the release note?

If no rel note is required, pls remove the rel note blocker flag.

thanks

Comment 5 David Davis 2016-03-07 16:16:59 UTC

*** This bug has been marked as a duplicate of bug 1231579 ***


Note You need to log in before you can comment on or make changes to this bug.