Bug 119982 - various problems with rhythmbox / gstreamer
various problems with rhythmbox / gstreamer
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
: 123805 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-04 12:44 EDT by Michael Schwendt
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 14:04:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2004-04-04 12:44:10 EDT
Fresh installation of Fedora Core Test 2 without any updates from
rawhide and with SELinux in permissive mode.

Rhythmbox loads Ogg files and seems to play them, clock advances, but
nothing can be heard. Rhythmbox and alsamixer volume levels are
increased and channels are un-muted. XMMS doesn't have the problem.

Terminal output:

** (rhythmbox:2173): CRITICAL **: file dparammanager.c: line 337
(gst_dpman_attach_dparam): assertion `G_PARAM_SPEC_VALUE_TYPE
(dpwrap->param_spec) == GST_DPARAM_TYPE (dparam)' failed

(rhythmbox:2173): GStreamer-CRITICAL **: file gstcaps.c: line 1178
(gst_caps_structure_fixate_field_nearest_int): assertion
`gst_structure_has_field (structure, field_name)' failed

(rhythmbox:2173): GStreamer-CRITICAL **: file gstcaps.c: line 1178
(gst_caps_structure_fixate_field_nearest_int): assertion
`gst_structure_has_field (structure, field_name)' failed
ALSA lib pcm.c:824:(snd_pcm_sw_params) snd_pcm_sw_params:
params->avail_min problem for start_threshold
ALSA lib pcm.c:824:(snd_pcm_sw_params) snd_pcm_sw_params:
params->avail_min problem for start_threshold

** (rhythmbox:2173): WARNING **: error scheduling group 0x960f270
ALSA lib pcm.c:824:(snd_pcm_sw_params) snd_pcm_sw_params:
params->avail_min problem for start_threshold


Version-Release number of selected component (if applicable):
rhythmbox-0.6.8-2

How reproducible:
Always
Comment 1 Bill Nottingham 2004-04-06 12:00:33 EDT
Please try with the rhythmbox and gstreamer from rawhide.
Comment 2 Michael Schwendt 2004-04-06 16:41:43 EDT
Rhythmbox from development gives a small dialog box with the title
"Error" and content "Could not pause playback" and an OK button.
There's a report about that already.

$ rpm -q rhythmbox gstreamer gstreamer-plugins libdv
rhythmbox-0.7.2-1
gstreamer-0.8.0-3
gstreamer-plugins-0.8.0-3
libdv-0.102-1

$ rhythmbox 

(rhythmbox:2685): Rhythmbox-CRITICAL **: file rb-shell.c: line 2410
(rb_shell_sync_selected_source): assertion `internalname' failed
Got error opening "file:///home/rbtest/kb-candytron.ogg": Could not
pause playback

[...]

Same with the very latest: gstreamer-0.8.0-4


[...]

Attempts at debugging gstreamer fail, too:

$ gst-launch-0.8 filesrc location=/home/rbtest/kb-candytron.ogg !
vorbisdec ! alsasink
RUNNING pipeline ...

(process:2913): GStreamer-CRITICAL **: file gstcaps.c: line 1178
(gst_caps_structure_fixate_field_nearest_int): assertion
`gst_structure_has_field (structure, field_name)' failed
ALSA lib pcm.c:824:(snd_pcm_sw_params) snd_pcm_sw_params:
params->avail_min problem for start_threshold
ERROR: pipeline doesn't want to play.
Comment 3 Colin Walters 2004-04-06 16:55:36 EDT
Can you try this?

gst-launch-0.8 filesrc location=/home/rbtest/kb-candytron.ogg !
vorbisdec ! alsasink device=hw:0
Comment 4 Michael Schwendt 2004-04-06 17:28:41 EDT
Gives:

RUNNING pipeline ...
ERROR: pipeline doesn't want to play.


(That was a bug around Test1, IIRC.)
Comment 5 Colin Walters 2004-04-06 17:39:57 EDT
How about:

gst-launch-0.8 filesrc location=/home/rbtest/kb-candytron.ogg !
vorbisdec ! audioscale ! audioconvert ! alsasink device=hw:0

Also, can you say what sound card you have?

And can you also try using osssink instead of alsasink?
Comment 6 Michael Schwendt 2004-04-06 17:51:48 EDT
The first one fails with:

WARNING: erroneous pipeline: could not link vorbisdec0 to audioscale0
         Trying to run anyway.
RUNNING pipeline ...
ERROR: pipeline doesn't want to play.

[...]

osssink fails with:

WARNING: erroneous pipeline: could not link vorbisdec0 to osssink0
         Trying to run anyway.
RUNNING pipeline ...
ERROR: pipeline doesn't want to play.

[...]

 * ALSA OSS portion (/dev/dsp) is alive and working fine.
 * Native ALSA driver works fine, too, e.g. with XMMS.

[...]

00:0e.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 07)

Module                  Size  Used by
snd_pcm_oss            42532  0 
snd_mixer_oss          13952  2 snd_pcm_oss
snd_ens1371            24544  2 
snd_rawmidi            21408  1 snd_ens1371
snd_seq_device          6280  1 snd_rawmidi
snd_pcm                84232  2 snd_pcm_oss,snd_ens1371
snd_page_alloc          8580  1 snd_pcm
snd_timer              25220  1 snd_pcm
snd_ac97_codec         53384  1 snd_ens1371
gameport                3968  1 snd_ens1371
snd                    43748  10
snd_pcm_oss,snd_mixer_oss,snd_ens1371,snd_rawmidi,snd_seq_device,snd_pcm,snd_timer,snd_ac97_codec
soundcore               7520  2 snd
Comment 7 Colin Walters 2004-04-15 15:33:47 EDT
Ok.  Try this command:

gst-launch filesrc location=/home/rbtest/kb-candytron.ogg ! spider !
volume ! audioscale ! audioconvert ! alsasink device=hw:0


Comment 8 Colin Walters 2004-04-15 15:34:57 EDT
Oh and also - there are newer GStreamer packages in rawhide now
(0.8.1), it would be nice if you could try those.
Comment 9 Michael Schwendt 2004-04-16 09:56:05 EDT
Had to use gst-launch-0.8 instead of gst-launch and it gives:

RUNNING pipeline ...
ERROR: pipeline doesn't want to play.

[...]

$ rpm -qa 'gstreamer*' rhythmbox
rhythmbox-0.7.2-1
gstreamer-plugins-devel-0.8.1-1
gstreamer-0.8.1-1
gstreamer-devel-0.8.1-1
gstreamer-plugins-0.8.1-1

[...]

I think chasing this further is a dead end, since the symptoms
reported originally were different.

Running rhythmbox now I'm back at bug 119958 (with no known work-around):

$ rhythmbox 

(rhythmbox:10901): Rhythmbox-WARNING **: unknown source Library!
Got error opening "file:///home/rbtest/kb-candytron.ogg": Could not
pause playback



No such problems with XMMS.
Comment 10 Colin Walters 2004-04-21 11:00:16 EDT
Does this happen with all oggs?  Only some?  Can you try a FLAC file?
What if you start esd and do:
gconftool-2 -s /system/gstreamer/0.8/default/audiosink -t string esdsink
Comment 11 Féliciano Matias 2004-04-21 15:00:00 EDT
Same problem here.
Perhaps related to bug #119958

> gconftool-2 -s /system/gstreamer/0.8/default/audiosink -t string esdsink

Magic this work :-)

Thanks.

sound card : "Ensoniq ES1371" (snd_ens1371)
Comment 12 Michael Schwendt 2004-04-21 17:52:48 EDT
In reply to comment 10:

 * other ogg files fail, too
 * flac files fail, too
 * esd was running already
 * switching default audiosink to esd makes rhythmbox work

Also working:

gst-launch-0.8 filesrc location=kb-candytron.ogg ! spider ! esdsink
Comment 13 Colin Walters 2004-07-07 14:17:00 EDT
Ok, can you try these packages:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/2/i386/gstreamer-0.8.3-2.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/2/i386/gstreamer-plugins-0.8.2-2.i386.rpm

To test, please reset your sink back to alsasink, via:
gconftool-2 -s /system/gstreamer/0.8/default/audiosink -t string alsasink

Thanks!
Comment 14 Colin Walters 2004-07-07 14:32:56 EDT
*** Bug 123805 has been marked as a duplicate of this bug. ***
Comment 15 Féliciano Matias 2004-07-07 23:23:21 EDT
Reply to Comment #13 
This works here. Thanks.
Tested with rhythmbox.
Comment 16 Michael Schwendt 2004-07-14 20:04:30 EDT
Tried the packages from comment 13 in a fresh user account. Worked
fine. Caveat, though, upon closing rhythmbox I got a segfault once
(and didn't have core dump enabled unfortunately). Could be an
unrelated bug, of course.
Comment 17 Colin Walters 2004-07-20 14:04:45 EDT
Ok, I'm going to push the test updates soon, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.