Bug 1199890 - Black flicker on gdm screen, affected by mouse
Black flicker on gdm screen, affected by mouse
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1200581
  Show dependency treegraph
 
Reported: 2015-03-09 03:04 EDT by Conley Moorhous
Modified: 2015-09-13 05:15 EDT (History)
32 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-27 19:12:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
c6 journal (794.24 KB, text/plain)
2015-03-23 01:00 EDT, Chris Murphy
no flags Details
c6 video (1.58 MB, video/mp4)
2015-03-23 01:03 EDT, Chris Murphy
no flags Details
GDM Custom.conf (235 bytes, text/plain)
2015-03-27 17:57 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Conley Moorhous 2015-03-09 03:04:37 EDT
Description of problem: There is strange flickering in GDM. It is flickering to black, making a black box all the way across the screen. The flickering is always underneath the mouse cursor, no matter where I move it. The flickering is worse when the mouse is moving, but still occurs when the mouse isn't moving.

Interestingly, when I move the mouse past an (imaginary) vertical line on the right side of the screen, most of the screen under the mouse becomes solid black (so the GDM background is not intermittently visible like it is when the mouse is elsewhere). Flickering still occurs toward the top section of the screen that is still under the mouse. If I move the mouse a bit further to the right, the screen under the mouse becomes a solid blue, sometimes changing blues. If I move the mouse further to the right still, it returns to like before, with the solid black and flickering. If I move the mouse further right, the flickering is gone. The part of the screen where the flickering is gone is around the Accessibility menu. The exact location varies, but it is always around the Accessibility menu.

I'm pretty sure it is related to bug 1199747. Notably, switching between GDM and the active gnome-shell session (VT1 to VT2 typically) or GDM and a TTY seems to precipitate that kernel bug. I wanted to get screenshots, but the aforementioned bug made that difficult. I can take pictures and videos with my camera if that would be helpful.


Version-Release number of selected component (if applicable): 3.15.91.2

How reproducible: Always

Steps to Reproduce:
1. Boot up and wait for GDM
2. Look at screen

Actual results: Screen flickers and the area changes depending on the location of the mouse

Expected results: Screen does not flicker
Comment 1 Diogo Campos 2015-03-13 19:05:57 EDT
Same happens to me.

Fedora 22 Alpha, fully updated at 13/march/2015.
GPU: Intel HD Graphics - SandyBridge (Pentium B950).
Happens at GNOME Shell over Wayland, too.
Comment 2 Diogo Campos 2015-03-14 17:03:26 EDT
Fixed for me with the updates from 14/march/2015.
Comment 3 Conley Moorhous 2015-03-14 22:32:18 EDT
I still have the same issue, but I am still somehow running kernel 4.0.0-0.rc1.git0.1.fc22 due to (or related to) bug 1201445
Comment 4 Diogo Campos 2015-03-15 03:43:48 EDT
The issue came back, I have no idea why.
I haven't updated, if I remember correctly.
Comment 5 Heiko Adams 2015-03-21 05:49:55 EDT
Same problem here. Everytime the cursor moves or a key is pressed the screen starts flickering
Comment 6 Chris Murphy 2015-03-23 00:59:18 EDT
Same happens for me, Macbook Pro 8,2 i915/Intel HD Graphics 3000 (Radeon disabled in GRUB pre-boot).
Comment 7 Chris Murphy 2015-03-23 01:00:00 EDT
Created attachment 1005182 [details]
c6 journal

Attaching journal which includes drm.debug=0x06.

The section starting:
[  238.978093] f22m.localdomain kernel: [drm:drm_atomic_set_fb_for_plane] Set [FB:48] for plane state ffff88035f9f40c0

Is exacerbating flicker with trackpad movement. Prior to that time, no keyboard/trackpad input happens, yet there still is flicker just not as aggressive.
Comment 8 Chris Murphy 2015-03-23 01:03:02 EDT
Created attachment 1005183 [details]
c6 video

Not very good, the cell phone autoexposure fixated on the brightest thing so the gray background is black in the video but it gives an idea of the flicker. It behaves sorta like a loose analog video connection in ancient times.
Comment 9 Chris Murphy 2015-03-23 10:07:58 EDT
This flicker doesn't happen at all if I regress to kernel 3.19.2. Is everyone else having this problem on a system with Intel i915 graphics?
Comment 10 Christian Stadelmann 2015-03-24 12:32:54 EDT
I can confirm this issue with fedup from today on a Core i5 2nd generation iGPU with kernel 4.0.0.rc-something.

I see flickering to black in gdm 3.15.92-1.fc22 and 3.15.91.2-1.fc22. It is always below the mouse cursor. When moving the cursor to the right it is gone (unlike what you reported).
Comment 11 Christian Stadelmann 2015-03-24 13:40:09 EDT
As a workaround I suggest disabling Wayland for GDM in /etc/gdm/custom.conf
Comment 12 M. Edward (Ed) Borasky 2015-03-24 14:59:40 EDT
(In reply to Christian Stadelmann from comment #11)
> As a workaround I suggest disabling Wayland for GDM in /etc/gdm/custom.conf

Thanks! I have this on my laptop even without touching the mouse / trackpad. Meanwhile, shouldn't this be either a blocker bug or ship with Wayland disabled by default? What are the chances of this getting fixed by beta release?
Comment 13 Bill Gianopoulos 2015-03-24 18:34:56 EDT
(In reply to Chris Murphy from comment #9)
> This flicker doesn't happen at all if I regress to kernel 3.19.2. Is
> everyone else having this problem on a system with Intel i915 graphics?

I thought this had already been answered.  As far as I know this problem has only been reported with the xorg-x11-drv-intel aka the i915 driver, and everyone using this driver has this issue.
Comment 14 Bill Gianopoulos 2015-03-24 18:37:43 EDT
Hmm. I thought I had already posted this comment but perhaps on one of the other related bugs.  This issue actually occurs on reboot before the gdm login screen occurs.  also it only occurs when the page is first displayed if you allow the screen blank or screen lock time to expire the page displays just fine.  The issue also occurs if you use the logout command.
Comment 15 Bill Gianopoulos 2015-03-24 19:17:42 EDT
(In reply to Bill Gianopoulos from comment #14)
> Hmm. I thought I had already posted this comment but perhaps on one of the
> other related bugs.  This issue actually occurs on reboot before the gdm
> login screen occurs.  also it only occurs when the page is first displayed
> if you allow the screen blank or screen lock time to expire the page
> displays just fine.  The issue also occurs if you use the logout command.

So I kind of think this is an xserver start issue rather than anything particular with the gdm login screen.
Comment 16 Luya Tshimbalanga 2015-03-25 03:02:24 EDT
I had similar issue with Intel® Core™ Duo CPU T2250 @ 1.73GHz × 2 running on Intel® 945GM. The current workaround that seems effective is to select rescue mode from the boot menu which seems resolving the problem.
Comment 17 Bill Gianopoulos 2015-03-25 07:37:46 EDT
(In reply to Luya Tshimbalanga from comment #16)
> I had similar issue with Intel® Core™ Duo CPU T2250 @ 1.73GHz × 2 running on
> Intel® 945GM. The current workaround that seems effective is to select
> rescue mode from the boot menu which seems resolving the problem.

This is not really a good workaround.  What you are doing here is just running an older kernel, so you are not really testing using a kernel that will ever be released.  The best workaround was already suggested in comment 11.

You need to edit the file /etc/gdm/custom.conf and change this section:

[daemon]
# Uncoment the line below to force the login screen to use Xorg
#WaylandEnable=true

to look like this:

[daemon]
# Uncoment the line below to force the login screen to use Xorg
#WaylandEnable=true
WaylandEnable=false
Comment 18 Christian Stadelmann 2015-03-25 11:38:39 EDT
@Bill: I don't think this is xserver-related since it only happens with gdm on wayland but does not happen with gdm on xserver.
Comment 19 Bill Gianopoulos 2015-03-25 11:42:35 EDT
(In reply to Christian Stadelmann from comment #18)
> @Bill: I don't think this is xserver-related since it only happens with gdm
> on wayland but does not happen with gdm on xserver.

Yes.  I misspoke.  It is obviously an Intel on Wayland issue.  I am not sure it is gdm related either.  Is there anything else that uses wayland by default?
Comment 20 Christian Stadelmann 2015-03-25 12:05:10 EDT
gnome wayland session. I just can't test that right now.
Comment 21 Dio Putra 2015-03-25 13:24:38 EDT
Hi, any mouse deadlock when switching user in GDM?. My laptop completely broken with no respond after switching user. I had same issue now.(Asus V5-431, Celeron 1007U)
Comment 22 Dennis Jacobfeuerborn 2015-03-25 17:06:54 EDT
(In reply to Dio Oktarianos Putra from comment #21)
> Hi, any mouse deadlock when switching user in GDM?. My laptop completely
> broken with no respond after switching user. I had same issue now.(Asus
> V5-431, Celeron 1007U)

I see the lockup when switching users as well but on F21 and only about 30% of the time. I'm using a Dell XPS 13.
Comment 23 Chris Murphy 2015-03-25 17:10:03 EDT
See bug 1204513 for console and reboot lockup. The journal contains a back trace pointing to i915. It's almost always reproducible on reboot/shutdown, and always reproducible on console switch. And it happens with 3.19 kernels, so anyone on Fedora 21 may by now have a 3.19.1 or 3.19.2 kernel (Fedora 20 was still on 3.18.9 as of yesterday).
Comment 24 Christian Stadelmann 2015-03-25 17:43:14 EDT
@ Comment 21 / mouse deadlock when switching users: see also #1147695 which was not introduced by new kernels but was present since F21 on gnome+wayland.
Comment 25 M. Edward (Ed) Borasky 2015-03-25 17:53:36 EDT
(In reply to Christian Stadelmann from comment #20)
> gnome wayland session. I just can't test that right now.

I tried GNOME Wayland session on my F22 Alpha (Intel GPU) laptop - once. Same symptom as GDM with Wayland - flicker, tearing, unusable.
Comment 26 Luya Tshimbalanga 2015-03-27 13:17:09 EDT
Updating to GDM 3.16.0.1 running Fedora 22 Alpha. No flicker nor tearing reported. 
Test done on Sony VAIO VGN-N250E using Intel Graphic 945GM.
Comment 27 Bill Gianopoulos 2015-03-27 13:33:06 EDT
(In reply to Luya Tshimbalanga from comment #26)
> Updating to GDM 3.16.0.1 running Fedora 22 Alpha. No flicker nor tearing
> reported. 
> Test done on Sony VAIO VGN-N250E using Intel Graphic 945GM.

So since gnome 3.16 is scheduled to land on fedora 22 this week, I guess this would no longer be an issue.
Comment 28 Conley Moorhous 2015-03-27 13:42:35 EDT
(In reply to Luya Tshimbalanga from comment #26)
> Updating to GDM 3.16.0.1 running Fedora 22 Alpha. No flicker nor tearing
> reported. 
> Test done on Sony VAIO VGN-N250E using Intel Graphic 945GM.

I still have flickering with the latest upgrades on F22 Alpha.

Since the intel drivers were not updated, I doubt that the underlying issue was solved (because the issue does seem to be the drivers rather than gdm, per se). However, the upgrades did not seem to disable Wayland in GDM:

The upgrade installed a new configuration file, /etc/gdm/custom.conf.rpmnew, with the following new lines:

# Uncoment (sic) the line below to force the login screen to use Xorg
#WaylandEnable=false

So, if/when you merged the configuration files, this shouldn't have changed anything.

Can you attach your copy of /etc/gdm/custom.conf?
Comment 29 Conley Moorhous 2015-03-27 13:46:59 EDT
(In reply to Luya Tshimbalanga from comment #26)
> Updating to GDM 3.16.0.1 running Fedora 22 Alpha. No flicker nor tearing
> reported. 
> Test done on Sony VAIO VGN-N250E using Intel Graphic 945GM.

Just saw Bill Gianopoulos' earlier comment directed at you; if you disabled Wayland in GDM, the issue should have been resolved both at the point which you disabled it (after rebooting) as well as now, with the latest updates. Was this the case for you?
Comment 30 Bill Gianopoulos 2015-03-27 13:52:05 EDT
(In reply to Luya Tshimbalanga from comment #26)
> Updating to GDM 3.16.0.1 running Fedora 22 Alpha. No flicker nor tearing
> reported. 
> Test done on Sony VAIO VGN-N250E using Intel Graphic 945GM.

Hmm, I just did an update with updates-testing enabled, which installed gdm 3.16.0.1 and I still have the flickering.
Comment 31 Bill Gianopoulos 2015-03-27 14:58:29 EDT
(In reply to Conley Moorhous from comment #29)
> (In reply to Luya Tshimbalanga from comment #26)
> > Updating to GDM 3.16.0.1 running Fedora 22 Alpha. No flicker nor tearing
> > reported. 
> > Test done on Sony VAIO VGN-N250E using Intel Graphic 945GM.
> 
> Just saw Bill Gianopoulos' earlier comment directed at you; if you disabled
> Wayland in GDM, the issue should have been resolved both at the point which
> you disabled it (after rebooting) as well as now, with the latest updates.
> Was this the case for you?

Particularly, if you want to test if this is fixed in version 3.16.0.1, you need to make sure the gdm configuration file has the default configuration for Wayland usage which is as follows:

[daemon]
# Uncoment the line below to force the login screen to use Xorg
#WaylandEnable=false
Comment 32 Bill Gianopoulos 2015-03-27 15:09:17 EDT
(In reply to Conley Moorhous from comment #28)

> Since the intel drivers were not updated, I doubt that the underlying issue
> was solved (because the issue does seem to be the drivers rather than gdm,
> per se). However, the upgrades did not seem to disable Wayland in GDM:

Should this bug be moved to form the gdm to the wayland component (or someplace else more Intel specific)?
Comment 33 Conley Moorhous 2015-03-27 15:48:13 EDT
(In reply to Bill Gianopoulos from comment #32)
> (In reply to Conley Moorhous from comment #28)
> 
> > Since the intel drivers were not updated, I doubt that the underlying issue
> > was solved (because the issue does seem to be the drivers rather than gdm,
> > per se). However, the upgrades did not seem to disable Wayland in GDM:
> 
> Should this bug be moved to form the gdm to the wayland component (or
> someplace else more Intel specific)?

Yes, definitely. I figured the bug would be reclassified as an Intel issue a while ago, truthfully. I should have changed it.

As far as I can tell, the flickering occurs in the exact same way (albeit less frequently) during a Gnome session on Wayland. So it's either Wayland, Intel drivers, or something like GTK3 (unsure about that one... however Gnome interfaces with Wayland and Intel). Whoever the culprit is, I don't think it could be GDM.
Comment 34 Luya Tshimbalanga 2015-03-27 17:57:51 EDT
Created attachment 1007520 [details]
GDM Custom.conf

(In reply to Conley Moorhous from comment #28)
> 
> I still have flickering with the latest upgrades on F22 Alpha.
> 
> Since the intel drivers were not updated, I doubt that the underlying issue
> was solved (because the issue does seem to be the drivers rather than gdm,
> per se). However, the upgrades did not seem to disable Wayland in GDM:
> 
> The upgrade installed a new configuration file, /etc/gdm/custom.conf.rpmnew,
> with the following new lines:
> 
> # Uncoment (sic) the line below to force the login screen to use Xorg
> #WaylandEnable=false
> 
> So, if/when you merged the configuration files, this shouldn't have changed
> anything.
> 
> Can you attach your copy of /etc/gdm/custom.conf?

Sure. I set WaylandEnable=true for testing purpose and went further trying Gnome Wayland. No flickering nor tearing other than known issue as cursor animators and slowdown on non Wayland application such as Firefox.
Comment 35 M. Edward (Ed) Borasky 2015-03-27 19:00:47 EDT
Just updated my laptop a few minutes ago to gnome 3.16:

$ dnf list installed|grep gnome-session
gnome-session.x86_64                 3.16.0-1.fc22                       @System
gnome-session-wayland-session.x86_64 3.16.0-1.fc22                       @System
gnome-session-xsession.x86_64        3.16.0-1.fc22                       @System

I tried logging in with "Gnome Wayland" and the system is unusable. Black, flickering, tearing - worse yet, I had to power cycle the machine to log back in!

Is there any other way we can isolate this to GTK or Wayland or the Intel GPU driver? I'm game for testing if someone will give me something to test.
Comment 36 chunshan 2015-03-30 22:48:39 EDT
I have two computers, one with ati graphical card and the other with intel i965 card. I use the same F22 system which installed to a mobile hdd.
The computer with ati card has no this problem.
But the computer with the intel i965 card has this bug.
When i turned off the SNA accelerate method of the Intel i965 card,the problem disappear in the gdm-wayland-session,but the login screen still has this problem.
So the problem may due to the intel sna drivers.
Comment 37 Dio Putra 2015-03-31 09:12:19 EDT
(In reply to chunshan from comment #36)
> But the computer with the intel i965 card has this bug.
> When i turned off the SNA accelerate method of the Intel i965 card,the
> problem disappear in the gdm-wayland-session,but the login screen still has
> this problem.
> So the problem may due to the intel sna drivers.

Do you test user transition smoothly? Flicker was gone when using Intel UXA patch https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues but still buggy with wayland IMHO. With Intel UXA, I got two type blank screen at user transition, one like old gdm which still implement vestigial code (Need force shutdown with power button) and two it's totally blank screen (Still responsive only with power button).
Comment 38 chunshan 2015-03-31 21:32:25 EDT
(In reply to Dio Oktarianos Putra from comment #37)
> (In reply to chunshan from comment #36)
> > But the computer with the intel i965 card has this bug.
> > When i turned off the SNA accelerate method of the Intel i965 card,the
> > problem disappear in the gdm-wayland-session,but the login screen still has
> > this problem.
> > So the problem may due to the intel sna drivers.
> 
> Do you test user transition smoothly? Flicker was gone when using Intel UXA
> patch https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues but
> still buggy with wayland IMHO. With Intel UXA, I got two type blank screen
> at user transition, one like old gdm which still implement vestigial code
> (Need force shutdown with power button) and two it's totally blank screen
> (Still responsive only with power button).

I just test the user transition.
I did not got the problem as you said.
Comment 39 Dio Putra 2015-04-01 14:00:39 EDT
(In reply to chunshan from comment #38)
> (In reply to Dio Oktarianos Putra from comment #37)
> > (In reply to chunshan from comment #36)
> > > But the computer with the intel i965 card has this bug.
> > > When i turned off the SNA accelerate method of the Intel i965 card,the
> > > problem disappear in the gdm-wayland-session,but the login screen still has
> > > this problem.
> > > So the problem may due to the intel sna drivers.
> > 
> > Do you test user transition smoothly? Flicker was gone when using Intel UXA
> > patch https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues but
> > still buggy with wayland IMHO. With Intel UXA, I got two type blank screen
> > at user transition, one like old gdm which still implement vestigial code
> > (Need force shutdown with power button) and two it's totally blank screen
> > (Still responsive only with power button).
> 
> I just test the user transition.
> I did not got the problem as you said.

Strange, both using Intel SNA and Intel UXA, my gdm is still unstable for me.
Comment 40 chunshan 2015-04-02 01:31:23 EDT
The kernel has been updated to the latest one(4.0.0-0.rc6.git0.1.fc22.x86_64).
In the latest kernel,some drm/i925 bugs have been fixed.
There is no flicker problem.
Comment 41 M. Edward (Ed) Borasky 2015-04-02 02:16:03 EDT
(In reply to chunshan from comment #40)
> The kernel has been updated to the latest
> one(4.0.0-0.rc6.git0.1.fc22.x86_64).
> In the latest kernel,some drm/i925 bugs have been fixed.
> There is no flicker problem.

Excellent news! I'll test it on my laptop tomorrow!
Comment 42 Conley Moorhous 2015-04-02 08:25:52 EDT
(In reply to chunshan from comment #40)
> The kernel has been updated to the latest
> one(4.0.0-0.rc6.git0.1.fc22.x86_64).
> In the latest kernel,some drm/i925 bugs have been fixed.
> There is no flicker problem.

Where is this build? I don't see it anywhere on koji.
Comment 43 Bill Gianopoulos 2015-04-02 18:38:22 EDT
I just updated my kernel to:

4.0.0-0.rc6.git1.1.fc22.x86_64

This did NOT fix the flicker on the GDM login screen for me.
Comment 44 Bill Gianopoulos 2015-04-02 18:39:28 EDT
(In reply to Conley Moorhous from comment #42)
> (In reply to chunshan from comment #40)
> > The kernel has been updated to the latest
> > one(4.0.0-0.rc6.git0.1.fc22.x86_64).
> > In the latest kernel,some drm/i925 bugs have been fixed.
> > There is no flicker problem.
> 
> Where is this build? I don't see it anywhere on koji.
I just searched for kernel in the package search and it came right up.  There is a git1 there now also and a git2 build still in progress.
Comment 45 Christian Stadelmann 2015-04-07 05:02:57 EDT
@Bill Gianopoulos regarding comment #19 and comment #20 : I can't reproduce that with wayland backend for gtk applications under gnome wayland session. maybe I was mistaken.

I still have flickering with the latest upgrades on F22 Alpha.
Comment 46 Christian Stadelmann 2015-04-10 01:43:28 EDT
I have to correct myself (comment #45): With gnome on wayland desktop session I am seeing this bug too sometimes.
Comment 47 chunshan 2015-04-10 02:43:59 EDT
(In reply to Christian Stadelmann from comment #46)
> I have to correct myself (comment #45): With gnome on wayland desktop
> session I am seeing this bug too sometimes.

with or without the intel uxa?
Comment 48 Christian Stadelmann 2015-04-10 03:47:59 EDT
According to man 4 intel I am using SNA (which is the default). I don't have any configuration below /etc/ setting the AccelMethod to UXA.

After reading https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues I created a file /etc/X11/xorg.conf.d/20-intel.conf with this content:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

I restarted gdm. Now GDM does not show the issue any more.
I logged in to gnome session on wayland. It is barely usable and flickering much more than before. In fact any UI is only visible while moving the mouse. I'll be switching back to SNA by deleting this file.

With gnome session on wayland and SNA this issue does not happen often. In fact it sometimes is not reproducible at all. This led to comment #45.
Comment 49 Bill Gianopoulos 2015-04-10 07:25:50 EDT
(In reply to Dio Oktarianos Putra from comment #37)
> (In reply to chunshan from comment #36)
> > But the computer with the intel i965 card has this bug.
> > When i turned off the SNA accelerate method of the Intel i965 card,the
> > problem disappear in the gdm-wayland-session,but the login screen still has
> > this problem.
> > So the problem may due to the intel sna drivers.
> 
> Do you test user transition smoothly? Flicker was gone when using Intel UXA
> patch https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues but
> still buggy with wayland IMHO. With Intel UXA, I got two type blank screen
> at user transition, one like old gdm which still implement vestigial code
> (Need force shutdown with power button) and two it's totally blank screen
> (Still responsive only with power button).

Well restarting gdm is NOT a valid test.  The gdm login screen does not flicker after a gdm restart even with the Intel UXA patch.  I suggest in future you test changes doing a full system restart to make sure you are not comparing apples and oranges.
Comment 50 Bill Gianopoulos 2015-04-10 07:29:49 EDT
To my last comment, restarting gdm seems to force the screensaver to be invoked before the login screen, which as I stated in comment 14 is sufficient to avoid the issue.
Comment 51 Bill Gianopoulos 2015-04-10 07:54:37 EDT
(In reply to Bill Gianopoulos from comment #49)

> Well restarting gdm is NOT a valid test.  The gdm login screen does not
> flicker after a gdm restart even with the Intel UXA patch.  I suggest in

Oops! I maent to say it does not flicker after gdm restart even without the Intel UXA patch.
Comment 52 Dio Putra 2015-04-16 18:34:12 EDT
(In reply to Bill Gianopoulos from comment #49)
> (In reply to Dio Oktarianos Putra from comment #37)
> > (In reply to chunshan from comment #36)
> > > But the computer with the intel i965 card has this bug.
> > > When i turned off the SNA accelerate method of the Intel i965 card,the
> > > problem disappear in the gdm-wayland-session,but the login screen still has
> > > this problem.
> > > So the problem may due to the intel sna drivers.
> > 
> > Do you test user transition smoothly? Flicker was gone when using Intel UXA
> > patch https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues but
> > still buggy with wayland IMHO. With Intel UXA, I got two type blank screen
> > at user transition, one like old gdm which still implement vestigial code
> > (Need force shutdown with power button) and two it's totally blank screen
> > (Still responsive only with power button).
> 
> Well restarting gdm is NOT a valid test.  The gdm login screen does not
> flicker after a gdm restart even with the Intel UXA patch.  I suggest in
> future you test changes doing a full system restart to make sure you are not
> comparing apples and oranges.

Sorry for mistake. This bug still occurred with final 4.0 kernel.
Comment 53 Bill Gianopoulos 2015-04-24 09:57:41 EDT
Not sure what fixed it but something that landed on rawhide in the last few days has eliminated the flicker at least on the gdm login screen.  The issue still persists in Fedora 22 beta.
Comment 54 Bill Gianopoulos 2015-04-24 11:03:24 EDT
Looking back on update logs, the only thing that seems like it may have fixed it was the update of the kernel to 4.1.0-0.rc0.git9 from git8.
Comment 55 Bill Gianopoulos 2015-04-24 11:19:29 EDT
(In reply to Bill Gianopoulos from comment #54)
> Looking back on update logs, the only thing that seems like it may have
> fixed it was the update of the kernel to 4.1.0-0.rc0.git9 from git8.

Please ignore that comment.

Kernel 4.1.0-0.rc0.git9.1.fc23.x86_64 still has the flicker issue on the gdm login screen.

Kernel 4.1.0-0.rc0.git12.1.fc23.x86_64 does not.
Comment 56 Bill Gianopoulos 2015-04-24 11:21:46 EDT
This needs to be moved to the kernel component.
Comment 57 Bill Gianopoulos 2015-04-24 12:17:17 EDT
More testing via downloading intermediate kernel version form koji reveals that we have the blinking issue at git9 but not at git10.

I realize that since this issue seems fixed this bug could be closed, but the issue of what to do re: the impending fedora 22 release remains.  In my opinion, this really not releasable as is.

It would seem the courses of action are:

1.  Revert the change to default to wayland for GDM login screen and just defer it to fedora 23 where it will be a viable change.

2.  figure out what fixed this in 4.1 kernel and backport that fix to 4.0 kernel.

3.  Revert the change to default to wayland for the GDM login screen until such time as the kernel for fedora 22 is updated to the 4.1 kernel.

4.  Deploy some kind of kludge that defaults to wayland for gdm login screen unless the system uses intel graphics.
Comment 58 Bill Gianopoulos 2015-04-24 12:21:41 EDT
Also the severity of this bug is listed as medium, which might be true on a single user system.  It is true that you can just hit enter on the keyboard type in the password and hit enter and be on your way.  However, on a multi-user system, where the multiple users are used to using the mouse to select their username, this is really unusable as it stands.
Comment 59 Bill Gianopoulos 2015-04-24 12:25:39 EDT
Sorry, I don't seem to have editbugs permission so am unable to make these changes on my own. :-(
Comment 60 Bill Gianopoulos 2015-04-24 19:55:42 EDT
OK.  Further testing has revealed the latest Rawhide kernel does not fix the GDM login screen flickering in all cases.

What it does fix is the initial login screen upon boot-up no longer flickers, and if I refrain from running "GNOME under Wayland", I do not seem to be able to get the login screen to flicker under any conditions.

However if I do run a "GNOME under Wayland" session, the login screen flickers really badly after I log out of the session.
Comment 61 Bojan Smojver 2015-04-27 21:05:15 EDT
Possibly related: bug #1200581.
Comment 62 Carl George 2015-04-29 20:44:33 EDT
I noticed several references to the Arch Wiki in this bug, but none to Arch itself.  I can confirm, this issue is also present on Arch with the following hardware and package versions.

Core i5-2467M
HD Graphics 3000

linux 4.0.1-1
xf86-video-intel 2.99.917-5
xorg-server 1.17.1-5
xorg-server-xwayland 1.17.1-5
wayland 1.7.0-1
gdm 3.16.1.1-1
gnome-session 3.16.0-1
gnome-shell 3.16.1-2
clutter 1.22.0-2
gtk3 3.16.2-1
mesa 10.5.4-1

Hopefully a cross reference of the versions can be of some use in isolating the exact issue.  Also, disabling wayland in /etc/gdm/custom.conf works for me.
Comment 63 Dio Putra 2015-05-03 10:41:33 EDT
I've got some updates via dnf today, and switching users from gdm without enabling wayland. Unfortunately, gdm flickered with some systemd splash bug and can't entering console anymore. But shutdown with ctrl+alt+del works to shutdown.
Comment 64 mike simpson 2015-05-12 14:12:57 EDT
latest updates to fedora 22 using dnf as of today
hardware Mobile Intel® GM45 Express Chipset 
still have tearing using wayland on login screen
still need to disable wayland in /etc/gdm/custom.conf

same hardware didn't have this issue using wayland session in gnome with fedora 21
Comment 65 chunshan 2015-05-13 22:26:54 EDT
this issue introduced by the kernel-4.0,kernel3.19 does not have this problem.the kernel4.1 much better, but still not been resolved.
Comment 66 M. Edward (Ed) Borasky 2015-05-15 19:39:46 EDT
There are numerous bugs associated with this, including one (bug 1218787) which has a freeze exception pending. This close to F22 release, I think the only practical course is to disable Wayland in the gdm configuration on the release / installed systems and push this into F23 where it can get solid attention upstream and in Fedora.
Comment 67 GregVD 2015-05-29 16:22:32 EDT
Hi. I have the same problem here. With F22 and the default session, i have that flickering when i try to login to the session. Including this issue(i dont know if this issue is related) and after login, F22 Gnome session (and tested with KDE) i have a distorsion when im using the mouse pointer over buttons, images, windows, title windows...inside Gnome.

I think is problem between Wayland Experimental and xorg-intel because i have a integrated Intel graphic card. You can read more (and see attached images) in ids: 1225248 and 1225731.

I had this issue in F22 Alpha & Beta in Live or installed modes. F21 and previous worked fine, and other distros or OS worked fine.

Bye
Comment 68 Christian Stadelmann 2015-05-30 06:55:09 EDT
Have you made sure that you updated your kernel to be at least version 4.0.4-301? You can check that by running `uname -a` in any terminal.
If your bug is gone after updating to this kernel version you ran into #1218688.

PS: If you put a hash character (# ) before the bug ID bugzilla will automatically create a link.
Comment 69 GregVD 2015-05-31 13:52:30 EDT
(In reply to Christian Stadelmann from comment #68)
> Have you made sure that you updated your kernel to be at least version
> 4.0.4-301? You can check that by running `uname -a` in any terminal.
> If your bug is gone after updating to this kernel version you ran into
> #1218688.
> 
> PS: If you put a hash character (# ) before the bug ID bugzilla will
> automatically create a link.

Yeah! This is my kernel version 4.0.4-301.fc22.x86_64. Ive always update the recent installed Fedora.

Im thinking the same about this issues and what i see is people with Intel G45 (or identical) integrated graphic card with some specific hardware.

You can read more information in:
#1225248
#1225731

Beside this flickering screen, we have the linear-distorsion in images, buttons and windows with that Intel graphic card.

Actually i solve the problem removing the actual kernel and installing a previous kernel. And i disable the wayland use by default...; i dont like this solution, beacuse i think is a kernel problem, wayland-experimental or xorg-intel-drv ...who knows, maybe all together. And i think is a serious issue.
Comment 70 Bill Gianopoulos 2015-05-31 14:03:57 EDT
(In reply to GregVD from comment #69)
> (In reply to Christian Stadelmann from comment #68)
> > Have you made sure that you updated your kernel to be at least version
> > 4.0.4-301? You can check that by running `uname -a` in any terminal.
> > If your bug is gone after updating to this kernel version you ran into
> > #1218688.
> > 
> > PS: If you put a hash character (# ) before the bug ID bugzilla will
> > automatically create a link.
> 
> Yeah! This is my kernel version 4.0.4-301.fc22.x86_64. Ive always update the
> recent installed Fedora.
> 
> Im thinking the same about this issues and what i see is people with Intel
> G45 (or identical) integrated graphic card with some specific hardware.
> 
> You can read more information in:
> #1225248
> #1225731
> 
> Beside this flickering screen, we have the linear-distorsion in images,
> buttons and windows with that Intel graphic card.
> 
> Actually i solve the problem removing the actual kernel and installing a
> previous kernel. And i disable the wayland use by default...; i dont like
> this solution, beacuse i think is a kernel problem, wayland-experimental or
> xorg-intel-drv ...who knows, maybe all together. And i think is a serious
> issue.

The issue in this bug is specific to the GDM login screen.  That is the only issue that is supposedly resolved.  Plus it is only resolved if you do not use Wayland on any other Applications.  IF you have issues other than flickering on the GDM login screen when that is the only thing using Wayland, then that IS NOT THIS BUG.
Comment 71 Maciej Żenczykowski 2015-06-14 12:11:07 EDT
Fully upgraded F22 system running kernel 4.0.4-303.fc22.x86_64 with i915 graphics is still exhibiting this left-right flicker problem below mouse cursor at the login screen, after logging in, problem is gone.
Comment 72 Christian Stadelmann 2015-07-27 17:11:48 EDT
This issue is fixed for me since several weeks. Since there are no new comments here I think no one else has seen this issue since. Please close.
Comment 73 Fedora Kernel Team 2015-07-27 19:12:43 EDT
Thank you.
Comment 74 Diogo Campos 2015-07-27 19:24:03 EDT
Nope. Thank YOU, kernel team.
That thing was annoying as hell.
S2
Comment 75 Rae Marks 2015-09-12 20:20:53 EDT
Hi everybody, regretfully this problem is showing up for me now. I installed Fedora 22 yesterday, and I did a full update. I'm running Intel graphics as well on the new skylake i5 (6600k).
Comment 76 GregVD 2015-09-13 05:15:23 EDT
Like some people here, this issue is fixed for me a few weeks ago. A new F22  installation must be updated to solve this issues.

Rae could you post here your kernel and xorg versions?

Note You need to log in before you can comment on or make changes to this bug.