Bug 1199992 - Error message for failed content view publishing is localized in Spanish
Summary: Error message for failed content view publishing is localized in Spanish
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule - Content
Version: 6.1.0
Hardware: x86_64
OS: Linux
medium
medium with 1 vote vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1227715 1247183 1273794 (view as bug list)
Depends On:
Blocks: 1122832 sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-03-09 13:21 UTC by Og Maciel
Modified: 2019-08-15 04:20 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 18:24:20 UTC


Attachments (Terms of Use)

Description Og Maciel 2015-03-09 13:21:16 UTC
Description of problem:

While publishing a content view with erratum filter (by date) I had a proxy failure which led to the following error to be displayed in the production log:

==> /var/log/foreman/production.log <==
2015-03-09 09:00:42 [E] ERF12-2749 [ProxyAPI::ProxyException]: No puedo recuperar los entornos para Puppet ([Errno::ECONNREFUSED]: Connection refused - connect(2)) de proxy https://[EDITED]:9090/puppet (ProxyAPI::ProxyException)

The full stacktrace is there but I believe that we want the error to be localized according to the Satellite's default locale (in my case:

LANG=en_US.UTF-8
LC_CTYPE=en_US.UTF-8

Version-Release number of selected component (if applicable):

* Satellite-6.1.0-RHEL-6-20150303.0

How reproducible:


Steps to Reproduce:
1. You'd have to perhaps stop foreman-proxy and attempt to publish a content view
2.
3.

Actual results:

The actual task fails but you would get the error already mentioned in /var/log/foreman/production.log in **Spanish**

Expected results:

The error should be localized according to the system's locale.

Additional info:

Comment 4 Anisha Narang 2015-07-27 11:00:51 UTC
I am facing a similar issue when trying to publish a content view. Checked on SNAP 14.
Error:
ERF12-4115 [ProxyAPI::ProxyException]: Klassen für KT_insights_qNqXuk_Library_new_cv_1605  konnten nicht von Puppet geladen werden ([RestClient::NotAcceptable]: 406 Not Acceptable) für Proxy https://example.com:9090/puppet

Any specific reason for this issue?

Comment 8 Brad Buckingham 2015-10-30 13:10:37 UTC
*** Bug 1247183 has been marked as a duplicate of this bug. ***

Comment 9 Brad Buckingham 2015-10-30 13:11:57 UTC
*** Bug 1227715 has been marked as a duplicate of this bug. ***

Comment 10 Brad Buckingham 2015-10-30 13:12:41 UTC
*** Bug 1273794 has been marked as a duplicate of this bug. ***

Comment 11 Calvin Hartwell 2016-02-19 13:19:34 UTC
Hey all,

Getting this error in a fresh installation of 6.1.7 attempting to publish some content views. Locale is EN/GB and installation is in English, but error is in German:

ERF12-4115 [ProxyAPI::ProxyException]: Klassen für KT_Default_Organization_Library_RHEL7_Rolling_2 konnten nicht von Puppet geladen werden ([RestClient::Forbidden]: 403 Forbidden) für Proxy https://sat.calvinhartwell.com:9090/puppet

Pushed two content views, one with RHEL7 content (Rolling version) and another for Puppet modules (it does not have any modules inside it though). 

Note the Trusted hosts section in /etc/foreman-proxy/settings.yml is already correct (with multiple lines of correct hostname) and I've tried restarting all services (katelloo-service restart) but the issue still exists.

Comment 12 David O'Brien 2016-04-18 00:47:33 UTC
Reset docs contact <> daobrien

Comment 13 Kristof Van Damme 2016-04-22 12:36:38 UTC
+1 Same problem. Any idea when this will be fixed?

Comment 17 Amit Kumar Das 2016-11-17 04:40:34 UTC
Hi Bryan, Is the issue tested in sat6.2? I have a new case (01700858, sat6.1) visiting similar error.
Thanks,
Amit Das

Comment 18 Bryan Kearney 2016-12-19 15:02:01 UTC
Amit, we have not verified this as in or out on 6.2.

Comment 19 Peter Vreman 2016-12-19 16:47:15 UTC
I have had this issue many times with 6.0 and 6.1, but since i run 6.2.x i have not seen this issue anymore. And i still use almost the same process to add and publish content in Sat6.x

Comment 20 Andrew Kofink 2017-01-30 21:07:57 UTC
Still seeing this in 6.1.9, even after the workaround involving the update to the :trusted_hosts: field in /etc/foreman-proxy/settings.yml.

I am having trouble reproducing this in 6.2.7, however.

Comment 21 Bryan Kearney 2017-02-09 18:24:20 UTC
Internal engineers and a trusted customer can not recreate on 6.2. I am going to close this as resolved in 6.2. If you are still seeing this on 6.2 or later, please feel free to re-open with additional information.


Note You need to log in before you can comment on or make changes to this bug.