Bug 1200179 - Discrepancies in the UI showing number of available erratum for a composite content view
Summary: Discrepancies in the UI showing number of available erratum for a composite c...
Keywords:
Status: CLOSED DUPLICATE of bug 1198349
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-03-09 22:35 UTC by Og Maciel
Modified: 2017-02-23 20:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-27 20:10:33 UTC


Attachments (Terms of Use)
Screenshot01.png (141.50 KB, image/png)
2015-03-09 22:36 UTC, Og Maciel
no flags Details
Screenshot02.png (137.52 KB, image/png)
2015-03-09 22:36 UTC, Og Maciel
no flags Details
Screenshot03.png (200.02 KB, image/png)
2015-03-09 22:37 UTC, Og Maciel
no flags Details
Screenshot04.png (201.13 KB, image/png)
2015-03-09 22:37 UTC, Og Maciel
no flags Details
Screenshot05.png (234.60 KB, image/png)
2015-03-09 22:38 UTC, Og Maciel
no flags Details
Screenshot06.png (247.03 KB, image/png)
2015-03-09 22:38 UTC, Og Maciel
no flags Details

Description Og Maciel 2015-03-09 22:35:42 UTC
Description of problem:

The attached Screenshot01.png shows that I have a "RHEL 70 x86_64" content view (version 3) containing 11024 Packages, 494 Errata and 1 Puppet Module.

The attached Screenshot02.png shows that I have a "Tutti" **composite** content view made up of several published content views, including "RHEL 70 x86_64" version 3.

The attached Screenshot03.png shows that "Tutti" has been published and promoted many times, and Version 10.0 shows the correct number of packages and erratum as included in "RHEL 70 x86_64" version 3.

However, once you click on the details for Version 10.0 of "Tutti" and select the "Errata" tab, we now see 7117 erratum available (Screenshot04.png).

If you were to scroll through the erratum listed you would actually only be able to see 494 but the total would still insist that you have 7117 available.

It looks like the total number of erratum may be including other repositories (I have a RHEL 7.1 Kickstart and EPEL 6 synchronized but **not** part of "Tutti") from my organization, for if I visit the Errata page and uncheck the choice boxes for Applicable and Installable, I see 6375 erratum available (see Screenshot05.png; still doesn't match the 7117 number I saw before).

However, if I filter the Errata page for my RHEL 7.0 repo only I see exactly what I expected, 494 (Screenshot06.png).


Version-Release number of selected component (if applicable):

* Satellite-6.1.0-RHEL-6-20150303.0

How reproducible:


Steps to Reproduce:
1. Synchronize RHEL RPMs for 7.0 x86_64 repo
2. Create a custom repo for EPEL 6 and sync it
3. Create a content view and add your RHEL 7.0 repo to it; publish it
4. At this point you don't really have to create a composite content view and add the one you just created to it. Instead, select the latest version of your published content view and click its Errata tab

Actual results:

The number of available erratum does not match what's available in your RHEL 7.0 repository

Expected results:


Additional info:

Comment 1 Og Maciel 2015-03-09 22:36:15 UTC
Created attachment 999689 [details]
Screenshot01.png

Comment 2 Og Maciel 2015-03-09 22:36:38 UTC
Created attachment 999690 [details]
Screenshot02.png

Comment 3 Og Maciel 2015-03-09 22:37:21 UTC
Created attachment 999691 [details]
Screenshot03.png

Comment 4 Og Maciel 2015-03-09 22:37:48 UTC
Created attachment 999692 [details]
Screenshot04.png

Comment 5 Og Maciel 2015-03-09 22:38:14 UTC
Created attachment 999693 [details]
Screenshot05.png

Comment 6 Og Maciel 2015-03-09 22:38:34 UTC
Created attachment 999694 [details]
Screenshot06.png

Comment 8 Og Maciel 2015-03-11 12:32:04 UTC
Just wanted to clarify, as per step (4), that this issue also affects non-composite content views.

Comment 9 Walden Raines 2015-07-27 20:10:33 UTC
This is a duplicate of bugs #1198349, #1222365, #1222673, #1228278, and #1232510.  All counts should now be correct.

*** This bug has been marked as a duplicate of bug 1198349 ***


Note You need to log in before you can comment on or make changes to this bug.