Bug 1198349 - Errata filters showing incorrect count
Summary: Errata filters showing incorrect count
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: sthirugn@redhat.com
David O'Brien
URL:
Whiteboard: rails-3.2.8
: 1200179 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker 1130651 sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-03-03 20:51 UTC by sthirugn@redhat.com
Modified: 2017-02-23 20:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 16:04:02 UTC


Attachments (Terms of Use)
Errata filters showing incorrect value (155.35 KB, image/png)
2015-03-03 20:51 UTC, sthirugn@redhat.com
no flags Details

Description sthirugn@redhat.com 2015-03-03 20:51:21 UTC
Description of problem:
Errata filters showing incorrect count

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150224.0

How reproducible:
Always

Steps to Reproduce:
1. Create multiple products, repos with errata in them
2. Go to Errata page
3. Check Applicable and Installable. Make sure to have 'All Repositories' in dropdown page.

Actual results:
See screenshot:
Showing 42 of 43 (43 Total)
and I selected all errata - it says 42 selected.

Expected results:
Showing 42 of 42 (42 Total)

Additional info:

Comment 1 sthirugn@redhat.com 2015-03-03 20:51:44 UTC
Created attachment 997665 [details]
Errata filters showing incorrect value

Comment 3 Walden Raines 2015-03-13 14:42:27 UTC
Created redmine issue http://projects.theforeman.org/issues/9747 from this bug

Comment 4 Walden Raines 2015-04-02 19:50:45 UTC
Rewriting all of the pages in the errata incremental update flow to support true select all functionality (because the controllers used don't support the bulk action style of params) is likely too much risk for a 6.1 release.  I propose that we push this fix to 6.1.1 or later.

Thoughts?

Comment 5 sthirugn@redhat.com 2015-04-09 17:37:47 UTC
(In reply to Walden Raines from comment #4)
> Rewriting all of the pages in the errata incremental update flow to support
> true select all functionality (because the controllers used don't support
> the bulk action style of params) is likely too much risk for a 6.1 release. 
> I propose that we push this fix to 6.1.1 or later.
> 
> Thoughts?

Agreed with Walden's inputs.  Removed 6.1.0 flag.

Comment 6 Walden Raines 2015-06-17 19:51:05 UTC
This only happens downstream so removing linked redmine issue.

Comment 8 Walden Raines 2015-06-19 13:14:12 UTC
Merged downstream 400fe2b732a554fe0139aaa0856128882fa33add.

Comment 9 Bryan Kearney 2015-06-26 14:32:18 UTC
Delivered in Snap10

Comment 10 sthirugn@redhat.com 2015-07-07 16:33:25 UTC
Verified in GA Snap 11.  (Screenshot attached)

Comment 12 Walden Raines 2015-07-27 20:10:33 UTC
*** Bug 1200179 has been marked as a duplicate of this bug. ***

Comment 13 Bryan Kearney 2015-08-12 16:04:02 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.