Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1200265 - NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related commands are executed and other additonal checks
Summary: NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related command...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jiffin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1188184 1217793
TreeView+ depends on / blocked
 
Reported: 2015-03-10 07:28 UTC by Meghana
Modified: 2016-06-16 12:43 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1217793 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:43:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Meghana 2015-03-10 07:28:10 UTC
Description of problem:

When NFS-Ganesha is enabled on a GlusterFS node, some default behaviour
of GlusterFS CLI commands need to be changed. Attempt to start Gluster-nfs 
when NFS-Ganesha is enabled should be stopped.

Comment 1 Jiffin 2015-03-12 09:21:54 UTC
It is a suggestion. Can you consider renaming `volume set ganesha.enable <volume_name>` to something more meaningful like volume set ganesha.export <volume_name>` , since it will export that volume through nfs-ganesha while setting this option. And it is also similar with global option features.ganesha , sounds confusing for me.

Comment 2 Anand Avati 2015-04-17 07:31:06 UTC
REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 3 Anand Avati 2015-04-17 07:39:48 UTC
REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 4 Anand Avati 2015-04-22 06:32:40 UTC
REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 5 Anand Avati 2015-04-23 06:15:03 UTC
REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#4) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 6 Anand Avati 2015-04-23 06:18:20 UTC
REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#5) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 7 Anand Avati 2015-04-29 10:48:18 UTC
REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#6) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 8 Anand Avati 2015-04-30 07:33:34 UTC
REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling CLI commands when NFS-Ganesha keys are set) posted (#7) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 9 Anand Avati 2015-04-30 10:30:05 UTC
COMMIT: http://review.gluster.org/10283 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 288e02853d913b96e4d6bce9afb16da7d891546f
Author: Meghana Madhusudhan <mmadhusu@redhat.com>
Date:   Fri Apr 17 10:56:57 2015 +0530

    NFS-Ganesha: Handling CLI commands when NFS-Ganesha keys are set
    
    When ganesha.enable is set to on and features.ganesha is
    enabled, there are a few behaviour changes that should
    be seen in other volume operations.
    
    1. ganesha.enable can be set to 'on' only
    when features.ganesha is set to 'enable'
    
    2.When gluster vol is started, and if ganesha.enable
    key was set to 'on', it should automatically export the volume
    via NFS-Ganesha.
    
    3.When ganesha.enable is set to 'on', and a volume
    is stopped, that volume should be unexported via NFS-Ganesha.
    
    4. gluster vol reset <volname>
    If ganesha.enable was set to on, then unexport the
    volume via NFS-Ganesha.
    
    5. gluster vol reset all
    If features.ganesha is set to enable, as part
    of reset all, set it to disable. This translates
    to teardown cluster.
    
    All the above problems are fixed by checking the global key
    and value, depending on the value, specific functions are called.
    And also, functions related to global commands
    are moved to cli-cmd-global.c
    
    Commit phase of features.ganesha enable/disable
    runs the ganesha-ha.sh setup/teardown respectively.
    Before the script begins, it is important that the
    NFS-Ganesha service starts on all the HA nodes.
    Having the start service commands in the
    commit phase could lead to problems.
    Moving the pre-requisite service start
    commands to the 'stage' phase.
    
    Change-Id: I5a256f94f8e1310ddcd5369f329b7168b2a24c47
    BUG: 1200265
    Signed-off-by: Meghana Madhusudhan <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/10283
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 12 Nagaprasad Sathyanarayana 2015-10-25 15:00:38 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 13 Niels de Vos 2016-06-16 12:43:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.