Bug 1217793 - NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related commands are executed and other additonal checks
Summary: NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related command...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ganesha-nfs
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Meghana
QA Contact:
URL:
Whiteboard:
: 1213821 (view as bug list)
Depends On: 1200265 1202637
Blocks: 1188184
TreeView+ depends on / blocked
 
Reported: 2015-05-01 17:16 UTC by Meghana
Modified: 2015-10-29 13:27 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1200265
Environment:
Last Closed: 2015-05-14 17:29:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Meghana 2015-05-01 17:16:29 UTC
+++ This bug was initially created as a clone of Bug #1200265 +++

Description of problem:

When NFS-Ganesha is enabled on a GlusterFS node, some default behaviour
of GlusterFS CLI commands need to be changed. Attempt to start Gluster-nfs 
when NFS-Ganesha is enabled should be stopped.

--- Additional comment from Jiffin on 2015-03-12 05:21:54 EDT ---

It is a suggestion. Can you consider renaming `volume set ganesha.enable <volume_name>` to something more meaningful like volume set ganesha.export <volume_name>` , since it will export that volume through nfs-ganesha while setting this option. And it is also similar with global option features.ganesha , sounds confusing for me.

--- Additional comment from Anand Avati on 2015-04-17 03:31:06 EDT ---

REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)

--- Additional comment from Anand Avati on 2015-04-17 03:39:48 EDT ---

REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)

--- Additional comment from Anand Avati on 2015-04-22 02:32:40 EDT ---

REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)

--- Additional comment from Anand Avati on 2015-04-23 02:15:03 EDT ---

REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#4) for review on master by Meghana M (mmadhusu@redhat.com)

--- Additional comment from Anand Avati on 2015-04-23 02:18:20 EDT ---

REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#5) for review on master by Meghana M (mmadhusu@redhat.com)

--- Additional comment from Anand Avati on 2015-04-29 06:48:18 EDT ---

REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling GlusterFS CLI commands when NFS-Ganesha related keys are set.) posted (#6) for review on master by Meghana M (mmadhusu@redhat.com)

--- Additional comment from Anand Avati on 2015-04-30 03:33:34 EDT ---

REVIEW: http://review.gluster.org/10283 (NFS-Ganesha: Handling CLI commands when NFS-Ganesha keys are set) posted (#7) for review on master by Meghana M (mmadhusu@redhat.com)

--- Additional comment from Anand Avati on 2015-04-30 06:30:05 EDT ---

COMMIT: http://review.gluster.org/10283 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 288e02853d913b96e4d6bce9afb16da7d891546f
Author: Meghana Madhusudhan <mmadhusu@redhat.com>
Date:   Fri Apr 17 10:56:57 2015 +0530

    NFS-Ganesha: Handling CLI commands when NFS-Ganesha keys are set
    
    When ganesha.enable is set to on and features.ganesha is
    enabled, there are a few behaviour changes that should
    be seen in other volume operations.
    
    1. ganesha.enable can be set to 'on' only
    when features.ganesha is set to 'enable'
    
    2.When gluster vol is started, and if ganesha.enable
    key was set to 'on', it should automatically export the volume
    via NFS-Ganesha.
    
    3.When ganesha.enable is set to 'on', and a volume
    is stopped, that volume should be unexported via NFS-Ganesha.
    
    4. gluster vol reset <volname>
    If ganesha.enable was set to on, then unexport the
    volume via NFS-Ganesha.
    
    5. gluster vol reset all
    If features.ganesha is set to enable, as part
    of reset all, set it to disable. This translates
    to teardown cluster.
    
    All the above problems are fixed by checking the global key
    and value, depending on the value, specific functions are called.
    And also, functions related to global commands
    are moved to cli-cmd-global.c
    
    Commit phase of features.ganesha enable/disable
    runs the ganesha-ha.sh setup/teardown respectively.
    Before the script begins, it is important that the
    NFS-Ganesha service starts on all the HA nodes.
    Having the start service commands in the
    commit phase could lead to problems.
    Moving the pre-requisite service start
    commands to the 'stage' phase.
    
    Change-Id: I5a256f94f8e1310ddcd5369f329b7168b2a24c47
    BUG: 1200265
    Signed-off-by: Meghana Madhusudhan <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/10283
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 1 Anand Avati 2015-05-01 17:21:25 UTC
REVIEW: http://review.gluster.org/10489 (NFS-Ganesha: Handling CLI commands when NFS-Ganesha keys are set) posted (#1) for review on release-3.7 by Meghana M (mmadhusu@redhat.com)

Comment 2 Anand Avati 2015-05-03 11:34:48 UTC
COMMIT: http://review.gluster.org/10489 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit c976b59bc4c34ed26bc3f5d9b78356600d8f1d47
Author: Meghana Madhusudhan <mmadhusu@redhat.com>
Date:   Fri Apr 17 10:56:57 2015 +0530

    NFS-Ganesha: Handling CLI commands when NFS-Ganesha keys are set
    
    When ganesha.enable is set to on and features.ganesha is
    enabled, there are a few behaviour changes that should
    be seen in other volume operations.
    
    1. ganesha.enable can be set to 'on' only
    when features.ganesha is set to 'enable'
    
    2.When gluster vol is started, and if ganesha.enable
    key was set to 'on', it should automatically export the volume
    via NFS-Ganesha.
    
    3.When ganesha.enable is set to 'on', and a volume
    is stopped, that volume should be unexported via NFS-Ganesha.
    
    4. gluster vol reset <volname>
    If ganesha.enable was set to on, then unexport the
    volume via NFS-Ganesha.
    
    5. gluster vol reset all
    If features.ganesha is set to enable, as part
    of reset all, set it to disable. This translates
    to teardown cluster.
    
    All the above problems are fixed by checking the global key
    and value, depending on the value, specific functions are called.
    And also, functions related to global commands
    are moved to cli-cmd-global.c
    
    Commit phase of features.ganesha enable/disable
    runs the ganesha-ha.sh setup/teardown respectively.
    Before the script begins, it is important that the
    NFS-Ganesha service starts on all the HA nodes.
    Having the start service commands in the
    commit phase could lead to problems.
    Moving the pre-requisite service start
    commands to the 'stage' phase.
    
    Change-Id: I9084d004c0aaf960f59ed8aa2d7f1c9309924658
    BUG: 1217793
    Signed-off-by: Meghana Madhusudhan <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/10489
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: NetBSD Build System
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Meghana 2015-05-05 06:19:36 UTC
Merged on release 3.7,

http://review.gluster.org/#/c/10489/

Comment 4 Niels de Vos 2015-05-14 17:29:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:35:58 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:38:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:47:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-10-29 13:27:03 UTC
*** Bug 1213821 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.