Bug 12008 - Long wait with empty blue screen: what's happening?
Long wait with empty blue screen: what's happening?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
: FutureFeature
: 12073 12077 12158 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-08 23:21 EDT by Brent Nordquist
Modified: 2007-04-18 12:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-13 16:49:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brent Nordquist 2000-06-08 23:21:35 EDT
In both graphical and text mode installs, there's a blue text-mode screen 
at the beginning that says "Welcome to RedHat Linux".  Then there is a long 
pause while the CD and disk are active.  (Presumably we're searching for 
drivers at this point, because I see a dialog briefly "Loading aic7xxx 
driver".)

On systems with slower CD drives, this could be quite a wait with a blank 
screen, which is a little unsettling.  How about a dialog "Searching for 
drivers" or something during this time?
Comment 1 Gene Czarcinski 2000-06-09 04:37:26 EDT
On a Compaq DeskPro PII 450MHz with 96MB memory and installing in text mode, I
got even longer waits.  Changing to the F3 screen showed a number of "error"
messages when loading drivers which indicated "null path" accessing the modules.

Although the system did finally install, these was an extremely long delay as
compared to previous versions of the installer.

Gene
Comment 2 Brock Organ 2000-06-09 11:49:06 EDT
after the waits, does the install continue without harm, and finish
successfully...?
Comment 3 Brent Nordquist 2000-06-10 00:29:36 EDT
Yes, it got past that point for me.  That's why I submitted this as
"enhancement"; just an idea to let users know what's going on during the long
delay.
Comment 4 Hans de Goede 2000-06-12 14:03:40 EDT
I have a K7-650 with 128 megs of memory and an 16x scsi cdrom on an adaptec 2920
and the above described blue screen seems to take forever, at least a message
and preferrable a fix would be mucb appreciated.
Comment 5 Dale Lovelace 2000-06-12 17:18:13 EDT
*** Bug 12158 has been marked as a duplicate of this bug. ***
Comment 6 Dale Lovelace 2000-06-12 17:18:54 EDT
*** Bug 12073 has been marked as a duplicate of this bug. ***
Comment 7 Dale Lovelace 2000-06-12 17:19:46 EDT
*** Bug 12077 has been marked as a duplicate of this bug. ***
Comment 8 Gene Czarcinski 2000-06-26 03:51:45 EDT
Please update for beta2 ... still true.
Comment 9 Brent Nordquist 2000-07-11 00:16:32 EDT
Erik Troan posted a new boot.img for Beta-3 tonight, and I'm happy to report
that the blue screen delay went from 2 minutes to 20 seconds on my system.  He's
also added an "anaconda loading, may take a while" kind of message; anaconda and
X load much more quickly now.

I'll let someone else close this, if it's felt that the new faster process
precludes the need for a dialog or progress bar... I'd still like to see one,
though, rather than a blank blue screen, no matter how short.

Note You need to log in before you can comment on or make changes to this bug.