Bug 12014 - XFree86-4 doesn't use Xwrapper and XFree86 not suid
Summary: XFree86-4 doesn't use Xwrapper and XFree86 not suid
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
: 12024 12134 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-09 05:35 UTC by Jeremy Katz
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-02 00:59:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2000-06-09 05:35:18 UTC
XFree86 4.0 does not yet use Xwrapper and the XFree86 binary is not
installed suid root.  Therefore, X can't be started by a normal user from
the console via startx.

Comment 1 Jeremy Katz 2000-06-09 14:29:34 UTC
Note that this first causes the error about not being able to write the log file
in /var/log, but even if you make that writable, you still need to suid X so
that it can open the console

Comment 2 Jeremy Katz 2000-06-09 14:29:42 UTC
*** Bug 12024 has been marked as a duplicate of this bug. ***

Comment 3 Hans de Goede 2000-06-12 18:09:49 UTC
I would like to add my vote to the return of Xwrapper, XF 40 works fine with it
just set /etc/X11/X to point to /usr/X11R6/bin/XFree86, and it is a must for the
3.3 servers.



Comment 4 Jeremy Katz 2000-06-13 01:13:17 UTC
*** Bug 12134 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2000-06-22 03:39:11 UTC
confirmed in beta2

Comment 6 Hans de Goede 2000-07-02 00:59:23 UTC
This bugs seems almost fixed in the just released 0.29 snapshot of Xfree:
XFree86-4.0-0.29

There is an correctly installed xwrapper now, but XFree86 itself also is suid
root (bad !) and the 3.3 servers like XF86_SVGA have standard permissions, while
they should be exute only (no read) by group and other, for safety reasons.


Comment 7 Bill Nottingham 2000-07-03 05:30:10 UTC
This should be fixed in 0.30; fully functional Xwrapper should be included.


Note You need to log in before you can comment on or make changes to this bug.