Bug 120215 - gpdf dies when starting (due to many implicit dependencies)
Summary: gpdf dies when starting (due to many implicit dependencies)
Status: CLOSED DUPLICATE of bug 117743
Alias: None
Product: Fedora
Classification: Fedora
Component: gpdf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-06 20:54 UTC by Pawel Salek
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
att-c.pdf (31.76 KB, application/pdf)
2004-04-18 16:53 UTC, Pawel Salek
no flags Details

Description Pawel Salek 2004-04-06 20:54:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
gpdf spits out plenty of warnings and does nothing.


Version-Release number of selected component (if applicable):
gpdf-0.131-1

How reproducible:
Always

Steps to Reproduce:
1. gpdf file.pdf on a minimal-install + gpdf.
    

Actual Results:  gpdf lecture-9.pdf 

(gpdf:12520): Gtk-WARNING **: Could not find the icon
'gnome-fs-regular'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://freedesktop.org/Software/icon-theme/releases

(gpdf:12520): GdkPixbuf-CRITICAL **: file gdk-pixbuf-io.c: line 761
(gdk_pixbuf_new_from_file): assertion `filename != NULL' failed

(gpdf:12520): GdkPixbuf-CRITICAL **: file gdk-pixbuf-io.c: line 761
(gdk_pixbuf_new_from_file): assertion `filename != NULL' failed

(gpdf:12520): GdkPixbuf-CRITICAL **: file gdk-pixbuf-io.c: line 761
(gdk_pixbuf_new_from_file): assertion `filename != NULL' failed

(gpdf:12520): GdkPixbuf-CRITICAL **: file gdk-pixbuf-io.c: line 761
(gdk_pixbuf_new_from_file): assertion `filename != NULL' failed

(gpdf:12520): GdkPixbuf-CRITICAL **: file gdk-pixbuf-io.c: line 761
(gdk_pixbuf_new_from_file): assertion `filename != NULL' failed

(gpdf:12520): GdkPixbuf-CRITICAL **: file gdk-pixbuf-io.c: line 761
(gdk_pixbuf_new_from_file): assertion `filename != NULL' failed

(gpdf:12520): GdkPixbuf-CRITICAL **: file gdk-pixbuf-io.c: line 761
(gdk_pixbuf_new_from_file): assertion `filename != NULL' failed
(gpdf:12520): Bonobo-CRITICAL **: file bonobo-widget.c: line 325
(bonobo_widget_get_control_frame): assertion `BONOBO_IS_WIDGET
(bonobo_widget)' failed

(gpdf:12520): Bonobo-CRITICAL **: file bonobo-control-frame.c: line
571 (bonobo_control_frame_set_autoactivate): assertion
`BONOBO_IS_CONTROL_FRAME (frame)' failed

(gpdf:12520): Bonobo-CRITICAL **: file bonobo-widget.c: line 325
(bonobo_widget_get_control_frame): assertion `BONOBO_IS_WIDGET
(bonobo_widget)' failed

(gpdf:12520): Bonobo-CRITICAL **: file bonobo-control-frame.c: line
533 (bonobo_control_frame_control_deactivate): assertion
`BONOBO_IS_CONTROL_FRAME (frame)' failed
[

Expected Results:  gpdf should promptly display the file.

Additional info:

Now, time for my opinion: Personally, I find it very strange that such
a simple package like gpdf has so many implicit and explicit
dependencies that make it extremely fragile. One might think that
providing an UI for a rendering code borrowed from xpdf should be a
trivial task to do. Would it not be best to have rather a minimal UI
to reduce the startup time, etc? Preloading every possible application
on the system and waking it up through bonobo is not the answer. I
think gtk + libgnomeprint should be sufficient for the job.
 I should say I am willing to provide a patch that removes some of
these dependencies if anybody upstream is interested.

Comment 1 Pawel Salek 2004-04-16 16:09:39 UTC
Alex, did you miss the "does nothing" phrase when changing the
severity? gpdf is _completely_ useless as is. Warnings are just the
icing on the cake.

Comment 2 Warren Togami 2004-04-18 14:00:09 UTC
Pawel, I do not see any gpdf failures anything like this.  Are you
using latest rawhide for all packages?

Is your gpdf problem any similar to Bug #117743 or Bug #118400 by chance?

Comment 3 Pawel Salek 2004-04-18 16:53:30 UTC
Created attachment 99516 [details]
att-c.pdf

This attachment cannot be displayed with up-to-date FC2t2+developement on my
computer.

Comment 4 Warren Togami 2004-04-18 17:01:22 UTC
Your attached PDF causes 100% CPU usage in gnome-pdf-viewer, which
seems to be fixed by the eexec patch for freetype in Bug #117743.  It
works fine for me after that patch.

*** This bug has been marked as a duplicate of 117743 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:02:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.