Bug 120233 - gpdf fails to open documents
gpdf fails to open documents
Status: CLOSED DUPLICATE of bug 117743
Product: Fedora
Classification: Fedora
Component: gpdf (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Alexander Larsson
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
Reported: 2004-04-06 19:58 EDT by Scott Sloan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
strace of gpf failing (818.75 KB, text/plain)
2004-04-06 20:02 EDT, Scott Sloan
no flags Details

  None (edit)
Description Scott Sloan 2004-04-06 19:58:09 EDT
Description of problem:

gpdf fails to open documents sometimes.

[scott@localhost scott]$ gpdf /stor/Library/Physics/Richard\ Feynman\
-\ Lecture s\ on\ Physics.pdf
(gpdf:877): Bonobo-CRITICAL **: file bonobo-control-frame.c: line 503
(bonobo_co ntrol_frame_control_activate): assertion
`frame->priv->control != CORBA_OBJECT_N IL' failed
** (gpdf:877): WARNING **: Property bag access exception 'Unknown
CORBA exceptio n id: 'IDL:omg.org/CORBA/INV_OBJREF:1.0''
(gpdf:877): Bonobo-CRITICAL **: file bonobo-control-frame.c: line 539
(bonobo_co ntrol_frame_control_deactivate): assertion
`frame->priv->control != CORBA_OBJECT _NIL' failed

[scott@localhost scott]$ rpm -q gpdf
Comment 1 Scott Sloan 2004-04-06 20:02:46 EDT
Created attachment 99169 [details]
strace of gpf failing
Comment 2 Scott Sloan 2004-04-08 01:45:30 EDT
Upon further investigation, this only happens with encrypted pdf files. 
Comment 3 Scott Sloan 2004-04-08 01:48:25 EDT
Never mind I take that back. This just seems to happens on some pdf's
and not others :)
Comment 4 Derek Tattersall 2004-04-08 14:10:54 EDT
On a .pdf file which xpdf describes as having an invalid header, gpdf
flashes an error message to quickly to read, and almost too quickly to
recognize that an error has occurred.  
Comment 5 Warren Togami 2004-04-18 10:01:36 EDT
Please provide URL to a PDF that causes your problem.

Is your gpdf problem any similar to Bug #117743 or Bug #118400 by chance?
Comment 6 Scott Sloan 2004-04-18 14:32:52 EDT

*** This bug has been marked as a duplicate of 117743 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:02:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.