Bug 120529 - mod_perl 1.99_16 is released
mod_perl 1.99_16 is released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
http://perl.apache.org/dist/mod_perl-...
:
Depends On:
Blocks: 130582
  Show dependency treegraph
 
Reported: 2004-04-09 17:08 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.99_16-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 14:05:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
filter-requires.sh (253 bytes, patch)
2004-08-12 11:13 EDT, Robert Scheck
no flags Details | Diff
filter-requires.sh (284 bytes, patch)
2004-08-23 13:46 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2004-04-09 17:08:18 EDT
Description of problem:
mod_perl 1.99_13 was released on March 8, 2004 and contains lots of 
fixes as well as new features, more you can read in the changelog:
http://perl.apache.org/dist/mod_perl-2.0-current/Changes

Version-Release number of selected component (if applicable):
mod_perl-1.99_12-2.1

Actual results:
No big changes in the spec file are necessary.

Expected results:
Please upgrade to 1.99_13, thank you :-)
Comment 1 Robert Scheck 2004-06-15 05:20:24 EDT
mod_perl 1.99_14 was released on May 21, 2004 and contains lots of
fixes as well as new features, more you can read in the changelog:
http://perl.apache.org/dist/mod_perl-2.0-current/Changes

mod_perl 1.99_14 has new (unsolved?) dependencies after building, 
which _13 hadn't:

Error: Failed dependencies:
        perl(Carp::Heavy) is needed by mod_perl-1.99_14-1
        perl(Data::Flow) is needed by mod_perl-1.99_14-1
Comment 2 Robert Scheck 2004-08-12 11:13:13 EDT
Created attachment 102650 [details]
filter-requires.sh

Okay, I think the upgrade to mod_perl-1.99_14 can be done, because the original
missing dependency to 'perl(Carp::Heavy)' is resolved in bug #128507 and bug
#129748.

The missing dependency to 'perl(Data::Flow)' can simply bounced out (as
Mandrake also already did it at it's mod_perl package (2.0.49_1.99_14-2mdk;
rgarciasuarez@mandrakesoft.com)).

I adapted the original 'filter-requires.sh' and attached it here.
Comment 3 Robert Scheck 2004-08-23 13:46:14 EDT
Created attachment 102992 [details]
filter-requires.sh

mod_perl 1.99_16 was released on August 22, 2004 and contains lots of fixes as
well as new features, more you can read in the changelog:
http://perl.apache.org/dist/mod_perl-2.0-current/Changes

"Prereq: perl >= 5.6.1" should be set, because in the changelog this is
recommented to avoid possible errors and problems.

Oh and I had to remove a new requirement to perl(Module::Build), which isn't
seems not to be really needed. A new filter-requires.sh is attached for this.

FYI: "Module::Build is a system for building, testing, and installing Perl
modules. It is meant to be an alternative to ExtUtils::MakeMaker".

Last but not least: The upgrade from mod_perl 1.99_14 (with my applied changes)
to _16 worked fine, here.
Comment 4 Robert Scheck 2004-10-04 14:05:23 EDT
Thank you, that you did at long last the update now, I reported a half 
year ago, already...

mod_perl-1.99_16-3 was pushed to Fedora Core Development, yesterday - 
closing now.

Note You need to log in before you can comment on or make changes to this bug.