Bug 1205641 - [RFE][HC] - Monitor if self-heal is ongoing on a gluster volume [NEEDINFO]
Summary: [RFE][HC] - Monitor if self-heal is ongoing on a gluster volume
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
urgent
medium vote
Target Milestone: ovirt-4.0.0-beta
: 4.0.0
Assignee: Ramesh N
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On: 1313370
Blocks: Generic_Hyper_Converged_Host 1196433 1196438 Gluster-HC-2 1316692
TreeView+ depends on / blocked
 
Reported: 2015-03-25 11:26 UTC by Sahina Bose
Modified: 2016-08-21 23:04 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this enhancement, the Manager monitors any unsynced entries in all Gluster replicated volumes. Unsynced entries are shown in the bricks subtab with the expected time to heal the entries. There will be a warning icon in the volume and the bricks status column when there is an unsynced entry.
Clone Of:
Environment:
Last Closed: 2016-08-17 14:37:43 UTC
oVirt Team: Gluster
knarra: needinfo? (rnachimu)
rule-engine: ovirt-4.0.0+
bmcclain: planning_ack+
sabose: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 42720 master ABANDONED WIP:gluster: new verb to provide gluster self-heal info. 2016-01-31 01:55:13 UTC
oVirt gerrit 56738 None None None 2016-05-12 12:37:45 UTC
oVirt gerrit 57075 master MERGED gluster: entity changes for self heal monitoring 2016-05-17 11:47:07 UTC
oVirt gerrit 57076 master MERGED gluster: add VDS Command for glusterVolumeHealInfo 2016-05-17 11:54:01 UTC
oVirt gerrit 57077 master MERGED gluster: sync gluster heal info periodically. 2016-05-18 05:59:19 UTC
oVirt gerrit 57078 master MERGED webadmin: Add Self Heal information to volumes and bricks tab 2016-05-18 06:38:39 UTC

Description Sahina Bose 2015-03-25 11:26:28 UTC
Description of problem:

For a replicate volume, the engine should monitor if self-heal is ongoing on a volume. There should be an indication in the UI for self-heal activity.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
NA

Actual results:


Expected results:


Additional info:
"volume heal statistics" can be used to monitor this

Comment 1 Doron Fediuck 2015-04-26 14:08:57 UTC
This should also allow the engine to prevent moving a host to maintenance while
self-heal / rebalance is in progress.

Comment 2 Red Hat Bugzilla Rules Engine 2015-10-19 11:03:30 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 3 Sandro Bonazzola 2016-05-02 09:51:34 UTC
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Comment 4 RamaKasturi 2016-08-10 12:29:45 UTC
cannot verify this bug until the below two bugs are fixed.

https://bugzilla.redhat.com/show_bug.cgi?id=1365605

https://bugzilla.redhat.com/show_bug.cgi?id=1365604

@Ramesh, can you please let us know when can we get these above bugs fixed ?

Comment 5 RamaKasturi 2016-08-17 11:06:14 UTC
Verified and works fine with build ovirt-engine-4.0.2.6-0.1.el7ev.noarch

1) When a volume is created Self-Heal Info column displays "N/A" for first 10 minutes since self-heal info sync frequency is 10 minutes.

2) If there are more than two unsynced_entries_history is present and if heal is going on then Expected time for heal will be displayed in the Self-Heal Info column. 

5)Brought one of the brick down , no I/O running on the volume and no heal happening, then no.of unsynced entries is displayed in the Self-Heal column.

5) Self-Heal Info column shows "N/A" when one of the brick is down in the volume.

6) Replaced a brick from UI which is down and replace happened successfully.

7) An exclamation mark is displayed on the status column of volume and on the bricks when there are unsynced entries present. Mouse hovering on that displays status of brick , with no.of unsynced entries present.

For volume mouse hovering does not display any tool tip and a bug is logged for the same. https://bugzilla.redhat.com/show_bug.cgi?id=1365604


Note You need to log in before you can comment on or make changes to this bug.